diff mbox series

[meta-multimedia] musicpd: unbreak build with ffmpeg 6.1

Message ID 20231120165324.2214368-1-f_l_k@t-online.de
State New
Headers show
Series [meta-multimedia] musicpd: unbreak build with ffmpeg 6.1 | expand

Commit Message

Markus Volk Nov. 20, 2023, 4:53 p.m. UTC
Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 ...tch-src_decoder_plugins_FfmpegIo.cxx.patch | 26 +++++++++++++++++++
 .../recipes-multimedia/musicpd/mpd_0.23.12.bb |  1 +
 2 files changed, 27 insertions(+)
 create mode 100644 meta-multimedia/recipes-multimedia/musicpd/mpd/0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch

Comments

Khem Raj Nov. 20, 2023, 5:34 p.m. UTC | #1
its upgraded to 0.23.14 on master, so please rebase on latest master
and send again.

On Mon, Nov 20, 2023 at 8:53 AM Markus Volk <f_l_k@t-online.de> wrote:
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  ...tch-src_decoder_plugins_FfmpegIo.cxx.patch | 26 +++++++++++++++++++
>  .../recipes-multimedia/musicpd/mpd_0.23.12.bb |  1 +
>  2 files changed, 27 insertions(+)
>  create mode 100644 meta-multimedia/recipes-multimedia/musicpd/mpd/0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch
>
> diff --git a/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch b/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch
> new file mode 100644
> index 000000000..b2dea331e
> --- /dev/null
> +++ b/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch
> @@ -0,0 +1,26 @@
> +From e62fd0eefe8b475e70d87a673a7216aac3bb622f Mon Sep 17 00:00:00 2001
> +From: Markus Volk <f_l_k@t-online.de>
> +Date: Mon, 20 Nov 2023 17:49:59 +0100
> +Subject: [PATCH] patch src_decoder_plugins_FfmpegIo.cxx
> +
> +Signed-off-by: Markus Volk <f_l_k@t-online.de>
> +Upstream-Status: Pending [https://github.com/MusicPlayerDaemon/MPD/issues/1898]
> +---
> + src/decoder/plugins/FfmpegIo.cxx | 1 +
> + 1 file changed, 1 insertion(+)
> +
> +diff --git a/src/decoder/plugins/FfmpegIo.cxx b/src/decoder/plugins/FfmpegIo.cxx
> +index 572f1a86a..3e2347fec 100644
> +--- a/src/decoder/plugins/FfmpegIo.cxx
> ++++ b/src/decoder/plugins/FfmpegIo.cxx
> +@@ -25,6 +25,7 @@
> + #include "input/InputStream.hxx"
> +
> + extern "C" {
> ++#include <libavutil/error.h>
> + #include <libavutil/mem.h>
> + }
> +
> +--
> +2.42.0
> +
> diff --git a/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb b/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb
> index 0c309ded0..4e9cb9090 100644
> --- a/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb
> +++ b/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb
> @@ -23,6 +23,7 @@ SRC_URI = "git://github.com/MusicPlayerDaemon/MPD;branch=master;protocol=https \
>             file://minor-fixup-for-libfmt10.patch \
>             file://fix-build-error-when-fmt-updated.patch \
>             file://0001-SndfileDecoderPlugin-Fix-type-mismatch-for-std-span.patch \
> +           file://0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch \
>             "
>  SRCREV = "b1422fbda40a1831d397fb161e7a555443c2a072"
>  S = "${WORKDIR}/git"
> --
> 2.42.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#106963): https://lists.openembedded.org/g/openembedded-devel/message/106963
> Mute This Topic: https://lists.openembedded.org/mt/102710978/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch b/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch
new file mode 100644
index 000000000..b2dea331e
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch
@@ -0,0 +1,26 @@ 
+From e62fd0eefe8b475e70d87a673a7216aac3bb622f Mon Sep 17 00:00:00 2001
+From: Markus Volk <f_l_k@t-online.de>
+Date: Mon, 20 Nov 2023 17:49:59 +0100
+Subject: [PATCH] patch src_decoder_plugins_FfmpegIo.cxx
+
+Signed-off-by: Markus Volk <f_l_k@t-online.de>
+Upstream-Status: Pending [https://github.com/MusicPlayerDaemon/MPD/issues/1898]
+---
+ src/decoder/plugins/FfmpegIo.cxx | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/decoder/plugins/FfmpegIo.cxx b/src/decoder/plugins/FfmpegIo.cxx
+index 572f1a86a..3e2347fec 100644
+--- a/src/decoder/plugins/FfmpegIo.cxx
++++ b/src/decoder/plugins/FfmpegIo.cxx
+@@ -25,6 +25,7 @@
+ #include "input/InputStream.hxx"
+ 
+ extern "C" {
++#include <libavutil/error.h>
+ #include <libavutil/mem.h>
+ }
+ 
+-- 
+2.42.0
+
diff --git a/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb b/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb
index 0c309ded0..4e9cb9090 100644
--- a/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb
+++ b/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb
@@ -23,6 +23,7 @@  SRC_URI = "git://github.com/MusicPlayerDaemon/MPD;branch=master;protocol=https \
            file://minor-fixup-for-libfmt10.patch \
            file://fix-build-error-when-fmt-updated.patch \
            file://0001-SndfileDecoderPlugin-Fix-type-mismatch-for-std-span.patch \
+           file://0001-patch-src_decoder_plugins_FfmpegIo.cxx.patch \
            "
 SRCREV = "b1422fbda40a1831d397fb161e7a555443c2a072"
 S = "${WORKDIR}/git"