diff mbox series

[meta-oe,1/2] libplist: Upgrade to latest master

Message ID 20231120072416.2556340-2-potin.lai.pt@gmail.com
State Accepted
Headers show
Series Upgrade idevicerestore and libplist to latest master | expand

Commit Message

Potin Lai Nov. 20, 2023, 7:24 a.m. UTC
Upgrade to latest master.

2cd858c test: use unique output file names across tests
d45396a Prevent adding NULL items to array/dictionary nodes
2d8d7ef Plug memory leak in plist_write_to_stream()
f28cf0f Add explicit casts and fix return type mismatches
d772fd7 Add an explicit PLIST_FORMAT_NONE value
50255a2 autoconf: Remove unused function checks and fix constructor/destructor attribute check
21a432b bplist: Move realloc from parse_unicode_node() into plist_utf16be_to_utf8()
b7d7459 Make sure function signatures match their declarations in the public header
ff00100 Windows: Use winsock2.h instead of sys/time.h when using MSVC
af51970 Add space before PRI* macros, some compilers do not like it
91c0aa8 Move PLIST_API to the headers
834bb31 Silence another false 'shadows builtin function' warning on MinGW
ff842f7 Silence false 'shadows builtin function' warning on MinGW
1d45b85 Silence more compiler warning on 32bit systems
57a7f14 Silence compiler warning on 32bit systems
954b3e4 Update doxygen config and document undocumented macros
4d08422 autoconf: small update to configure.ac
5d65599 autoconf: Allow disabling build of test suite
61f01b1 Add a PLIST_OPT_NONE value to plist_write_options_t

Signed-off-by: Potin Lai <potin.lai.pt@gmail.com>
---
 meta-oe/recipes-extended/libimobiledevice/libplist_git.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
index 3a10b40f1..f8e7f98df 100644
--- a/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
+++ b/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
@@ -8,9 +8,9 @@  DEPENDS = "libxml2 glib-2.0 swig python3"
 
 inherit autotools pkgconfig python3native python3targetconfig
 
-PV = "2.3.0"
+PV = "2.3.0+git${SRCPV}"
 
-SRCREV = "b8fcc89b74c9128a13b07cc15a0ce25dca0cd97e"
+SRCREV = "2cd858c679d25633077ca78b67182a9b77653816"
 SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https;branch=master"
 
 S = "${WORKDIR}/git"