diff mbox series

[meta-oe] ledmon: Fix systemd unit install

Message ID 20231120034721.1414989-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] ledmon: Fix systemd unit install | expand

Commit Message

Khem Raj Nov. 20, 2023, 3:47 a.m. UTC
Use confgure knob to emable systemd service unitfile generation.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb | 9 ++-------
 1 file changed, 2 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb b/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb
index d431fd9a84..88a6e5bb30 100644
--- a/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb
+++ b/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb
@@ -25,15 +25,10 @@  COMPATIBLE_HOST:libc-musl = "null"
 
 S = "${WORKDIR}/git"
 
+EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd', '', d)}"
+
 EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
 
 # The ledmon sources include headers in ${S}/config to build but not in CFLAGS. 
 # We need to add this include path in CFLAGS.
 CFLAGS += "-I${S}/config"
-
-do_install:append() {
-        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-	        install -d ${D}${systemd_unitdir}/system
-	        install -m 0755 ${S}/systemd/ledmon.service ${D}${systemd_unitdir}/system
-        fi
-}