diff mbox series

[meta-oe] meta-oe: recipes-support: Add btop

Message ID 20231118182646.3237533-1-jan.claussen10@web.de
State Under Review
Headers show
Series [meta-oe] meta-oe: recipes-support: Add btop | expand

Commit Message

Jan Claußen Nov. 18, 2023, 6:26 p.m. UTC
Adds btop, the shell-based resource monitor that shows usage and stats for processor, memory, disks, network and processes.

Signed-off-by: Jan Claußen <jan.claussen10@web.de>
---
 meta-oe/recipes-support/btop/btop_1.2.13.bb | 23 +++++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 meta-oe/recipes-support/btop/btop_1.2.13.bb

--
2.42.1

Comments

Khem Raj Nov. 18, 2023, 7:09 p.m. UTC | #1
I tweaked the commit message summary before staging it into
master-next, here is some guidelines on patch submission

https://docs.yoctoproject.org/contributor-guide/submit-changes.html?highlight=patch+submission

ps: It also explains why we use mailing lists in contribution workflow.

On Sat, Nov 18, 2023 at 10:26 AM Jan Claußen <jan.claussen10@web.de> wrote:
>
> Adds btop, the shell-based resource monitor that shows usage and stats for processor, memory, disks, network and processes.
>
> Signed-off-by: Jan Claußen <jan.claussen10@web.de>
> ---
>  meta-oe/recipes-support/btop/btop_1.2.13.bb | 23 +++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>  create mode 100644 meta-oe/recipes-support/btop/btop_1.2.13.bb
>
> diff --git a/meta-oe/recipes-support/btop/btop_1.2.13.bb b/meta-oe/recipes-support/btop/btop_1.2.13.bb
> new file mode 100644
> index 000000000..a944fe7b5
> --- /dev/null
> +++ b/meta-oe/recipes-support/btop/btop_1.2.13.bb
> @@ -0,0 +1,23 @@
> +SUMMARY = "Resource monitor that shows usage and stats for processor, memory, disks, network and processes."
> +HOMEPAGE = "https://github.com/aristocratos/btop"
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> +SECTION = "console/utils"
> +
> +SRC_URI = "git://github.com/aristocratos/btop.git;protocol=https;branch=main"
> +SRCREV = "9edbf27f1b6d5844a97325fcda732762ba086a99"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit cmake
> +
> +FILES:${PN} += " \
> +    ${datadir}/icons \
> +    ${datadir}/icons/hicolor \
> +    ${datadir}/icons/hicolor/48x48 \
> +    ${datadir}/icons/hicolor/scalable \
> +    ${datadir}/icons/hicolor/48x48/apps \
> +    ${datadir}/icons/hicolor/48x48/apps/btop.png \
> +    ${datadir}/icons/hicolor/scalable/apps \
> +    ${datadir}/icons/hicolor/scalable/apps/btop.svg \
> +"
> --
> 2.42.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#106891): https://lists.openembedded.org/g/openembedded-devel/message/106891
> Mute This Topic: https://lists.openembedded.org/mt/102675969/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Jan Claußen Nov. 18, 2023, 9:10 p.m. UTC | #2
So the commit title should have started with the recipe name? btop-1.2.13.bb?

Is there any mail program that can format diffs automatically btw? I don't care about how to submit patches. It is just not nice to read and in your case I also have an > added for every reply, which just gets hard to read after long correspondence.
On Nov. 18 2023, at 8:09 pm, Khem Raj <raj.khem@gmail.com> wrote:
> I tweaked the commit message summary before staging it into
> master-next, here is some guidelines on patch submission
>
> https://docs.yoctoproject.org/contributor-guide/submit-changes.html?highlight=patch+submission
> ps: It also explains why we use mailing lists in contribution workflow.
> On Sat, Nov 18, 2023 at 10:26 AM Jan Claußen <jan.claussen10@web.de> wrote:
> >
> > Adds btop, the shell-based resource monitor that shows usage and stats for processor, memory, disks, network and processes.
> >
> > Signed-off-by: Jan Claußen <jan.claussen10@web.de>
> > ---
> > meta-oe/recipes-support/btop/btop_1.2.13.bb | 23 +++++++++++++++++++++
> > 1 file changed, 23 insertions(+)
> > create mode 100644 meta-oe/recipes-support/btop/btop_1.2.13.bb
> >
> > diff --git a/meta-oe/recipes-support/btop/btop_1.2.13.bb b/meta-oe/recipes-support/btop/btop_1.2.13.bb
> > new file mode 100644
> > index 000000000..a944fe7b5
> > --- /dev/null
> > +++ b/meta-oe/recipes-support/btop/btop_1.2.13.bb
> > @@ -0,0 +1,23 @@
> > +SUMMARY = "Resource monitor that shows usage and stats for processor, memory, disks, network and processes."
> > +HOMEPAGE = "https://github.com/aristocratos/btop"
> > +LICENSE = "Apache-2.0"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> > +SECTION = "console/utils"
> > +
> > +SRC_URI = "git://github.com/aristocratos/btop.git;protocol=https;branch=main"
> > +SRCREV = "9edbf27f1b6d5844a97325fcda732762ba086a99"
> > +
> > +S = "${WORKDIR}/git"
> > +
> > +inherit cmake
> > +
> > +FILES:${PN} += " \
> > + ${datadir}/icons \
> > + ${datadir}/icons/hicolor \
> > + ${datadir}/icons/hicolor/48x48 \
> > + ${datadir}/icons/hicolor/scalable \
> > + ${datadir}/icons/hicolor/48x48/apps \
> > + ${datadir}/icons/hicolor/48x48/apps/btop.png \
> > + ${datadir}/icons/hicolor/scalable/apps \
> > + ${datadir}/icons/hicolor/scalable/apps/btop.svg \
> > +"
> > --
> > 2.42.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#106891): https://lists.openembedded.org/g/openembedded-devel/message/106891
> > Mute This Topic: https://lists.openembedded.org/mt/102675969/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
Jan Claußen Nov. 18, 2023, 9:20 p.m. UTC | #3
Thunderbird has a Colorized Diffs addon, but Thunderbird itself has not aged well imo. I have switched to Mailspring few years ago. Maybe I will use it just for this purpose though!
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/btop/btop_1.2.13.bb b/meta-oe/recipes-support/btop/btop_1.2.13.bb
new file mode 100644
index 000000000..a944fe7b5
--- /dev/null
+++ b/meta-oe/recipes-support/btop/btop_1.2.13.bb
@@ -0,0 +1,23 @@ 
+SUMMARY = "Resource monitor that shows usage and stats for processor, memory, disks, network and processes."
+HOMEPAGE = "https://github.com/aristocratos/btop"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+SECTION = "console/utils"
+
+SRC_URI = "git://github.com/aristocratos/btop.git;protocol=https;branch=main"
+SRCREV = "9edbf27f1b6d5844a97325fcda732762ba086a99"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES:${PN} += " \
+    ${datadir}/icons \
+    ${datadir}/icons/hicolor \
+    ${datadir}/icons/hicolor/48x48 \
+    ${datadir}/icons/hicolor/scalable \
+    ${datadir}/icons/hicolor/48x48/apps \
+    ${datadir}/icons/hicolor/48x48/apps/btop.png \
+    ${datadir}/icons/hicolor/scalable/apps \
+    ${datadir}/icons/hicolor/scalable/apps/btop.svg \
+"