diff mbox series

[meta-python,kirkstone] python3-cson: fix run-time dependencies

Message ID 20231117231321.605621-1-yoann.congal@smile.fr
State New
Headers show
Series [meta-python,kirkstone] python3-cson: fix run-time dependencies | expand

Commit Message

Yoann Congal Nov. 17, 2023, 11:13 p.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Add the missing run-time dependency on python3-json. As a result we no
longer need to pull python3 native and can drop other *DEPENDS.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
(cherry picked from commit 40b4cf5a83098a5f1be873be5c29f26380bc7993)
Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
---
 meta-python/recipes-extended/python-cson/python3-cson_git.bb | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-extended/python-cson/python3-cson_git.bb b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
index c4fcc61ec..1187d12af 100644
--- a/meta-python/recipes-extended/python-cson/python3-cson_git.bb
+++ b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
@@ -12,8 +12,7 @@  SRC_URI = "git://github.com/gt3389b/python-cson.git;branch=master;protocol=https
 
 S = "${WORKDIR}/git"
 
-RDEPENDS:${PN}:class-native = ""
-DEPENDS:append:class-native = " python-native "
+RDEPENDS:${PN} = "python3-json"
 
 inherit setuptools3