diff mbox series

[meta-python] python3-gpiod: setup target config in ptest compile

Message ID 20231115164704.2932248-1-brgl@bgdev.pl
State Accepted
Headers show
Series [meta-python] python3-gpiod: setup target config in ptest compile | expand

Commit Message

Bartosz Golaszewski Nov. 15, 2023, 4:47 p.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

The python3targetconfig class does not setup the build config for target
in do_ptest_compile_base so we need to do this manually. While at it: use
the provided nativepython3 command instead of using the full path.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta-python/recipes-devtools/python/python3-gpiod_2.1.3.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Khem Raj Nov. 16, 2023, 9:51 p.m. UTC | #1
On Wed, 15 Nov 2023 17:47:04 +0100, Bartosz Golaszewski wrote:
> The python3targetconfig class does not setup the build config for target
> in do_ptest_compile_base so we need to do this manually. While at it: use
> the provided nativepython3 command instead of using the full path.
> 
> 

Applied, thanks!

[1/1] python3-gpiod: setup target config in ptest compile
      commit: 936ae8ef2e7943a8bc9fba33ef099901e59a028f

Best regards,
Khem Raj Nov. 16, 2023, 9:52 p.m. UTC | #2
On Wed, 15 Nov 2023 17:47:04 +0100, Bartosz Golaszewski wrote:
> The python3targetconfig class does not setup the build config for target
> in do_ptest_compile_base so we need to do this manually. While at it: use
> the provided nativepython3 command instead of using the full path.
> 
> 

Applied, thanks!

[1/1] python3-gpiod: setup target config in ptest compile
      commit: 936ae8ef2e7943a8bc9fba33ef099901e59a028f

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-gpiod_2.1.3.bb b/meta-python/recipes-devtools/python/python3-gpiod_2.1.3.bb
index ef2f01fd4..310694ade 100644
--- a/meta-python/recipes-devtools/python/python3-gpiod_2.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-gpiod_2.1.3.bb
@@ -28,7 +28,8 @@  RDEPENDS:${PN}-ptest += " \
 export LINK_SYSTEM_LIBGPIOD = "1"
 
 do_compile_ptest() {
-    ${STAGING_BINDIR_NATIVE}/python3-native/python3 build_tests.py
+    setup_target_config
+    nativepython3 build_tests.py
 }
 
 do_install_ptest() {