diff mbox series

[meta-python,2/3] python3-wrapt: Upgrade 1.15.0 -> 1.16.0

Message ID 20231113142909.3093632-2-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/3] python3-file-magic: add recipe | expand

Commit Message

Leon Anavi Nov. 13, 2023, 2:29 p.m. UTC
Upgrade to version 1.16.0:

- The patch_function_wrapper() decorator now accepts an enabled
  argument which can be a literal boolean value, object that
  evaluates as boolean, or a callable object which returns a
  boolean.
- The import hook loader and finder objects are now implemented
  as transparent object proxies so they properly proxy pass access
  to attributes/functions of the wrapped loader or finder.
- Code files in the implementation have been reorganized such that
  the pure Python version of the ObjectProxy class is directly
  available even if the C extension variant is being used.
- Bug fix: it was not possible to update the __class__ attribute
  through the transparent object proxy when relying on the C
  implementation.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/{python3-wrapt_1.15.0.bb => python3-wrapt_1.16.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-wrapt_1.15.0.bb => python3-wrapt_1.16.0.bb} (81%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-wrapt_1.15.0.bb b/meta-python/recipes-devtools/python/python3-wrapt_1.16.0.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-wrapt_1.15.0.bb
rename to meta-python/recipes-devtools/python/python3-wrapt_1.16.0.bb
index e35e1f7a7..f99b552c6 100644
--- a/meta-python/recipes-devtools/python/python3-wrapt_1.15.0.bb
+++ b/meta-python/recipes-devtools/python/python3-wrapt_1.16.0.bb
@@ -4,7 +4,7 @@  LICENSE = "BSD-2-Clause"
 SECTION = "devel/python"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=dc34cbad60bc961452eb7ade801d25f7"
 
-SRC_URI[sha256sum] = "d06730c6aed78cee4126234cf2d071e01b44b915e725a6cb439a879ec9754a3a"
+SRC_URI[sha256sum] = "5f370f952971e7d17c7d1ead40e49f32345a7f7a5373571ef44d800d06b1899d"
 
 inherit pypi setuptools3