diff mbox series

[meta-networking] civetweb: upgrade 1.12 -> 1.16

Message ID 20231112200451.610152-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-networking] civetweb: upgrade 1.12 -> 1.16 | expand

Commit Message

Alper Ak Nov. 12, 2023, 8:04 p.m. UTC
=========================
- Added "-DCIVETWEB_SSL_OPENSSL_API_3_0=ON" because of following error:

civetweb.c:1561:2: error: #error "Please define OPENSSL_API_#_# or USE_MBEDTLS"

You may also want to check out the available CMake options here:

https://github.com/civetweb/civetweb/blob/d7ba35bbb649209c66e582d5a0244ba988a15159/CMakeLists.txt
=========================

Changelog:

https://github.com/civetweb/civetweb/blob/d7ba35bbb649209c66e582d5a0244ba988a15159/RELEASE_NOTES.md

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../civetweb/{civetweb_git.bb => civetweb_1.16.bb}         | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
 rename meta-networking/recipes-connectivity/civetweb/{civetweb_git.bb => civetweb_1.16.bb} (91%)

Comments

Khem Raj Nov. 12, 2023, 11:06 p.m. UTC | #1
On Sun, Nov 12, 2023 at 12:05 PM Alper Ak <alperyasinak1@gmail.com> wrote:
>
> =========================
> - Added "-DCIVETWEB_SSL_OPENSSL_API_3_0=ON" because of following error:
>
> civetweb.c:1561:2: error: #error "Please define OPENSSL_API_#_# or USE_MBEDTLS"
>
> You may also want to check out the available CMake options here:
>
> https://github.com/civetweb/civetweb/blob/d7ba35bbb649209c66e582d5a0244ba988a15159/CMakeLists.txt
> =========================
>
> Changelog:
>
> https://github.com/civetweb/civetweb/blob/d7ba35bbb649209c66e582d5a0244ba988a15159/RELEASE_NOTES.md
>
> Signed-off-by: alperak <alperyasinak1@gmail.com>
> ---
>  .../civetweb/{civetweb_git.bb => civetweb_1.16.bb}         | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
>  rename meta-networking/recipes-connectivity/civetweb/{civetweb_git.bb => civetweb_1.16.bb} (91%)
>
> diff --git a/meta-networking/recipes-connectivity/civetweb/civetweb_git.bb b/meta-networking/recipes-connectivity/civetweb/civetweb_1.16.bb
> similarity index 91%
> rename from meta-networking/recipes-connectivity/civetweb/civetweb_git.bb
> rename to meta-networking/recipes-connectivity/civetweb/civetweb_1.16.bb
> index e9c205618..0a654a10f 100644
> --- a/meta-networking/recipes-connectivity/civetweb/civetweb_git.bb
> +++ b/meta-networking/recipes-connectivity/civetweb/civetweb_1.16.bb
> @@ -2,10 +2,10 @@ SUMMARY = "Civetweb embedded web server"
>  HOMEPAGE = "https://github.com/civetweb/civetweb"
>
>  LICENSE = "MIT"
> -LIC_FILES_CHKSUM = "file://LICENSE.md;md5=50bd1d7f135b50d7e218996ba28d0d88"
> +LIC_FILES_CHKSUM = "file://LICENSE.md;md5=ce6ce6eb1b2fd59ee6bab219470442a3"

Please add
License-Update: <reason for this checksum change>

> +
> +SRCREV = "d7ba35bbb649209c66e582d5a0244ba988a15159"
>
> -SRCREV = "4b440a339979852d5a51fb11a822952712231c23"
> -PV = "1.12+git${SRCPV}"
>  SRC_URI = "git://github.com/civetweb/civetweb.git;branch=master;protocol=https \
>             file://0001-Unittest-Link-librt-and-libm-using-l-option.patch \
>             "
> @@ -23,6 +23,7 @@ EXTRA_OECMAKE = " \
>      -DCIVETWEB_ENABLE_LUA=OFF \
>      -DCIVETWEB_ENABLE_ASAN=OFF \
>      -DCIVETWEB_BUILD_TESTING=OFF \
> +    -DCIVETWEB_SSL_OPENSSL_API_3_0=ON \
>  "
>
>  # Building with ninja fails on missing third_party/lib/libcheck.a (which
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#106603): https://lists.openembedded.org/g/openembedded-devel/message/106603
> Mute This Topic: https://lists.openembedded.org/mt/102548768/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Nov. 13, 2023, 6:34 p.m. UTC | #2
On Sun, 12 Nov 2023 23:04:51 +0300, alperak wrote:
> =========================
> - Added "-DCIVETWEB_SSL_OPENSSL_API_3_0=ON" because of following error:
> 
> civetweb.c:1561:2: error: #error "Please define OPENSSL_API_#_# or USE_MBEDTLS"
> 
> You may also want to check out the available CMake options here:
> 
> [...]

Applied, thanks!

[1/1] civetweb: upgrade 1.12 -> 1.16
      commit: fc60d791b82b306ae0ba154990fa94ca91ac84ee

Best regards,
diff mbox series

Patch

diff --git a/meta-networking/recipes-connectivity/civetweb/civetweb_git.bb b/meta-networking/recipes-connectivity/civetweb/civetweb_1.16.bb
similarity index 91%
rename from meta-networking/recipes-connectivity/civetweb/civetweb_git.bb
rename to meta-networking/recipes-connectivity/civetweb/civetweb_1.16.bb
index e9c205618..0a654a10f 100644
--- a/meta-networking/recipes-connectivity/civetweb/civetweb_git.bb
+++ b/meta-networking/recipes-connectivity/civetweb/civetweb_1.16.bb
@@ -2,10 +2,10 @@  SUMMARY = "Civetweb embedded web server"
 HOMEPAGE = "https://github.com/civetweb/civetweb"
 
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=50bd1d7f135b50d7e218996ba28d0d88"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=ce6ce6eb1b2fd59ee6bab219470442a3"
+
+SRCREV = "d7ba35bbb649209c66e582d5a0244ba988a15159"
 
-SRCREV = "4b440a339979852d5a51fb11a822952712231c23"
-PV = "1.12+git${SRCPV}"
 SRC_URI = "git://github.com/civetweb/civetweb.git;branch=master;protocol=https \
            file://0001-Unittest-Link-librt-and-libm-using-l-option.patch \
            "
@@ -23,6 +23,7 @@  EXTRA_OECMAKE = " \
     -DCIVETWEB_ENABLE_LUA=OFF \
     -DCIVETWEB_ENABLE_ASAN=OFF \
     -DCIVETWEB_BUILD_TESTING=OFF \
+    -DCIVETWEB_SSL_OPENSSL_API_3_0=ON \
 "
 
 # Building with ninja fails on missing third_party/lib/libcheck.a (which