diff mbox series

[meta-oe] cups-filters: Fix for current gcc

Message ID 20231111221848.1363223-1-f_l_k@t-online.de
State Accepted
Headers show
Series [meta-oe] cups-filters: Fix for current gcc | expand

Commit Message

Markus Volk Nov. 11, 2023, 10:18 p.m. UTC
std::string_view is part of c++17

This fixes:
error: 'std::string_view' has not been declared

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta-oe/recipes-printing/cups/cups-filters_1.28.17.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Khem Raj Nov. 13, 2023, 6:33 p.m. UTC | #1
On Sat, 11 Nov 2023 23:18:48 +0100, Markus Volk wrote:
> std::string_view is part of c++17
> 
> This fixes:
> error: 'std::string_view' has not been declared
> 
> 

Applied, thanks!

[1/1] cups-filters: Fix for current gcc
      commit: ba28b8f98713fb5b009ccbf8f12a0638598444cb

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-printing/cups/cups-filters_1.28.17.bb b/meta-oe/recipes-printing/cups/cups-filters_1.28.17.bb
index 01c29d2c9..dc527bf72 100644
--- a/meta-oe/recipes-printing/cups/cups-filters_1.28.17.bb
+++ b/meta-oe/recipes-printing/cups/cups-filters_1.28.17.bb
@@ -30,6 +30,8 @@  EXTRA_OECONF:class-native += " --with-pdftops=pdftops \
                                     --disable-ldap \
                                     --with-png --without-jpeg --without-tiff"
 
+CXXFLAGS += "-std=c++17"
+
 PACKAGECONFIG[jpeg] = "--with-jpeg,--without-jpeg,jpeg"
 PACKAGECONFIG[png] = "--with-png,--without-png,libpng"
 PACKAGECONFIG[tiff] = "--with-tiff,--without-tiff,tiff"