diff mbox series

[meta-python,1/2] python3-screeninfo: add recipe

Message ID 20231103132453.3853904-1-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/2] python3-screeninfo: add recipe | expand

Commit Message

Leon Anavi Nov. 3, 2023, 1:24 p.m. UTC
Add screeninfo, fetch location and size of physical screens.
Versions 0.8.1 and 0.8.0 changelog:

- Added typing information
- Started tracking changes
- Switched to poetry
- Added ignoring of enumerators that work, but return no valid
  monitors
- Added ScreenInfoError to list of top-level symbols

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-screeninfo_0.8.1.bb           | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-screeninfo_0.8.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-screeninfo_0.8.1.bb b/meta-python/recipes-devtools/python/python3-screeninfo_0.8.1.bb
new file mode 100644
index 000000000..0fb3f3a22
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-screeninfo_0.8.1.bb
@@ -0,0 +1,16 @@ 
+DESCRIPTION = "Fetch location and size of physical screens."
+HOMEPAGE = "https://github.com/rr-/screeninfo"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a23813181e06852d377bc25ae5563a97"
+
+PYPI_PACKAGE = "screeninfo"
+
+SRC_URI[sha256sum] = "9983076bcc7e34402a1a9e4d7dabf3729411fd2abb3f3b4be7eba73519cd2ed1"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-profile \
+"