diff mbox series

[meta-python,1/3] python3-flask-restx: Add Flask-RestX Python Recipe

Message ID 20231103131037.2997335-2-arthur.oliveira@ossystems.com.br
State Under Review
Headers show
Series Branch Name: topic-add-python-recipes | expand

Commit Message

arthur.oliveira@ossystems.com.br Nov. 3, 2023, 1:10 p.m. UTC
From: Arthur Oliveira <arthur.oliveira@ossystems.com.br>

This commit introduces the python3-flask-restx recipe, which brings a fully
featured framework for fast, easy, and documented API development with Flask.
It is released under the BSD-3-Clause license.

Signed-off-by: Arthur Oliveira <arthur.oliveira@ossystems.com.br>
---
update license to BSD-3-Clause
---
 .../python/python3-flask-restx_1.2.0.bb             | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb b/meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb
new file mode 100644
index 000000000..cff797139
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb
@@ -0,0 +1,13 @@ 
+DESCRIPTION = "Fully featured framework for fast, easy and documented API development with Flask"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c96dd911c6d9e32868b6bc667a38a3e2"
+
+SRC_URI[sha256sum] = "9a5338b108c57fbed1d24d5d53fe98442b2be7ffa2ff3291305af7a613ce6fc0"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    python3-isodate \
+    python3-jsonschema \
+    python3-pytz \
+"