diff mbox series

[v1,1/1] Brotli: fix build failed if the path includes "-static"

Message ID 20231103100246.3899364-1-jamin_lin@aspeedtech.com
State Under Review
Headers show
Series [v1,1/1] Brotli: fix build failed if the path includes "-static" | expand

Commit Message

Jamin Lin Nov. 3, 2023, 10:02 a.m. UTC
It would like to remove "-static" in the name of statice library
at the do_install task. For example: replace libbrotlicommon-static.a
with ibbrotlicommon-static.a However, if the patch of
this statice library includes "-static", it would build failed.
(ex: set my build directory "build-static")
Change to remove "-static" in the base name of static library
to fix this build failed.

Signed-off-by: Jamin Lin <jamin_lin@aspeedtech.com>
---
 meta-oe/recipes-extended/brotli/brotli_1.0.9.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
index 4e2813dde..6492b1943 100644
--- a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
+++ b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
@@ -16,7 +16,8 @@  inherit cmake lib_package
 
 do_install:append () {
 	for lib in $(ls ${D}${libdir}/*-static.a); do
-		mv -v "${lib}" "$(echo ${lib} | sed s/-static//)"
+		basename=$(basename ${lib})
+		mv -v "${lib}" "${D}${libdir}$(echo ${basename} | sed s/-static//)"
 	done
 }