diff mbox series

[meta-oe] Update ipmitool to eliminate unneeded patch

Message ID 20231102172736.221038-1-johnathanx.mantey@intel.com
State New
Headers show
Series [meta-oe] Update ipmitool to eliminate unneeded patch | expand

Commit Message

Johnathan Mantey Nov. 2, 2023, 5:27 p.m. UTC
The upstream ipmitool code has implemented an autoconfig control to
enable and disable dynamic fetching of the IANA numbers file. As a
result the patch removing the code that blocks fetching the IANA numbers is
no longer relevant.

The patch being removed explicitlly blocks downloading the IANA
numbers file. Maintain this behavior at this level by using the
--disable-registry-download feature.

In order for that autoconfig switch to work, the recipe must inherit
the pkgconfig feature. Without the pkgconfig dependency the code in
the configure.ac file causes a compile time error.

Tested:
IANA numbers file isn't downloaded.
Manually downloaded IANA file is installed in /usr/share/misc
Enabling registry download enables dynamic download of IANA numbers

Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com>
---
 ...-the-logic-to-download-IANA-PEN-data.patch | 41 -------------------
 .../ipmitool/ipmitool_1.8.19.bb               |  8 ++--
 2 files changed, 5 insertions(+), 44 deletions(-)
 delete mode 100644 meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch

Comments

Khem Raj Nov. 2, 2023, 5:48 p.m. UTC | #1
Thanks for the patch, few nits for future reference
The patch is not generated against standalone meta-openembedded repo
so please do so. it makes it easy
for us to appy it. The subject line has a familiar format

recipe: <summary>

Details.

The append is not needed the option can be merged into the options
just above it.

I have made this tweaks and pushed it into staging ( master-next )
please test it out as well on your end

On Thu, Nov 2, 2023 at 10:27 AM Johnathan Mantey
<johnathanx.mantey@intel.com> wrote:
>
> The upstream ipmitool code has implemented an autoconfig control to
> enable and disable dynamic fetching of the IANA numbers file. As a
> result the patch removing the code that blocks fetching the IANA numbers is
> no longer relevant.
>
> The patch being removed explicitlly blocks downloading the IANA
> numbers file. Maintain this behavior at this level by using the
> --disable-registry-download feature.
>
> In order for that autoconfig switch to work, the recipe must inherit
> the pkgconfig feature. Without the pkgconfig dependency the code in
> the configure.ac file causes a compile time error.
>
> Tested:
> IANA numbers file isn't downloaded.
> Manually downloaded IANA file is installed in /usr/share/misc
> Enabling registry download enables dynamic download of IANA numbers
>
> Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com>
> ---
>  ...-the-logic-to-download-IANA-PEN-data.patch | 41 -------------------
>  .../ipmitool/ipmitool_1.8.19.bb               |  8 ++--
>  2 files changed, 5 insertions(+), 44 deletions(-)
>  delete mode 100644 meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
>
> diff --git a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
> deleted file mode 100644
> index 442f132718..0000000000
> --- a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
> +++ /dev/null
> @@ -1,41 +0,0 @@
> -From 63d72f97bd106dd2101cd7fdac6df4f7a053d67c Mon Sep 17 00:00:00 2001
> -From: Khem Raj <raj.khem@gmail.com>
> -Date: Fri, 2 Sep 2022 08:27:39 -0700
> -Subject: [PATCH] configure: Remove the logic to download IANA PEN database
> - during configure
> -
> -OE will do all downloading before it starts to configure therefore this
> -step is moved out into bitbake recipe, so we can make it immutable build
> -
> -Upstream-Status: Inappropriate [OE-Specific]
> -
> -Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ----
> - configure.ac | 16 +---------------
> - 1 file changed, 1 insertion(+), 15 deletions(-)
> -
> ---- a/configure.ac
> -+++ b/configure.ac
> -@@ -56,21 +56,7 @@ if test "x$exec_prefix" = "xNONE"; then
> -       exec_prefix="$prefix"
> - fi
> -
> --if test "x$WGET" = "x"; then
> --      if test "x$CURL" = "x"; then
> --              AC_MSG_WARN([** Neither wget nor curl could be found.])
> --              AC_MSG_WARN([** IANA PEN database will not be installed by `make install` !])
> --      else
> --              DOWNLOAD="$CURL --location --progress-bar"
> --              AM_CONDITIONAL([DOWNLOAD], [true])
> --      fi
> --else
> --      DOWNLOAD="$WGET -c -nd -O -"
> --      AM_CONDITIONAL([DOWNLOAD], [true])
> --fi
> --
> --AC_MSG_WARN([** Download is:])
> --AC_MSG_WARN($DOWNLOAD)
> -+AM_CONDITIONAL([DOWNLOAD], [false])
> - AC_SUBST(DOWNLOAD, $DOWNLOAD)
> -
> - dnl
> diff --git a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
> index ab9074bba5..1c541faf8c 100644
> --- a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
> +++ b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
> @@ -21,10 +21,9 @@ LICENSE = "BSD-3-Clause"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184"
>
>  DEPENDS = "openssl readline ncurses"
> -SRCREV = "19d78782d795d0cf4ceefe655f616210c9143e62"
> +SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3"
>  SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \
>             ${IANA_ENTERPRISE_NUMBERS} \
> -           file://0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch \
>             "
>  IANA_ENTERPRISE_NUMBERS ?= ""
>
> @@ -34,7 +33,7 @@ IANA_ENTERPRISE_NUMBERS ?= ""
>
>  S = "${WORKDIR}/git"
>
> -inherit autotools
> +inherit autotools pkgconfig
>
>  do_install:append() {
>          if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then
> @@ -50,5 +49,8 @@ FILES:${PN} += "${datadir}/misc"
>  # --enable-file-security adds some security checks
>  # --disable-intf-free disables FreeIPMI support - we don't want to depend on
>  #   FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
> +# --disable-registry-download prevents the IANA numbers from being fetched
> +#   at build time, as it is not repeatable.
>  #
>  EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free"
> +EXTRA_OECONF:append = " --disable-registry-download "
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105842): https://lists.openembedded.org/g/openembedded-devel/message/105842
> Mute This Topic: https://lists.openembedded.org/mt/102347757/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Johnathan Mantey Nov. 2, 2023, 5:56 p.m. UTC | #2
Khem Raj <raj.khem@gmail.com> writes:

> Thanks for the patch, few nits for future reference
> The patch is not generated against standalone meta-openembedded 
> repo
> so please do so. it makes it easy
> for us to appy it. The subject line has a familiar format
>
> recipe: <summary>
>
> Details.
>
> The append is not needed the option can be merged into the 
> options
> just above it.
>
> I have made this tweaks and pushed it into staging ( master-next 
> )
> please test it out as well on your end
>

I will endeavor to do better for the next commit, as I do have one 
I hope to make.
Thanks for tweaking my patch, I will pull what you've done, and do 
some testing.

> On Thu, Nov 2, 2023 at 10:27 AM Johnathan Mantey
> <johnathanx.mantey@intel.com> wrote:
>>
>> The upstream ipmitool code has implemented an autoconfig 
>> control to
>> enable and disable dynamic fetching of the IANA numbers 
>> file. As a
>> result the patch removing the code that blocks fetching the 
>> IANA numbers is
>> no longer relevant.
>>
>> The patch being removed explicitlly blocks downloading the IANA
>> numbers file. Maintain this behavior at this level by using the
>> --disable-registry-download feature.
>>
>> In order for that autoconfig switch to work, the recipe must 
>> inherit
>> the pkgconfig feature. Without the pkgconfig dependency the 
>> code in
>> the configure.ac file causes a compile time error.
>>
>> Tested:
>> IANA numbers file isn't downloaded.
>> Manually downloaded IANA file is installed in /usr/share/misc
>> Enabling registry download enables dynamic download of IANA 
>> numbers
>>
>> Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com>
>> ---
>>  ...-the-logic-to-download-IANA-PEN-data.patch | 41 
>>  -------------------
>>  .../ipmitool/ipmitool_1.8.19.bb               |  8 ++--
>>  2 files changed, 5 insertions(+), 44 deletions(-)
>>  delete mode 100644 
>>  meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
>>
>> diff --git
> a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
> b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
>> deleted file mode 100644
>> index 442f132718..0000000000
>> --- 
>> a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
>> +++ /dev/null
>> @@ -1,41 +0,0 @@
>> -From 63d72f97bd106dd2101cd7fdac6df4f7a053d67c Mon Sep 17 
>> 00:00:00 2001
>> -From: Khem Raj <raj.khem@gmail.com>
>> -Date: Fri, 2 Sep 2022 08:27:39 -0700
>> -Subject: [PATCH] configure: Remove the logic to download IANA 
>> PEN database
>> - during configure
>> -
>> -OE will do all downloading before it starts to configure 
>> therefore this
>> -step is moved out into bitbake recipe, so we can make it 
>> immutable build
>> -
>> -Upstream-Status: Inappropriate [OE-Specific]
>> -
>> -Signed-off-by: Khem Raj <raj.khem@gmail.com>
>> ----
>> - configure.ac | 16 +---------------
>> - 1 file changed, 1 insertion(+), 15 deletions(-)
>> -
>> ---- a/configure.ac
>> -+++ b/configure.ac
>> -@@ -56,21 +56,7 @@ if test "x$exec_prefix" = "xNONE"; then
>> -       exec_prefix="$prefix"
>> - fi
>> -
>> --if test "x$WGET" = "x"; then
>> --      if test "x$CURL" = "x"; then
>> --              AC_MSG_WARN([** Neither wget nor curl could be 
>> found.])
>> --              AC_MSG_WARN([** IANA PEN database will not be 
>> installed by `make install` !])
>> --      else
>> --              DOWNLOAD="$CURL --location --progress-bar"
>> --              AM_CONDITIONAL([DOWNLOAD], [true])
>> --      fi
>> --else
>> --      DOWNLOAD="$WGET -c -nd -O -"
>> --      AM_CONDITIONAL([DOWNLOAD], [true])
>> --fi
>> --
>> --AC_MSG_WARN([** Download is:])
>> --AC_MSG_WARN($DOWNLOAD)
>> -+AM_CONDITIONAL([DOWNLOAD], [false])
>> - AC_SUBST(DOWNLOAD, $DOWNLOAD)
>> -
>> - dnl
>> diff --git 
>> a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb 
>> b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
>> index ab9074bba5..1c541faf8c 100644
>> --- 
>> a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
>> +++ 
>> b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
>> @@ -21,10 +21,9 @@ LICENSE = "BSD-3-Clause"
>>  LIC_FILES_CHKSUM = 
>>  "file://COPYING;md5=9aa91e13d644326bf281924212862184"
>>
>>  DEPENDS = "openssl readline ncurses"
>> -SRCREV = "19d78782d795d0cf4ceefe655f616210c9143e62"
>> +SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3"
>>  SRC_URI = 
>>  "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master 
>>  \
>>             ${IANA_ENTERPRISE_NUMBERS} \
>> - 
>> file://0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch 
>> \
>>             "
>>  IANA_ENTERPRISE_NUMBERS ?= ""
>>
>> @@ -34,7 +33,7 @@ IANA_ENTERPRISE_NUMBERS ?= ""
>>
>>  S = "${WORKDIR}/git"
>>
>> -inherit autotools
>> +inherit autotools pkgconfig
>>
>>  do_install:append() {
>>          if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then
>> @@ -50,5 +49,8 @@ FILES:${PN} += "${datadir}/misc"
>>  # --enable-file-security adds some security checks
>>  # --disable-intf-free disables FreeIPMI support - we don't 
>>  want to depend on
>>  #   FreeIPMI libraries, FreeIPMI has its own ipmitoool-like 
>>  utility.
>> +# --disable-registry-download prevents the IANA numbers from 
>> being fetched
>> +#   at build time, as it is not repeatable.
>>  #
>>  EXTRA_OECONF = "--disable-dependency-tracking 
>>  --enable-file-security --disable-intf-free"
>> +EXTRA_OECONF:append = " --disable-registry-download "
>> --
>> 2.41.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#105842): 
>> https://lists.openembedded.org/g/openembedded-devel/message/105842
>> Mute This Topic: 
>> https://lists.openembedded.org/mt/102347757/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: 
>> https://lists.openembedded.org/g/openembedded-devel/unsub 
>> [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Johnathan Mantey Nov. 2, 2023, 7:39 p.m. UTC | #3
Khem Raj <raj.khem@gmail.com> writes:

> Thanks for the patch, few nits for future reference
> The patch is not generated against standalone meta-openembedded 
> repo
> so please do so. it makes it easy
> for us to appy it. The subject line has a familiar format
>
> recipe: <summary>
>
> Details.
>
> The append is not needed the option can be merged into the 
> options
> just above it.
>
> I have made this tweaks and pushed it into staging ( master-next 
> )
> please test it out as well on your end
>

I have applied your changes and performed some tests. Everything 
is working as expected.
Thank you for fixing this for me, and getting it staged!

> On Thu, Nov 2, 2023 at 10:27 AM Johnathan Mantey
> <johnathanx.mantey@intel.com> wrote:
>>
>> The upstream ipmitool code has implemented an autoconfig 
>> control to
>> enable and disable dynamic fetching of the IANA numbers 
>> file. As a
>> result the patch removing the code that blocks fetching the 
>> IANA numbers is
>> no longer relevant.
>>
>> The patch being removed explicitlly blocks downloading the IANA
>> numbers file. Maintain this behavior at this level by using the
>> --disable-registry-download feature.
>>
>> In order for that autoconfig switch to work, the recipe must 
>> inherit
>> the pkgconfig feature. Without the pkgconfig dependency the 
>> code in
>> the configure.ac file causes a compile time error.
>>
>> Tested:
>> IANA numbers file isn't downloaded.
>> Manually downloaded IANA file is installed in /usr/share/misc
>> Enabling registry download enables dynamic download of IANA 
>> numbers
>>
>> Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com>
>> ---
>>  ...-the-logic-to-download-IANA-PEN-data.patch | 41 
>>  -------------------
>>  .../ipmitool/ipmitool_1.8.19.bb               |  8 ++--
>>  2 files changed, 5 insertions(+), 44 deletions(-)
>>  delete mode 100644 
>>  meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
>>
>> diff --git
> a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
> b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
>> deleted file mode 100644
>> index 442f132718..0000000000
>> --- 
>> a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
>> +++ /dev/null
>> @@ -1,41 +0,0 @@
>> -From 63d72f97bd106dd2101cd7fdac6df4f7a053d67c Mon Sep 17 
>> 00:00:00 2001
>> -From: Khem Raj <raj.khem@gmail.com>
>> -Date: Fri, 2 Sep 2022 08:27:39 -0700
>> -Subject: [PATCH] configure: Remove the logic to download IANA 
>> PEN database
>> - during configure
>> -
>> -OE will do all downloading before it starts to configure 
>> therefore this
>> -step is moved out into bitbake recipe, so we can make it 
>> immutable build
>> -
>> -Upstream-Status: Inappropriate [OE-Specific]
>> -
>> -Signed-off-by: Khem Raj <raj.khem@gmail.com>
>> ----
>> - configure.ac | 16 +---------------
>> - 1 file changed, 1 insertion(+), 15 deletions(-)
>> -
>> ---- a/configure.ac
>> -+++ b/configure.ac
>> -@@ -56,21 +56,7 @@ if test "x$exec_prefix" = "xNONE"; then
>> -       exec_prefix="$prefix"
>> - fi
>> -
>> --if test "x$WGET" = "x"; then
>> --      if test "x$CURL" = "x"; then
>> --              AC_MSG_WARN([** Neither wget nor curl could be 
>> found.])
>> --              AC_MSG_WARN([** IANA PEN database will not be 
>> installed by `make install` !])
>> --      else
>> --              DOWNLOAD="$CURL --location --progress-bar"
>> --              AM_CONDITIONAL([DOWNLOAD], [true])
>> --      fi
>> --else
>> --      DOWNLOAD="$WGET -c -nd -O -"
>> --      AM_CONDITIONAL([DOWNLOAD], [true])
>> --fi
>> --
>> --AC_MSG_WARN([** Download is:])
>> --AC_MSG_WARN($DOWNLOAD)
>> -+AM_CONDITIONAL([DOWNLOAD], [false])
>> - AC_SUBST(DOWNLOAD, $DOWNLOAD)
>> -
>> - dnl
>> diff --git 
>> a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb 
>> b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
>> index ab9074bba5..1c541faf8c 100644
>> --- 
>> a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
>> +++ 
>> b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
>> @@ -21,10 +21,9 @@ LICENSE = "BSD-3-Clause"
>>  LIC_FILES_CHKSUM = 
>>  "file://COPYING;md5=9aa91e13d644326bf281924212862184"
>>
>>  DEPENDS = "openssl readline ncurses"
>> -SRCREV = "19d78782d795d0cf4ceefe655f616210c9143e62"
>> +SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3"
>>  SRC_URI = 
>>  "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master 
>>  \
>>             ${IANA_ENTERPRISE_NUMBERS} \
>> - 
>> file://0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch 
>> \
>>             "
>>  IANA_ENTERPRISE_NUMBERS ?= ""
>>
>> @@ -34,7 +33,7 @@ IANA_ENTERPRISE_NUMBERS ?= ""
>>
>>  S = "${WORKDIR}/git"
>>
>> -inherit autotools
>> +inherit autotools pkgconfig
>>
>>  do_install:append() {
>>          if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then
>> @@ -50,5 +49,8 @@ FILES:${PN} += "${datadir}/misc"
>>  # --enable-file-security adds some security checks
>>  # --disable-intf-free disables FreeIPMI support - we don't 
>>  want to depend on
>>  #   FreeIPMI libraries, FreeIPMI has its own ipmitoool-like 
>>  utility.
>> +# --disable-registry-download prevents the IANA numbers from 
>> being fetched
>> +#   at build time, as it is not repeatable.
>>  #
>>  EXTRA_OECONF = "--disable-dependency-tracking 
>>  --enable-file-security --disable-intf-free"
>> +EXTRA_OECONF:append = " --disable-registry-download "
>> --
>> 2.41.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#105842): 
>> https://lists.openembedded.org/g/openembedded-devel/message/105842
>> Mute This Topic: 
>> https://lists.openembedded.org/mt/102347757/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: 
>> https://lists.openembedded.org/g/openembedded-devel/unsub 
>> [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
deleted file mode 100644
index 442f132718..0000000000
--- a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
+++ /dev/null
@@ -1,41 +0,0 @@ 
-From 63d72f97bd106dd2101cd7fdac6df4f7a053d67c Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 2 Sep 2022 08:27:39 -0700
-Subject: [PATCH] configure: Remove the logic to download IANA PEN database
- during configure
-
-OE will do all downloading before it starts to configure therefore this
-step is moved out into bitbake recipe, so we can make it immutable build
-
-Upstream-Status: Inappropriate [OE-Specific]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- configure.ac | 16 +---------------
- 1 file changed, 1 insertion(+), 15 deletions(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -56,21 +56,7 @@ if test "x$exec_prefix" = "xNONE"; then
- 	exec_prefix="$prefix"
- fi
- 
--if test "x$WGET" = "x"; then
--	if test "x$CURL" = "x"; then
--		AC_MSG_WARN([** Neither wget nor curl could be found.])
--		AC_MSG_WARN([** IANA PEN database will not be installed by `make install` !])
--	else
--		DOWNLOAD="$CURL --location --progress-bar"
--		AM_CONDITIONAL([DOWNLOAD], [true])
--	fi
--else
--	DOWNLOAD="$WGET -c -nd -O -"
--	AM_CONDITIONAL([DOWNLOAD], [true])
--fi
--
--AC_MSG_WARN([** Download is:])
--AC_MSG_WARN($DOWNLOAD)
-+AM_CONDITIONAL([DOWNLOAD], [false])
- AC_SUBST(DOWNLOAD, $DOWNLOAD)
- 
- dnl
diff --git a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
index ab9074bba5..1c541faf8c 100644
--- a/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
+++ b/meta-openembedded/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
@@ -21,10 +21,9 @@  LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184"
 
 DEPENDS = "openssl readline ncurses"
-SRCREV = "19d78782d795d0cf4ceefe655f616210c9143e62"
+SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3"
 SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \
            ${IANA_ENTERPRISE_NUMBERS} \
-           file://0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch \
            "
 IANA_ENTERPRISE_NUMBERS ?= ""
 
@@ -34,7 +33,7 @@  IANA_ENTERPRISE_NUMBERS ?= ""
 
 S = "${WORKDIR}/git"
 
-inherit autotools
+inherit autotools pkgconfig
 
 do_install:append() {
         if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then
@@ -50,5 +49,8 @@  FILES:${PN} += "${datadir}/misc"
 # --enable-file-security adds some security checks
 # --disable-intf-free disables FreeIPMI support - we don't want to depend on
 #   FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
+# --disable-registry-download prevents the IANA numbers from being fetched
+#   at build time, as it is not repeatable.
 #
 EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free"
+EXTRA_OECONF:append = " --disable-registry-download "