diff mbox series

[meta-python,2/2] python3-blivetgui: 2.3.0 -> 2.4.2

Message ID 20231102062924.786081-2-kai.kang@windriver.com
State Under Review
Headers show
Series [meta-python,1/2] python3-blivet: 3.4.3 -> 3.8.2 | expand

Commit Message

Kai Nov. 2, 2023, 6:29 a.m. UTC
From: Kai Kang <kai.kang@windriver.com>

Update python3-blivetgui from 2.3.0 to 2.4.2

* drop patches that there are not needed any more
* not set var `B` that out of source tree build is supported
* inherit setuptools3 rather than setuptools3_legacy

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 ...ols-instead-of-distutils-in-setup.py.patch | 30 ----------
 ...Use-symbolic-list-add-and-edit-icons.patch | 56 -------------------
 ...ui_2.3.0.bb => python3-blivetgui_2.4.2.bb} | 18 ++----
 3 files changed, 5 insertions(+), 99 deletions(-)
 delete mode 100644 meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch
 delete mode 100644 meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch
 rename meta-python/recipes-extended/python-blivet/{python3-blivetgui_2.3.0.bb => python3-blivetgui_2.4.2.bb} (61%)
diff mbox series

Patch

diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch
deleted file mode 100644
index c88912bfa..000000000
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch
+++ /dev/null
@@ -1,30 +0,0 @@ 
-From 54014061be2fed20d6c35aba9719ea70a9fea9ea Mon Sep 17 00:00:00 2001
-From: Vojtech Trefny <vtrefny@redhat.com>
-Date: Wed, 1 Sep 2021 08:59:19 +0200
-Subject: [PATCH] Use setuptools instead of distutils in setup.py
-
-The distutils module is deprecated and will be removed in Python
-3.12.
-
-Upstream-Status: Backport [https://github.com/kraj/blivet-gui/commit/54014061be2fed20d6c35aba9719ea70a9fea9ea]
----
- setup.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index aa8ef57..77849a1 100644
---- a/setup.py
-+++ b/setup.py
-@@ -1,7 +1,7 @@
- from __future__ import print_function
- 
--from distutils.core import setup
--from distutils.command.sdist import sdist
-+from setuptools import setup
-+from setuptools.command.sdist import sdist
- import glob
- import sys
- 
--- 
-2.35.1
-
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch
deleted file mode 100644
index 3a95859ad..000000000
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch
+++ /dev/null
@@ -1,56 +0,0 @@ 
-Upstream-Status: Backport [https://github.com/storaged-project/blivet-gui/commit/eb8ec968]
-
-Signed-off-by: Kai Kang <kai.kang@windriver.com>
-
-From eb8ec968d1ee8b4b710568b1eb8536296f90751e Mon Sep 17 00:00:00 2001
-From: Adam Williamson <awilliam@redhat.com>
-Date: Thu, 17 Feb 2022 11:16:22 -0800
-Subject: [PATCH] Use symbolic list-add and edit- icons (Adwaita dropped old
- ones)
-
-adwaita-icon-theme 42 no longer includes the non-symbolic icons
-for these names. The choices are to switch to symbolic ones or
-carry the non-symbolic ones downstream.
-
-Signed-off-by: Adam Williamson <awilliam@redhat.com>
----
- blivetgui/list_actions.py      | 8 ++++----
- blivetgui/processing_window.py | 6 +++---
- 2 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/blivetgui/list_actions.py b/blivetgui/list_actions.py
-index b7c1f9c..5388feb 100644
---- a/blivetgui/list_actions.py
-+++ b/blivetgui/list_actions.py
-@@ -48,10 +48,10 @@ def __init__(self, blivet_gui):
-         self.blivet_gui = blivet_gui
- 
-         icon_theme = Gtk.IconTheme.get_default()  # pylint: disable=no-value-for-parameter
--        icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add", 16, 0)
--        icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete", 16, 0)
--        icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all", 16, 0)
--        icon_misc = Gtk.IconTheme.load_icon(icon_theme, "edit-paste", 16, 0)
-+        icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add-symbolic", 16, 0)
-+        icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete-symbolic", 16, 0)
-+        icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all-symbolic", 16, 0)
-+        icon_misc = Gtk.IconTheme.load_icon(icon_theme, "edit-paste-symbolic", 16, 0)
- 
-         self.action_icons = {"add": icon_add, "delete": icon_delete, "edit": icon_edit,
-                              "misc": icon_misc}
-diff --git a/blivetgui/processing_window.py b/blivetgui/processing_window.py
-index c400f90..a020ae8 100644
---- a/blivetgui/processing_window.py
-+++ b/blivetgui/processing_window.py
-@@ -93,9 +93,9 @@ def add_action_view(self):
-         """
- 
-         icon_theme = Gtk.IconTheme.get_default()  # pylint: disable=no-value-for-parameter
--        icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add", 16, 0)
--        icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete", 16, 0)
--        icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all", 16, 0)
-+        icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add-symbolic", 16, 0)
-+        icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete-symbolic", 16, 0)
-+        icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all-symbolic", 16, 0)
- 
-         actions_list = Gtk.ListStore(GdkPixbuf.Pixbuf, str, GdkPixbuf.Pixbuf)
- 
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
similarity index 61%
rename from meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
rename to meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
index 42bcf4651..b6e04e081 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
@@ -5,20 +5,14 @@  SECTION = "devel/python"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
-S = "${WORKDIR}/git"
-B = "${S}"
+SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=main;protocol=https"
+SRCREV = "9b6a83a7aef546ddacafcc656984c9bbed67a8ec"
 
-SRCREV = "42512ee48494cee71febf04078d9774f0146a085"
-SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=main;protocol=https \
-           file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \
-           file://0002-Use-symbolic-list-add-and-edit-icons.patch \
-           "
+S = "${WORKDIR}/git"
 
-inherit features_check
+inherit features_check setuptools3
 REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data"
 
-inherit setuptools3_legacy python3native
-
 PIP_INSTALL_PACKAGE = "blivet_gui"
 
 RDEPENDS:${PN} = "python3-pygobject python3 \
@@ -26,6 +20,4 @@  RDEPENDS:${PN} = "python3-pygobject python3 \
                   python3-pid libreport \
 "
 
-FILES:${PN} += " \
-    ${datadir}/* \
-    "
+FILES:${PN} += "${datadir}/*"