diff mbox series

[meta-python] python3-nacl: drop duplicate recipe

Message ID 20231101070722.2549598-1-kai.kang@windriver.com
State Under Review
Headers show
Series [meta-python] python3-nacl: drop duplicate recipe | expand

Commit Message

Kai Nov. 1, 2023, 7:07 a.m. UTC
From: Kai Kang <kai.kang@windriver.com>

Recipes python3-nacl and python3-pynacl are exactly the same reipces for
python packge "PyNaCl", so drop the latter one python3-nacl_1.5.0.bb.

And let python3-pynacl rprovides python3-nacl in case it is required by
other recipes. Ajust the order in python3-pynacl as well accord to

https://docs.yoctoproject.org/dev/contributor-guide/recipe-style-guide.html#recipe-ordering

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 .../python/python3-nacl_1.5.0.bb              | 25 -------------------
 .../python/python3-pynacl_1.5.0.bb            | 22 ++++++++--------
 2 files changed, 12 insertions(+), 35 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
deleted file mode 100644
index 7d5292745..000000000
--- a/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
+++ /dev/null
@@ -1,25 +0,0 @@ 
-SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
-HOMEPAGE = "https://github.com/pyca/pynacl"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
-
-PYPI_PACKAGE = "PyNaCl"
-
-inherit pypi setuptools3
-
-SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
-
-DEPENDS += "\
-    libsodium \
-    python3-cffi-native \
-    python3-pip-native \
-"
-
-RDEPENDS:${PN}:class-target += " \
-    python3-cffi \
-    python3-pycparser \
-"
-
-export SODIUM_INSTALL = "system"
-
-BBCLASSEXTEND = "native"
\ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb b/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
index 5a8ed131a..0747c67c1 100644
--- a/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
@@ -10,21 +10,11 @@  PYPI_PACKAGE = "PyNaCl"
 
 inherit pypi python_setuptools_build_meta
 
-# in meta-virtualization layer
-#
-RCONFLICTS:${PN} = "python3-nacl"
-
 DEPENDS += "\
     ${PYTHON_PN}-cffi-native \
     libsodium \
 "
 
-RDEPENDS:${PN} = "\
-    ${PYTHON_PN}-six \
-    ${PYTHON_PN}-cffi \
-    libsodium \
-"
-
 do_compile:prepend() {
     export SODIUM_INSTALL=system
 }
@@ -32,3 +22,15 @@  do_compile:prepend() {
 do_install:prepend() {
     export SODIUM_INSTALL=system
 }
+
+RDEPENDS:${PN} = "\
+    ${PYTHON_PN}-six \
+    ${PYTHON_PN}-cffi \
+    libsodium \
+"
+
+RPROVIDES:${PN} = "python3-nacl"
+
+# in meta-virtualization layer
+#
+RCONFLICTS:${PN} = "python3-nacl"