diff mbox series

[meta-networking] wireguard-tools: Use PACKAGECONFIG to select wg-quick and bashcompletion

Message ID 20231031203328.3372015-1-daiane.angolini@foundries.io
State Under Review
Headers show
Series [meta-networking] wireguard-tools: Use PACKAGECONFIG to select wg-quick and bashcompletion | expand

Commit Message

Daiane Angolini Oct. 31, 2023, 8:33 p.m. UTC
Condition the creation of sub-packages and their consequences to a
PACKAGECONFIG, which can be overriden outside the metalayer.

Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io>
---
 .../wireguard/wireguard-tools_1.0.20210914.bb          | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Khem Raj Nov. 1, 2023, 10:32 p.m. UTC | #1
this fails see
https://errors.yoctoproject.org/Errors/Details/741221/

On Tue, Oct 31, 2023 at 1:33 PM Daiane Angolini via
lists.openembedded.org
<daiane.angolini=foundries.io@lists.openembedded.org> wrote:
>
> Condition the creation of sub-packages and their consequences to a
> PACKAGECONFIG, which can be overriden outside the metalayer.
>
> Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io>
> ---
>  .../wireguard/wireguard-tools_1.0.20210914.bb          | 10 ++++++----
>  1 file changed, 6 insertions(+), 4 deletions(-)
>
> diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
> index 20435338c..44b9eb2f7 100644
> --- a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
> +++ b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
> @@ -11,11 +11,15 @@ do_install () {
>      oe_runmake DESTDIR="${D}" PREFIX="${prefix}" SYSCONFDIR="${sysconfdir}" \
>          SYSTEMDUNITDIR="${systemd_system_unitdir}" \
>          WITH_SYSTEMDUNITS=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'yes', '', d)} \
> -        WITH_BASHCOMPLETION=yes \
> -        WITH_WGQUICK=yes \
> +        ${PACKAGECONFIG_ARGS} \
>          install
>  }
>
> +PACKAGECONFIG ??= "bashcompletion wgquick"
> +
> +PACKAGECONFIG[bashcompletion] = "WITH_BASHCOMPLETION=yes, , , , , "
> +PACKAGECONFIG[wgquick] = "WITH_WGQUICK=yes, , ,${PN} bash,${PN}-wg-quick, "
> +
>  PACKAGES += "${PN}-wg-quick"
>
>  FILES:${PN} = " \
> @@ -27,8 +31,6 @@ FILES:${PN}-wg-quick = " \
>      ${systemd_system_unitdir} \
>  "
>
> -RDEPENDS:${PN}-wg-quick = "${PN} bash"
>  RRECOMMENDS:${PN} = " \
>      kernel-module-wireguard \
> -    ${PN}-wg-quick \
>      "
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105808): https://lists.openembedded.org/g/openembedded-devel/message/105808
> Mute This Topic: https://lists.openembedded.org/mt/102306255/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
index 20435338c..44b9eb2f7 100644
--- a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
@@ -11,11 +11,15 @@  do_install () {
     oe_runmake DESTDIR="${D}" PREFIX="${prefix}" SYSCONFDIR="${sysconfdir}" \
         SYSTEMDUNITDIR="${systemd_system_unitdir}" \
         WITH_SYSTEMDUNITS=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'yes', '', d)} \
-        WITH_BASHCOMPLETION=yes \
-        WITH_WGQUICK=yes \
+        ${PACKAGECONFIG_ARGS} \
         install
 }
 
+PACKAGECONFIG ??= "bashcompletion wgquick"
+
+PACKAGECONFIG[bashcompletion] = "WITH_BASHCOMPLETION=yes, , , , , "
+PACKAGECONFIG[wgquick] = "WITH_WGQUICK=yes, , ,${PN} bash,${PN}-wg-quick, "
+
 PACKAGES += "${PN}-wg-quick"
 
 FILES:${PN} = " \
@@ -27,8 +31,6 @@  FILES:${PN}-wg-quick = " \
     ${systemd_system_unitdir} \
 "
 
-RDEPENDS:${PN}-wg-quick = "${PN} bash"
 RRECOMMENDS:${PN} = " \
     kernel-module-wireguard \
-    ${PN}-wg-quick \
     "