diff mbox series

connectivity: add pcapplusplus recipe

Message ID 20231027150244.231022-1-peron.clem@gmail.com
State Under Review
Headers show
Series connectivity: add pcapplusplus recipe | expand

Commit Message

Clément Péron Oct. 27, 2023, 3:02 p.m. UTC
Add PcapPlusPlus 23.09 recipe.

Signed-off-by: Clément Péron <peron.clem@gmail.com>
---
 .../pcapplusplus/pcapplusplus_23.09.bb        | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 meta-oe/recipes-connectivity/pcapplusplus/pcapplusplus_23.09.bb

Comments

Clément Péron Oct. 27, 2023, 4:50 p.m. UTC | #1
Hi,

Le ven. 27 oct. 2023, 17:02, Clément Péron <peron.clem@gmail.com> a écrit :

> Add PcapPlusPlus 23.09 recipe.
>
> Signed-off-by: Clément Péron <peron.clem@gmail.com>
> ---
>  .../pcapplusplus/pcapplusplus_23.09.bb        | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
>  create mode 100644 meta-oe/recipes-connectivity/pcapplusplus/
> pcapplusplus_23.09.bb
>
> diff --git a/meta-oe/recipes-connectivity/pcapplusplus/
> pcapplusplus_23.09.bb b/meta-oe/recipes-connectivity/pcapplusplus/
> pcapplusplus_23.09.bb
> new file mode 100644
> index 000000000..90f18b7aa
> --- /dev/null
> +++ b/meta-oe/recipes-connectivity/pcapplusplus/pcapplusplus_23.09.bb
> @@ -0,0 +1,19 @@
> +SUMMARY = "A multiplatform C++ library for capturing, parsing and
> crafting of network packets"
> +HOMEPAGE = "https://pcapplusplus.github.io/"
> +BUGTRACKER = "https://github.com/seladb/PcapPlusPlus/issues"
> +SECTION = "libs/network"
> +LICENSE = "Unlicense"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=911690f51af322440237a253d695d19f"
> +
> +DEPENDS = "libpcap"
> +
> +SRC_URI = "git://
> github.com/seladb/PcapPlusPlus.git;protocol=https;branch=master"
> +SRCREV = "4cf8ed44f9dd145f874dc1dd747dfefcfcab75be"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit cmake
> +
> +PACKAGECONFIG ??= "shared"
> +PACKAGECONFIG[zstd] =
> "-DLIGHT_PCAPNG_ZSTD=ON,-DLIGHT_PCAPNG_ZSTD=OFF,zstd"
> +PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF


I will send a v2 to also disable Tests and Examples binaries in the package

Regards
diff mbox series

Patch

diff --git a/meta-oe/recipes-connectivity/pcapplusplus/pcapplusplus_23.09.bb b/meta-oe/recipes-connectivity/pcapplusplus/pcapplusplus_23.09.bb
new file mode 100644
index 000000000..90f18b7aa
--- /dev/null
+++ b/meta-oe/recipes-connectivity/pcapplusplus/pcapplusplus_23.09.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "A multiplatform C++ library for capturing, parsing and crafting of network packets"
+HOMEPAGE = "https://pcapplusplus.github.io/"
+BUGTRACKER = "https://github.com/seladb/PcapPlusPlus/issues"
+SECTION = "libs/network"
+LICENSE = "Unlicense"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=911690f51af322440237a253d695d19f"
+
+DEPENDS = "libpcap"
+
+SRC_URI = "git://github.com/seladb/PcapPlusPlus.git;protocol=https;branch=master"
+SRCREV = "4cf8ed44f9dd145f874dc1dd747dfefcfcab75be"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ??= "shared"
+PACKAGECONFIG[zstd] = "-DLIGHT_PCAPNG_ZSTD=ON,-DLIGHT_PCAPNG_ZSTD=OFF,zstd"
+PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF"