diff mbox series

[meta-oe,2/2] debsums: remove old recipe

Message ID 20231019011326.3535316-2-ticotimo@gmail.com
State Under Review
Headers show
Series [meta-perl,1/2] po4a: remove old recipe | expand

Commit Message

Tim Orling Oct. 19, 2023, 1:13 a.m. UTC
The debsums recipe has not been substantially touched since 2020
when it was moved to dynamic-layers.

In meta-openembedded ecosystem, it is the only known recipe that
depends on po4a, which is being removed in a separate commit.

According to the layerindex, no known recipes depend on debsums:
https://layers.openembedded.org/layerindex/branch/master/recipes/?q=depends%3Adebsums

Signed-off-by: Tim Orling <ticotimo@gmail.com>
---
 .../packagegroup-meta-oe.bbappend             |  2 +-
 .../recipes-support/debsums/debsums_2.2.2.bb  | 56 -------------------
 2 files changed, 1 insertion(+), 57 deletions(-)
 delete mode 100644 meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb

Comments

Khem Raj Oct. 19, 2023, 3:30 a.m. UTC | #1
Adding Tom since he added it back in 2017.

On Wed, Oct 18, 2023 at 6:14 PM Tim Orling <ticotimo@gmail.com> wrote:
>
> The debsums recipe has not been substantially touched since 2020
> when it was moved to dynamic-layers.
>
> In meta-openembedded ecosystem, it is the only known recipe that
> depends on po4a, which is being removed in a separate commit.
>
> According to the layerindex, no known recipes depend on debsums:
> https://layers.openembedded.org/layerindex/branch/master/recipes/?q=depends%3Adebsums
>
> Signed-off-by: Tim Orling <ticotimo@gmail.com>
> ---
>  .../packagegroup-meta-oe.bbappend             |  2 +-
>  .../recipes-support/debsums/debsums_2.2.2.bb  | 56 -------------------
>  2 files changed, 1 insertion(+), 57 deletions(-)
>  delete mode 100644 meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
>
> diff --git a/meta-oe/dynamic-layers/perl-layer/recipes-core/packagegroups/packagegroup-meta-oe.bbappend b/meta-oe/dynamic-layers/perl-layer/recipes-core/packagegroups/packagegroup-meta-oe.bbappend
> index 8cb8d22a2..5c48fd5c0 100644
> --- a/meta-oe/dynamic-layers/perl-layer/recipes-core/packagegroups/packagegroup-meta-oe.bbappend
> +++ b/meta-oe/dynamic-layers/perl-layer/recipes-core/packagegroups/packagegroup-meta-oe.bbappend
> @@ -1 +1 @@
> -RDEPENDS:packagegroup-meta-oe-support += "debsums rasdaemon"
> +RDEPENDS:packagegroup-meta-oe-support += "rasdaemon"
> diff --git a/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb b/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
> deleted file mode 100644
> index 252db1994..000000000
> --- a/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
> +++ /dev/null
> @@ -1,56 +0,0 @@
> -SUMMARY = "Miscellaneous utilities specific to Debian"
> -SUMMARY:${PN}-cron = "Cron scripts to control automatic debsum checking"
> -DESCRIPTION = "A tool for verification of installed package files against \
> -MD5 checksums debsums can verify the integrity of installed package files \
> -against MD5 checksums installed by the package, or generated from a .deb \
> -archive."
> -DESCRIPTION:${PN}-cron = "Cron scripts to control automatic system integrity \
> -checking via debsums."
> -SECTION = "base"
> -LICENSE = "GPL-2.0-only"
> -LIC_FILES_CHKSUM = "file://debian/copyright;md5=770d751553e6559e9eaefd2e11ccf7e9"
> -
> -SRC_URI = "http://snapshot.debian.org/archive/debian/20170530T212108Z/pool/main/d/debsums/debsums_2.2.2.tar.xz"
> -SRC_URI[md5sum] = "82b0710855a7e5212d4358163a269e79"
> -SRC_URI[sha256sum] = "aa61896f93a6bbfe0161c21dcd67529ae8e1ec8c3ccf244523c52c4ad8253d97"
> -
> -# the package is taken from snapshots.debian.org; that source is static and goes stale
> -# so we check the latest upstream from a directory that does get updated
> -UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
> -
> -inherit perlnative gettext
> -
> -DEPENDS += "po4a-native"
> -
> -do_install() {
> -        install -d ${D}/${sysconfdir}/cron.daily ${D}/${sysconfdir}/cron.weekly
> -        install -d ${D}/${sysconfdir}/cron.monthly ${D}${sbindir} ${D}${bindir}
> -        install -d ${D}${mandir}/man1 ${D}${mandir}/man8
> -        install -m 0755 debsums ${D}${bindir}/
> -        install -m 0755 rdebsums ${D}${bindir}/
> -        install -m 0755 debsums_init ${D}${sbindir}
> -        install -m 0644 man/debsums.1 ${D}${mandir}/man1/
> -        install -m 0644 man/rdebsums.1 ${D}${mandir}/man1/
> -        install -m 0644 man/debsums_init.8 ${D}${mandir}/man8/
> -        install -m 0644 debian/cron.daily \
> -                ${D}/${sysconfdir}/cron.daily/debsums
> -        install -m 0644 debian/cron.weekly \
> -                ${D}/${sysconfdir}/cron.weekly/debsums
> -        install -m 0644 debian/cron.monthly \
> -                ${D}/${sysconfdir}/cron.monthly/debsums
> -        # Must exist, defaults to empty.
> -        touch ${D}/${sysconfdir}/debsums-ignore
> -}
> -
> -PACKAGES =+ "${PN}-cron"
> -
> -RDEPENDS:${PN} = "dpkg dpkg-perl libfile-fnmatch-perl perl \
> -                  perl-module-constant perl-module-digest-md5 \
> -                  perl-module-errno perl-module-fcntl \
> -                  perl-module-file-basename perl-module-file-copy \
> -                  perl-module-file-find perl-module-file-glob \
> -                  perl-module-file-path perl-module-file-spec \
> -                  perl-module-file-temp perl-module-getopt-long \
> -                  perl-module-posix"
> -
> -FILES:${PN}-cron = "${sysconfdir}/cron.*"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105587): https://lists.openembedded.org/g/openembedded-devel/message/105587
> Mute This Topic: https://lists.openembedded.org/mt/102052093/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Tom Rini Oct. 19, 2023, 1:45 p.m. UTC | #2
On Wed, Oct 18, 2023 at 08:30:27PM -0700, Khem Raj wrote:
> Adding Tom since he added it back in 2017.
> 
> On Wed, Oct 18, 2023 at 6:14 PM Tim Orling <ticotimo@gmail.com> wrote:
> >
> > The debsums recipe has not been substantially touched since 2020
> > when it was moved to dynamic-layers.
> >
> > In meta-openembedded ecosystem, it is the only known recipe that
> > depends on po4a, which is being removed in a separate commit.
> >
> > According to the layerindex, no known recipes depend on debsums:
> > https://layers.openembedded.org/layerindex/branch/master/recipes/?q=depends%3Adebsums
> >
> > Signed-off-by: Tim Orling <ticotimo@gmail.com>

Thanks for checking.  We no longer have a use case for this recipe.

Acked-by: Tom Rini <trini@konsulko.com>
diff mbox series

Patch

diff --git a/meta-oe/dynamic-layers/perl-layer/recipes-core/packagegroups/packagegroup-meta-oe.bbappend b/meta-oe/dynamic-layers/perl-layer/recipes-core/packagegroups/packagegroup-meta-oe.bbappend
index 8cb8d22a2..5c48fd5c0 100644
--- a/meta-oe/dynamic-layers/perl-layer/recipes-core/packagegroups/packagegroup-meta-oe.bbappend
+++ b/meta-oe/dynamic-layers/perl-layer/recipes-core/packagegroups/packagegroup-meta-oe.bbappend
@@ -1 +1 @@ 
-RDEPENDS:packagegroup-meta-oe-support += "debsums rasdaemon"
+RDEPENDS:packagegroup-meta-oe-support += "rasdaemon"
diff --git a/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb b/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
deleted file mode 100644
index 252db1994..000000000
--- a/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
+++ /dev/null
@@ -1,56 +0,0 @@ 
-SUMMARY = "Miscellaneous utilities specific to Debian"
-SUMMARY:${PN}-cron = "Cron scripts to control automatic debsum checking"
-DESCRIPTION = "A tool for verification of installed package files against \
-MD5 checksums debsums can verify the integrity of installed package files \
-against MD5 checksums installed by the package, or generated from a .deb \
-archive."
-DESCRIPTION:${PN}-cron = "Cron scripts to control automatic system integrity \
-checking via debsums."
-SECTION = "base"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://debian/copyright;md5=770d751553e6559e9eaefd2e11ccf7e9"
-
-SRC_URI = "http://snapshot.debian.org/archive/debian/20170530T212108Z/pool/main/d/debsums/debsums_2.2.2.tar.xz"
-SRC_URI[md5sum] = "82b0710855a7e5212d4358163a269e79"
-SRC_URI[sha256sum] = "aa61896f93a6bbfe0161c21dcd67529ae8e1ec8c3ccf244523c52c4ad8253d97"
-
-# the package is taken from snapshots.debian.org; that source is static and goes stale
-# so we check the latest upstream from a directory that does get updated
-UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
-
-inherit perlnative gettext
-
-DEPENDS += "po4a-native"
-
-do_install() {
-        install -d ${D}/${sysconfdir}/cron.daily ${D}/${sysconfdir}/cron.weekly
-        install -d ${D}/${sysconfdir}/cron.monthly ${D}${sbindir} ${D}${bindir}
-        install -d ${D}${mandir}/man1 ${D}${mandir}/man8
-        install -m 0755 debsums ${D}${bindir}/
-        install -m 0755 rdebsums ${D}${bindir}/
-        install -m 0755 debsums_init ${D}${sbindir}
-        install -m 0644 man/debsums.1 ${D}${mandir}/man1/
-        install -m 0644 man/rdebsums.1 ${D}${mandir}/man1/
-        install -m 0644 man/debsums_init.8 ${D}${mandir}/man8/
-        install -m 0644 debian/cron.daily \
-                ${D}/${sysconfdir}/cron.daily/debsums
-        install -m 0644 debian/cron.weekly \
-                ${D}/${sysconfdir}/cron.weekly/debsums
-        install -m 0644 debian/cron.monthly \
-                ${D}/${sysconfdir}/cron.monthly/debsums
-        # Must exist, defaults to empty.
-        touch ${D}/${sysconfdir}/debsums-ignore
-}
-
-PACKAGES =+ "${PN}-cron"
-
-RDEPENDS:${PN} = "dpkg dpkg-perl libfile-fnmatch-perl perl \
-                  perl-module-constant perl-module-digest-md5 \
-                  perl-module-errno perl-module-fcntl \
-                  perl-module-file-basename perl-module-file-copy \
-                  perl-module-file-find perl-module-file-glob \
-                  perl-module-file-path perl-module-file-spec \
-                  perl-module-file-temp perl-module-getopt-long \
-                  perl-module-posix"
-
-FILES:${PN}-cron = "${sysconfdir}/cron.*"