diff mbox series

[meta-python,3/3] python3-pylint: Upgrade to 3.0.0

Message ID 20231003042313.1153843-3-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/3] python3-pyroute2: Add missing dependency on sqlite3 for ptests | expand

Commit Message

Khem Raj Oct. 3, 2023, 4:23 a.m. UTC
Package additional hidden files for ptests (test_primer.py)

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...001-pylint-remove-plugin-pickle-test.patch | 53 -------------------
 ....toml-Remove-hard-coded-dependencies.patch | 26 ---------
 ...lint_2.17.4.bb => python3-pylint_3.0.0.bb} |  5 +-
 3 files changed, 2 insertions(+), 82 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
 delete mode 100644 meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
 rename meta-python/recipes-devtools/python/{python3-pylint_2.17.4.bb => python3-pylint_3.0.0.bb} (89%)

Comments

Daniel McGregor Oct. 10, 2023, 6:34 p.m. UTC | #1
I think these changes should be cherry-picked to nanbield. It's got
the update for astroid to v3.0.0, and that breaks pylint on that
branch.

On Mon, 2 Oct 2023 at 22:23, Khem Raj <raj.khem@gmail.com> wrote:
>
> Package additional hidden files for ptests (test_primer.py)
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  ...001-pylint-remove-plugin-pickle-test.patch | 53 -------------------
>  ....toml-Remove-hard-coded-dependencies.patch | 26 ---------
>  ...lint_2.17.4.bb => python3-pylint_3.0.0.bb} |  5 +-
>  3 files changed, 2 insertions(+), 82 deletions(-)
>  delete mode 100644 meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
>  delete mode 100644 meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
>  rename meta-python/recipes-devtools/python/{python3-pylint_2.17.4.bb => python3-pylint_3.0.0.bb} (89%)
>
> diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
> deleted file mode 100644
> index a7637a5ca6..0000000000
> --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
> +++ /dev/null
> @@ -1,53 +0,0 @@
> -From 341e19dd69d847f84859e85cabff5846e7da24c4 Mon Sep 17 00:00:00 2001
> -From: Trevor Gamblin <tgamblin@baylibre.com>
> -Date: Mon, 15 May 2023 09:26:04 -0400
> -Subject: [PATCH] pylint: remove plugin pickle test
> -
> -Upstream-Status: Inappropriate (oe-specific)
> -
> -Upstream uses an assertion in the removed test to state that the test
> -needs changing if the plugin loading succeeds. The same failure wasn't
> -seen when running the tests on the host with pytest, so disable it by
> -removing the test from the suite.
> -
> -Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> ----
> - tests/test_check_parallel.py | 22 ----------------------
> - 1 file changed, 22 deletions(-)
> -
> -diff --git a/tests/test_check_parallel.py b/tests/test_check_parallel.py
> -index d56502eaf..34fec140f 100644
> ---- a/tests/test_check_parallel.py
> -+++ b/tests/test_check_parallel.py
> -@@ -257,28 +257,6 @@ class TestCheckParallelFramework:
> -         assert stats.statement == 18
> -         assert stats.warning == 0
> -
> --    def test_linter_with_unpickleable_plugins_is_pickleable(self) -> None:
> --        """The linter needs to be pickle-able in order to be passed between workers"""
> --        linter = PyLinter(reporter=Reporter())
> --        # We load an extension that we know is not pickle-safe
> --        linter.load_plugin_modules(["pylint.extensions.overlapping_exceptions"])
> --        try:
> --            dill.dumps(linter)
> --            raise AssertionError(
> --                "Plugins loaded were pickle-safe! This test needs altering"
> --            )
> --        except (KeyError, TypeError, PickleError, NotImplementedError):
> --            pass
> --
> --        # And expect this call to make it pickle-able
> --        linter.load_plugin_configuration()
> --        try:
> --            dill.dumps(linter)
> --        except KeyError as exc:
> --            raise AssertionError(
> --                "Cannot pickle linter when using non-pickleable plugin"
> --            ) from exc
> --
> -     def test_worker_check_sequential_checker(self) -> None:
> -         """Same as test_worker_check_single_file_no_checkers with SequentialTestChecker."""
> -         linter = PyLinter(reporter=Reporter())
> ---
> -2.40.1
> -
> diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> deleted file mode 100644
> index 7950e72077..0000000000
> --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> +++ /dev/null
> @@ -1,26 +0,0 @@
> -From c5c415a240189ac6730ba95de0bb5883dfb53609 Mon Sep 17 00:00:00 2001
> -From: Trevor Gamblin <tgamblin@baylibre.com>
> -Date: Mon, 1 May 2023 11:32:24 -0400
> -Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies
> -
> -Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> ----
> -Upstream-Status: Pending
> -
> - pyproject.toml | 2 +-
> - 1 file changed, 1 insertion(+), 1 deletion(-)
> -
> -diff --git a/pyproject.toml b/pyproject.toml
> -index bd542646b..2c0ed9485 100644
> ---- a/pyproject.toml
> -+++ b/pyproject.toml
> -@@ -1,5 +1,5 @@
> - [build-system]
> --requires = ["setuptools~=62.6", "wheel~=0.37.1"]
> -+requires = ["setuptools", "wheel"]
> - build-backend = "setuptools.build_meta"
> -
> - [project]
> ---
> -2.40.0
> -
> diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> similarity index 89%
> rename from meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb
> rename to meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> index 96fce2e048..413e6599db 100644
> --- a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb
> +++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> @@ -6,10 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
>  SRC_URI += " \
>          git://github.com/pylint-dev/pylint;branch=main;protocol=https \
>          file://run-ptest \
> -        file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \
> -        file://0001-pylint-remove-plugin-pickle-test.patch \
>          "
> -SRCREV ?= "fc34a4b6abe56f3ac07ca15d846b1c1955545f85"
> +SRCREV ?= "4a7ad5ea9f1c5a98ccf736578a00554be0da6dc7"
>
>  inherit python_setuptools_build_meta ptest
>
> @@ -47,5 +45,6 @@ S = "${WORKDIR}/git"
>  do_install_ptest() {
>      install -d ${D}${PTEST_PATH}/tests
>      cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
> +    install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
>      sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
>  }
> --
> 2.42.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105316): https://lists.openembedded.org/g/openembedded-devel/message/105316
> Mute This Topic: https://lists.openembedded.org/mt/101728502/3617261
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [danismostlikely@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Oct. 10, 2023, 6:59 p.m. UTC | #2
On Tue, Oct 10, 2023 at 11:35 AM Dan McGregor <danismostlikely@gmail.com> wrote:
>
> I think these changes should be cherry-picked to nanbield. It's got
> the update for astroid to v3.0.0, and that breaks pylint on that
> branch.
>

yes Armin is working on syncing nanbield to latest master.
have you tried nanbield-next ?

> On Mon, 2 Oct 2023 at 22:23, Khem Raj <raj.khem@gmail.com> wrote:
> >
> > Package additional hidden files for ptests (test_primer.py)
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> >  ...001-pylint-remove-plugin-pickle-test.patch | 53 -------------------
> >  ....toml-Remove-hard-coded-dependencies.patch | 26 ---------
> >  ...lint_2.17.4.bb => python3-pylint_3.0.0.bb} |  5 +-
> >  3 files changed, 2 insertions(+), 82 deletions(-)
> >  delete mode 100644 meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
> >  delete mode 100644 meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> >  rename meta-python/recipes-devtools/python/{python3-pylint_2.17.4.bb => python3-pylint_3.0.0.bb} (89%)
> >
> > diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
> > deleted file mode 100644
> > index a7637a5ca6..0000000000
> > --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
> > +++ /dev/null
> > @@ -1,53 +0,0 @@
> > -From 341e19dd69d847f84859e85cabff5846e7da24c4 Mon Sep 17 00:00:00 2001
> > -From: Trevor Gamblin <tgamblin@baylibre.com>
> > -Date: Mon, 15 May 2023 09:26:04 -0400
> > -Subject: [PATCH] pylint: remove plugin pickle test
> > -
> > -Upstream-Status: Inappropriate (oe-specific)
> > -
> > -Upstream uses an assertion in the removed test to state that the test
> > -needs changing if the plugin loading succeeds. The same failure wasn't
> > -seen when running the tests on the host with pytest, so disable it by
> > -removing the test from the suite.
> > -
> > -Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > ----
> > - tests/test_check_parallel.py | 22 ----------------------
> > - 1 file changed, 22 deletions(-)
> > -
> > -diff --git a/tests/test_check_parallel.py b/tests/test_check_parallel.py
> > -index d56502eaf..34fec140f 100644
> > ---- a/tests/test_check_parallel.py
> > -+++ b/tests/test_check_parallel.py
> > -@@ -257,28 +257,6 @@ class TestCheckParallelFramework:
> > -         assert stats.statement == 18
> > -         assert stats.warning == 0
> > -
> > --    def test_linter_with_unpickleable_plugins_is_pickleable(self) -> None:
> > --        """The linter needs to be pickle-able in order to be passed between workers"""
> > --        linter = PyLinter(reporter=Reporter())
> > --        # We load an extension that we know is not pickle-safe
> > --        linter.load_plugin_modules(["pylint.extensions.overlapping_exceptions"])
> > --        try:
> > --            dill.dumps(linter)
> > --            raise AssertionError(
> > --                "Plugins loaded were pickle-safe! This test needs altering"
> > --            )
> > --        except (KeyError, TypeError, PickleError, NotImplementedError):
> > --            pass
> > --
> > --        # And expect this call to make it pickle-able
> > --        linter.load_plugin_configuration()
> > --        try:
> > --            dill.dumps(linter)
> > --        except KeyError as exc:
> > --            raise AssertionError(
> > --                "Cannot pickle linter when using non-pickleable plugin"
> > --            ) from exc
> > --
> > -     def test_worker_check_sequential_checker(self) -> None:
> > -         """Same as test_worker_check_single_file_no_checkers with SequentialTestChecker."""
> > -         linter = PyLinter(reporter=Reporter())
> > ---
> > -2.40.1
> > -
> > diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> > deleted file mode 100644
> > index 7950e72077..0000000000
> > --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> > +++ /dev/null
> > @@ -1,26 +0,0 @@
> > -From c5c415a240189ac6730ba95de0bb5883dfb53609 Mon Sep 17 00:00:00 2001
> > -From: Trevor Gamblin <tgamblin@baylibre.com>
> > -Date: Mon, 1 May 2023 11:32:24 -0400
> > -Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies
> > -
> > -Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > ----
> > -Upstream-Status: Pending
> > -
> > - pyproject.toml | 2 +-
> > - 1 file changed, 1 insertion(+), 1 deletion(-)
> > -
> > -diff --git a/pyproject.toml b/pyproject.toml
> > -index bd542646b..2c0ed9485 100644
> > ---- a/pyproject.toml
> > -+++ b/pyproject.toml
> > -@@ -1,5 +1,5 @@
> > - [build-system]
> > --requires = ["setuptools~=62.6", "wheel~=0.37.1"]
> > -+requires = ["setuptools", "wheel"]
> > - build-backend = "setuptools.build_meta"
> > -
> > - [project]
> > ---
> > -2.40.0
> > -
> > diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> > similarity index 89%
> > rename from meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb
> > rename to meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> > index 96fce2e048..413e6599db 100644
> > --- a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb
> > +++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> > @@ -6,10 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
> >  SRC_URI += " \
> >          git://github.com/pylint-dev/pylint;branch=main;protocol=https \
> >          file://run-ptest \
> > -        file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \
> > -        file://0001-pylint-remove-plugin-pickle-test.patch \
> >          "
> > -SRCREV ?= "fc34a4b6abe56f3ac07ca15d846b1c1955545f85"
> > +SRCREV ?= "4a7ad5ea9f1c5a98ccf736578a00554be0da6dc7"
> >
> >  inherit python_setuptools_build_meta ptest
> >
> > @@ -47,5 +45,6 @@ S = "${WORKDIR}/git"
> >  do_install_ptest() {
> >      install -d ${D}${PTEST_PATH}/tests
> >      cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
> > +    install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
> >      sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
> >  }
> > --
> > 2.42.0
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#105316): https://lists.openembedded.org/g/openembedded-devel/message/105316
> > Mute This Topic: https://lists.openembedded.org/mt/101728502/3617261
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [danismostlikely@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Daniel McGregor Oct. 10, 2023, 7:49 p.m. UTC | #3
On Tue, 10 Oct 2023 at 12:59, Khem Raj <raj.khem@gmail.com> wrote:
>
> On Tue, Oct 10, 2023 at 11:35 AM Dan McGregor <danismostlikely@gmail.com> wrote:
> >
> > I think these changes should be cherry-picked to nanbield. It's got
> > the update for astroid to v3.0.0, and that breaks pylint on that
> > branch.
> >
>
> yes Armin is working on syncing nanbield to latest master.
> have you tried nanbield-next ?

Not yet. I've been testing against nanbield. But so far nanbield-next
lacks pylint 3. If I revert the astroids change it works as expected,
though.

>
> > On Mon, 2 Oct 2023 at 22:23, Khem Raj <raj.khem@gmail.com> wrote:
> > >
> > > Package additional hidden files for ptests (test_primer.py)
> > >
> > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > ---
> > >  ...001-pylint-remove-plugin-pickle-test.patch | 53 -------------------
> > >  ....toml-Remove-hard-coded-dependencies.patch | 26 ---------
> > >  ...lint_2.17.4.bb => python3-pylint_3.0.0.bb} |  5 +-
> > >  3 files changed, 2 insertions(+), 82 deletions(-)
> > >  delete mode 100644 meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
> > >  delete mode 100644 meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> > >  rename meta-python/recipes-devtools/python/{python3-pylint_2.17.4.bb => python3-pylint_3.0.0.bb} (89%)
> > >
> > > diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
> > > deleted file mode 100644
> > > index a7637a5ca6..0000000000
> > > --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
> > > +++ /dev/null
> > > @@ -1,53 +0,0 @@
> > > -From 341e19dd69d847f84859e85cabff5846e7da24c4 Mon Sep 17 00:00:00 2001
> > > -From: Trevor Gamblin <tgamblin@baylibre.com>
> > > -Date: Mon, 15 May 2023 09:26:04 -0400
> > > -Subject: [PATCH] pylint: remove plugin pickle test
> > > -
> > > -Upstream-Status: Inappropriate (oe-specific)
> > > -
> > > -Upstream uses an assertion in the removed test to state that the test
> > > -needs changing if the plugin loading succeeds. The same failure wasn't
> > > -seen when running the tests on the host with pytest, so disable it by
> > > -removing the test from the suite.
> > > -
> > > -Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > > ----
> > > - tests/test_check_parallel.py | 22 ----------------------
> > > - 1 file changed, 22 deletions(-)
> > > -
> > > -diff --git a/tests/test_check_parallel.py b/tests/test_check_parallel.py
> > > -index d56502eaf..34fec140f 100644
> > > ---- a/tests/test_check_parallel.py
> > > -+++ b/tests/test_check_parallel.py
> > > -@@ -257,28 +257,6 @@ class TestCheckParallelFramework:
> > > -         assert stats.statement == 18
> > > -         assert stats.warning == 0
> > > -
> > > --    def test_linter_with_unpickleable_plugins_is_pickleable(self) -> None:
> > > --        """The linter needs to be pickle-able in order to be passed between workers"""
> > > --        linter = PyLinter(reporter=Reporter())
> > > --        # We load an extension that we know is not pickle-safe
> > > --        linter.load_plugin_modules(["pylint.extensions.overlapping_exceptions"])
> > > --        try:
> > > --            dill.dumps(linter)
> > > --            raise AssertionError(
> > > --                "Plugins loaded were pickle-safe! This test needs altering"
> > > --            )
> > > --        except (KeyError, TypeError, PickleError, NotImplementedError):
> > > --            pass
> > > --
> > > --        # And expect this call to make it pickle-able
> > > --        linter.load_plugin_configuration()
> > > --        try:
> > > --            dill.dumps(linter)
> > > --        except KeyError as exc:
> > > --            raise AssertionError(
> > > --                "Cannot pickle linter when using non-pickleable plugin"
> > > --            ) from exc
> > > --
> > > -     def test_worker_check_sequential_checker(self) -> None:
> > > -         """Same as test_worker_check_single_file_no_checkers with SequentialTestChecker."""
> > > -         linter = PyLinter(reporter=Reporter())
> > > ---
> > > -2.40.1
> > > -
> > > diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> > > deleted file mode 100644
> > > index 7950e72077..0000000000
> > > --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> > > +++ /dev/null
> > > @@ -1,26 +0,0 @@
> > > -From c5c415a240189ac6730ba95de0bb5883dfb53609 Mon Sep 17 00:00:00 2001
> > > -From: Trevor Gamblin <tgamblin@baylibre.com>
> > > -Date: Mon, 1 May 2023 11:32:24 -0400
> > > -Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies
> > > -
> > > -Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > > ----
> > > -Upstream-Status: Pending
> > > -
> > > - pyproject.toml | 2 +-
> > > - 1 file changed, 1 insertion(+), 1 deletion(-)
> > > -
> > > -diff --git a/pyproject.toml b/pyproject.toml
> > > -index bd542646b..2c0ed9485 100644
> > > ---- a/pyproject.toml
> > > -+++ b/pyproject.toml
> > > -@@ -1,5 +1,5 @@
> > > - [build-system]
> > > --requires = ["setuptools~=62.6", "wheel~=0.37.1"]
> > > -+requires = ["setuptools", "wheel"]
> > > - build-backend = "setuptools.build_meta"
> > > -
> > > - [project]
> > > ---
> > > -2.40.0
> > > -
> > > diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> > > similarity index 89%
> > > rename from meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb
> > > rename to meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> > > index 96fce2e048..413e6599db 100644
> > > --- a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb
> > > +++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
> > > @@ -6,10 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
> > >  SRC_URI += " \
> > >          git://github.com/pylint-dev/pylint;branch=main;protocol=https \
> > >          file://run-ptest \
> > > -        file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \
> > > -        file://0001-pylint-remove-plugin-pickle-test.patch \
> > >          "
> > > -SRCREV ?= "fc34a4b6abe56f3ac07ca15d846b1c1955545f85"
> > > +SRCREV ?= "4a7ad5ea9f1c5a98ccf736578a00554be0da6dc7"
> > >
> > >  inherit python_setuptools_build_meta ptest
> > >
> > > @@ -47,5 +45,6 @@ S = "${WORKDIR}/git"
> > >  do_install_ptest() {
> > >      install -d ${D}${PTEST_PATH}/tests
> > >      cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
> > > +    install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
> > >      sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
> > >  }
> > > --
> > > 2.42.0
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#105316): https://lists.openembedded.org/g/openembedded-devel/message/105316
> > > Mute This Topic: https://lists.openembedded.org/mt/101728502/3617261
> > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [danismostlikely@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
deleted file mode 100644
index a7637a5ca6..0000000000
--- a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
+++ /dev/null
@@ -1,53 +0,0 @@ 
-From 341e19dd69d847f84859e85cabff5846e7da24c4 Mon Sep 17 00:00:00 2001
-From: Trevor Gamblin <tgamblin@baylibre.com>
-Date: Mon, 15 May 2023 09:26:04 -0400
-Subject: [PATCH] pylint: remove plugin pickle test
-
-Upstream-Status: Inappropriate (oe-specific)
-
-Upstream uses an assertion in the removed test to state that the test
-needs changing if the plugin loading succeeds. The same failure wasn't
-seen when running the tests on the host with pytest, so disable it by
-removing the test from the suite.
-
-Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
----
- tests/test_check_parallel.py | 22 ----------------------
- 1 file changed, 22 deletions(-)
-
-diff --git a/tests/test_check_parallel.py b/tests/test_check_parallel.py
-index d56502eaf..34fec140f 100644
---- a/tests/test_check_parallel.py
-+++ b/tests/test_check_parallel.py
-@@ -257,28 +257,6 @@ class TestCheckParallelFramework:
-         assert stats.statement == 18
-         assert stats.warning == 0
- 
--    def test_linter_with_unpickleable_plugins_is_pickleable(self) -> None:
--        """The linter needs to be pickle-able in order to be passed between workers"""
--        linter = PyLinter(reporter=Reporter())
--        # We load an extension that we know is not pickle-safe
--        linter.load_plugin_modules(["pylint.extensions.overlapping_exceptions"])
--        try:
--            dill.dumps(linter)
--            raise AssertionError(
--                "Plugins loaded were pickle-safe! This test needs altering"
--            )
--        except (KeyError, TypeError, PickleError, NotImplementedError):
--            pass
--
--        # And expect this call to make it pickle-able
--        linter.load_plugin_configuration()
--        try:
--            dill.dumps(linter)
--        except KeyError as exc:
--            raise AssertionError(
--                "Cannot pickle linter when using non-pickleable plugin"
--            ) from exc
--
-     def test_worker_check_sequential_checker(self) -> None:
-         """Same as test_worker_check_single_file_no_checkers with SequentialTestChecker."""
-         linter = PyLinter(reporter=Reporter())
--- 
-2.40.1
-
diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
deleted file mode 100644
index 7950e72077..0000000000
--- a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
+++ /dev/null
@@ -1,26 +0,0 @@ 
-From c5c415a240189ac6730ba95de0bb5883dfb53609 Mon Sep 17 00:00:00 2001
-From: Trevor Gamblin <tgamblin@baylibre.com>
-Date: Mon, 1 May 2023 11:32:24 -0400
-Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies
-
-Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
----
-Upstream-Status: Pending
-
- pyproject.toml | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pyproject.toml b/pyproject.toml
-index bd542646b..2c0ed9485 100644
---- a/pyproject.toml
-+++ b/pyproject.toml
-@@ -1,5 +1,5 @@
- [build-system]
--requires = ["setuptools~=62.6", "wheel~=0.37.1"]
-+requires = ["setuptools", "wheel"]
- build-backend = "setuptools.build_meta"
- 
- [project]
--- 
-2.40.0
-
diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb
rename to meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
index 96fce2e048..413e6599db 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
@@ -6,10 +6,8 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
 SRC_URI += " \
         git://github.com/pylint-dev/pylint;branch=main;protocol=https \
         file://run-ptest \
-        file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \
-        file://0001-pylint-remove-plugin-pickle-test.patch \
         "
-SRCREV ?= "fc34a4b6abe56f3ac07ca15d846b1c1955545f85"
+SRCREV ?= "4a7ad5ea9f1c5a98ccf736578a00554be0da6dc7"
 
 inherit python_setuptools_build_meta ptest
 
@@ -47,5 +45,6 @@  S = "${WORKDIR}/git"
 do_install_ptest() {
     install -d ${D}${PTEST_PATH}/tests
     cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+    install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
     sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
 }