diff mbox series

[meta-python,2/2] python3-boto3: add recipe for latest version of boto3

Message ID 20230929214903.2144891-2-derek@asterius.io
State Under Review
Headers show
Series [meta-python,1/2] python3-botocore: add recipe for latest version of botocore | expand

Commit Message

Derek Straka Sept. 29, 2023, 9:49 p.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../python/python3-boto3_1.28.57.bb              | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-boto3_1.28.57.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-boto3_1.28.57.bb b/meta-python/recipes-devtools/python/python3-boto3_1.28.57.bb
new file mode 100644
index 000000000..ad40fd0d0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-boto3_1.28.57.bb
@@ -0,0 +1,16 @@ 
+HOMEPAGE = "https://github.com/boto/boto"
+SUMMARY = "Amazon Web Services API"
+DESCRIPTION = "\
+  Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK) for Python, \
+  which allows Python developers to write software that makes use of services like \
+  Amazon S3 and Amazon EC2. \
+  "
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[sha256sum] = "e2d2824ba6459b330d097e94039a9c4f96ae3f4bcdc731d620589ad79dcd16d3"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-botocore python3-urllib3 python3-unixadmin"