diff mbox series

[meta-python] python3-nacl: Add recipe for the latest release of PyNaCl

Message ID 20230929213521.2140103-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-nacl: Add recipe for the latest release of PyNaCl | expand

Commit Message

Derek Straka Sept. 29, 2023, 9:35 p.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../python/python3-nacl_1.5.0.bb              | 25 +++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb

Comments

Kai Nov. 1, 2023, 2:31 a.m. UTC | #1
On 9/30/23 05:35, Derek Straka wrote:
> Signed-off-by: Derek Straka <derek@asterius.io>
> ---
>   .../python/python3-nacl_1.5.0.bb              | 25 +++++++++++++++++++
>   1 file changed, 25 insertions(+)
>   create mode 100644 meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
> new file mode 100644
> index 000000000..7d5292745
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
> @@ -0,0 +1,25 @@
> +SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
> +HOMEPAGE = "https://github.com/pyca/pynacl"
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
> +
> +PYPI_PACKAGE = "PyNaCl"

It is exactly the same recipe with name python3-nacl_1.5.0.bb in the 
same directory. And I suggest to
remove one of them and let the other one rprovides it if needed.

Regards,
Kai


> +
> +inherit pypi setuptools3
> +
> +SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
> +
> +DEPENDS += "\
> +    libsodium \
> +    python3-cffi-native \
> +    python3-pip-native \
> +"
> +
> +RDEPENDS:${PN}:class-target += " \
> +    python3-cffi \
> +    python3-pycparser \
> +"
> +
> +export SODIUM_INSTALL = "system"
> +
> +BBCLASSEXTEND = "native"
> \ No newline at end of file
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105272): https://lists.openembedded.org/g/openembedded-devel/message/105272
> Mute This Topic: https://lists.openembedded.org/mt/101667089/3616933
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [kai.kang@eng.windriver.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Nov. 1, 2023, 3:48 a.m. UTC | #2
On Tue, Oct 31, 2023 at 7:32 PM Kai <kai.kang@windriver.com> wrote:
>
> On 9/30/23 05:35, Derek Straka wrote:
> > Signed-off-by: Derek Straka <derek@asterius.io>
> > ---
> >   .../python/python3-nacl_1.5.0.bb              | 25 +++++++++++++++++++
> >   1 file changed, 25 insertions(+)
> >   create mode 100644 meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
> >
> > diff --git a/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
> > new file mode 100644
> > index 000000000..7d5292745
> > --- /dev/null
> > +++ b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
> > @@ -0,0 +1,25 @@
> > +SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
> > +HOMEPAGE = "https://github.com/pyca/pynacl"
> > +LICENSE = "Apache-2.0"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
> > +
> > +PYPI_PACKAGE = "PyNaCl"
>
> It is exactly the same recipe with name python3-nacl_1.5.0.bb in the
> same directory. And I suggest to
> remove one of them and let the other one rprovides it if needed.

this seems fine to me. Please send a patch to remove old recipe and
add PROVIDES to new one

>
> Regards,
> Kai
>
>
> > +
> > +inherit pypi setuptools3
> > +
> > +SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
> > +
> > +DEPENDS += "\
> > +    libsodium \
> > +    python3-cffi-native \
> > +    python3-pip-native \
> > +"
> > +
> > +RDEPENDS:${PN}:class-target += " \
> > +    python3-cffi \
> > +    python3-pycparser \
> > +"
> > +
> > +export SODIUM_INSTALL = "system"
> > +
> > +BBCLASSEXTEND = "native"
> > \ No newline at end of file
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#105272): https://lists.openembedded.org/g/openembedded-devel/message/105272
> > Mute This Topic: https://lists.openembedded.org/mt/101667089/3616933
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [kai.kang@eng.windriver.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
> --
> Kai Kang
> Wind River Linux
>
Derek Straka Nov. 1, 2023, 3:56 a.m. UTC | #3
Works for me.  I'd personally prefer to keep it in meta-python since I'd
rather not create a meta-virtualization dependency for my personal project,
but I can be persuaded if it creates more work for others.

On Tue, Oct 31, 2023 at 10:49 PM Khem Raj <raj.khem@gmail.com> wrote:

> On Tue, Oct 31, 2023 at 7:32 PM Kai <kai.kang@windriver.com> wrote:
> >
> > On 9/30/23 05:35, Derek Straka wrote:
> > > Signed-off-by: Derek Straka <derek@asterius.io>
> > > ---
> > >   .../python/python3-nacl_1.5.0.bb              | 25
> +++++++++++++++++++
> > >   1 file changed, 25 insertions(+)
> > >   create mode 100644 meta-python/recipes-devtools/python/
> python3-nacl_1.5.0.bb
> > >
> > > diff --git a/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
> b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
> > > new file mode 100644
> > > index 000000000..7d5292745
> > > --- /dev/null
> > > +++ b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
> > > @@ -0,0 +1,25 @@
> > > +SUMMARY = "Python binding to the Networking and Cryptography (NaCl)
> library"
> > > +HOMEPAGE = "https://github.com/pyca/pynacl"
> > > +LICENSE = "Apache-2.0"
> > > +LIC_FILES_CHKSUM =
> "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
> > > +
> > > +PYPI_PACKAGE = "PyNaCl"
> >
> > It is exactly the same recipe with name python3-nacl_1.5.0.bb in the
> > same directory. And I suggest to
> > remove one of them and let the other one rprovides it if needed.
>
> this seems fine to me. Please send a patch to remove old recipe and
> add PROVIDES to new one
>
> >
> > Regards,
> > Kai
> >
> >
> > > +
> > > +inherit pypi setuptools3
> > > +
> > > +SRC_URI[sha256sum] =
> "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
> > > +
> > > +DEPENDS += "\
> > > +    libsodium \
> > > +    python3-cffi-native \
> > > +    python3-pip-native \
> > > +"
> > > +
> > > +RDEPENDS:${PN}:class-target += " \
> > > +    python3-cffi \
> > > +    python3-pycparser \
> > > +"
> > > +
> > > +export SODIUM_INSTALL = "system"
> > > +
> > > +BBCLASSEXTEND = "native"
> > > \ No newline at end of file
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#105272):
> https://lists.openembedded.org/g/openembedded-devel/message/105272
> > > Mute This Topic: https://lists.openembedded.org/mt/101667089/3616933
> > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub
> [kai.kang@eng.windriver.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
> >
> > --
> > Kai Kang
> > Wind River Linux
> >
>
Kai Nov. 1, 2023, 4:46 a.m. UTC | #4
On 11/1/23 11:56, Derek Straka wrote:
> Works for me.  I'd personally prefer to keep it in meta-python since 
> I'd rather not create a meta-virtualization dependency for 
> my personal project, but I can be persuaded if it creates more work 
> for others.

Yes, it will be kept in meta-python that both of the recipes are in 
meta-python.

Regards,
Kai

>
> On Tue, Oct 31, 2023 at 10:49 PM Khem Raj <raj.khem@gmail.com> wrote:
>
>     On Tue, Oct 31, 2023 at 7:32 PM Kai <kai.kang@windriver.com> wrote:
>     >
>     > On 9/30/23 05:35, Derek Straka wrote:
>     > > Signed-off-by: Derek Straka <derek@asterius.io>
>     > > ---
>     > >   .../python/python3-nacl_1.5.0.bb
>     <https://urldefense.com/v3/__http://python3-nacl_1.5.0.bb__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW_t0d6nQw$>
>                 | 25 +++++++++++++++++++
>     > >   1 file changed, 25 insertions(+)
>     > >   create mode 100644
>     meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
>     <https://urldefense.com/v3/__http://python3-nacl_1.5.0.bb__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW_t0d6nQw$>
>     > >
>     > > diff --git
>     a/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
>     <https://urldefense.com/v3/__http://python3-nacl_1.5.0.bb__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW_t0d6nQw$>
>     b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
>     <https://urldefense.com/v3/__http://python3-nacl_1.5.0.bb__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW_t0d6nQw$>
>     > > new file mode 100644
>     > > index 000000000..7d5292745
>     > > --- /dev/null
>     > > +++
>     b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
>     <https://urldefense.com/v3/__http://python3-nacl_1.5.0.bb__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW_t0d6nQw$>
>     > > @@ -0,0 +1,25 @@
>     > > +SUMMARY = "Python binding to the Networking and Cryptography
>     (NaCl) library"
>     > > +HOMEPAGE = "https://github.com/pyca/pynacl
>     <https://urldefense.com/v3/__https://github.com/pyca/pynacl__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW9eTnCX1g$>"
>     > > +LICENSE = "Apache-2.0"
>     > > +LIC_FILES_CHKSUM =
>     "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
>     > > +
>     > > +PYPI_PACKAGE = "PyNaCl"
>     >
>     > It is exactly the same recipe with name python3-nacl_1.5.0.bb
>     <https://urldefense.com/v3/__http://python3-nacl_1.5.0.bb__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW_t0d6nQw$>
>     in the
>     > same directory. And I suggest to
>     > remove one of them and let the other one rprovides it if needed.
>
>     this seems fine to me. Please send a patch to remove old recipe and
>     add PROVIDES to new one
>
>     >
>     > Regards,
>     > Kai
>     >
>     >
>     > > +
>     > > +inherit pypi setuptools3
>     > > +
>     > > +SRC_URI[sha256sum] =
>     "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
>     > > +
>     > > +DEPENDS += "\
>     > > +    libsodium \
>     > > +    python3-cffi-native \
>     > > +    python3-pip-native \
>     > > +"
>     > > +
>     > > +RDEPENDS:${PN}:class-target += " \
>     > > +    python3-cffi \
>     > > +    python3-pycparser \
>     > > +"
>     > > +
>     > > +export SODIUM_INSTALL = "system"
>     > > +
>     > > +BBCLASSEXTEND = "native"
>     > > \ No newline at end of file
>     > >
>     > > -=-=-=-=-=-=-=-=-=-=-=-
>     > > Links: You receive all messages sent to this group.
>     > > View/Reply Online (#105272):
>     https://lists.openembedded.org/g/openembedded-devel/message/105272
>     <https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-devel/message/105272__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW9BXbdMYw$>
>     > > Mute This Topic:
>     https://lists.openembedded.org/mt/101667089/3616933
>     <https://urldefense.com/v3/__https://lists.openembedded.org/mt/101667089/3616933__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW_I2ufC_g$>
>     > > Group Owner: openembedded-devel+owner@lists.openembedded.org
>     <mailto:openembedded-devel%2Bowner@lists.openembedded.org>
>     > > Unsubscribe:
>     https://lists.openembedded.org/g/openembedded-devel/unsub
>     <https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-devel/unsub__;!!AjveYdw8EvQ!cM6NlZF43XGcQqc1vQIYJhJ3jNKput2q3D1rDFp-P_OrzFB0pFRF7WSBw9sofwN0Af1n5o9oAW8cIkdseQ$>
>     [kai.kang@eng.windriver.com]
>     > > -=-=-=-=-=-=-=-=-=-=-=-
>     > >
>     >
>     > --
>     > Kai Kang
>     > Wind River Linux
>     >
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
new file mode 100644
index 000000000..7d5292745
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-nacl_1.5.0.bb
@@ -0,0 +1,25 @@ 
+SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
+HOMEPAGE = "https://github.com/pyca/pynacl"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
+
+PYPI_PACKAGE = "PyNaCl"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
+
+DEPENDS += "\
+    libsodium \
+    python3-cffi-native \
+    python3-pip-native \
+"
+
+RDEPENDS:${PN}:class-target += " \
+    python3-cffi \
+    python3-pycparser \
+"
+
+export SODIUM_INSTALL = "system"
+
+BBCLASSEXTEND = "native"
\ No newline at end of file