diff mbox series

[meta-python] python3-absl: Update version 1.4.0 -> 2.0.0

Message ID 20230920161313.1230258-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-absl: Update version 1.4.0 -> 2.0.0 | expand

Commit Message

Derek Straka Sept. 20, 2023, 4:13 p.m. UTC
Changelog
==================
New
Support Python 3.12.

Changed
absl-py no longer supports Python 3.6. It has reached end-of-life for more
than a year now.
(logging) logging.exception can now take exc_info as argument, with
default value True. Prior to this change setting exc_info would raise
KeyError, this change fixes this behaviour.
(testing) For Python 3.11+, the calls to absltest.TestCase.enter_context
are forwarded to unittest.TestCase.enterContext (when called via instance)
or unittest.TestCase.enterClassContext (when called via class) now. As a
result, on Python 3.11+, the private _cls_exit_stack attribute is not
defined on absltest.TestCase and _exit_stack attribute is not defined on
its instances.
(testing) absltest.TestCase.assertSameStructure() now uses the test case's
equality functions (registered with TestCase.addTypeEqualityFunc()) for
comparing leaves of the structure.
(testing) abslTest.TestCase.fail() now names its arguments
(self, msg=None, user_msg=None), and not (self, msg=None, prefix=None),
better reflecting the behavior and usage of the two message arguments.
DEFINE_enum, DEFINE_multi_enum, and EnumParser now raise errors when
enum_values is provided as a single string value. Additionally,
EnumParser.enum_values is now stored as a list copy of the provided
enum_values parameter.
(testing) Updated paramaterized.CoopTestCase() to use Python 3 metaclass
idioms. Most uses of this function continued working during the Python 3
migration still worked because a Python 2 compatibility __metaclass__
variables also existed. Now pure Python 3 base classes without backwards
compatibility will work as intended.
(testing) absltest.TestCase.assertSequenceStartsWith now explicitly fail
when passed a Mapping or Set object as the whole argument.

Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../python/{python3-absl_1.4.0.bb => python3-absl_2.0.0.bb}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-absl_1.4.0.bb => python3-absl_2.0.0.bb} (76%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-absl_1.4.0.bb b/meta-python/recipes-devtools/python/python3-absl_2.0.0.bb
similarity index 76%
rename from meta-python/recipes-devtools/python/python3-absl_1.4.0.bb
rename to meta-python/recipes-devtools/python/python3-absl_2.0.0.bb
index bbea9cacb..42c7f3f84 100644
--- a/meta-python/recipes-devtools/python/python3-absl_1.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-absl_2.0.0.bb
@@ -4,7 +4,7 @@  SECTION = "devel/python"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-SRC_URI[sha256sum] = "d2c244d01048ba476e7c080bd2c6df5e141d211de80223460d5b3b8a2a58433d"
+SRC_URI[sha256sum] = "d9690211c5fcfefcdd1a45470ac2b5c5acd45241c3af71eed96bc5441746c0d5"
 
 PYPI_PACKAGE = "absl-py"