diff mbox series

[meta-python,6/6] python3-apiflask: add recipe

Message ID 20230915070727.4026-6-sam.van.den.berge@gmail.com
State Under Review
Headers show
Series [meta-python,1/6] python3-flask-jwt-extended: add recipe | expand

Commit Message

Sam Van Den Berge Sept. 15, 2023, 7:07 a.m. UTC
From: Sam Van Den Berge <sam.van.den.berge@gmail.com>

Signed-off-by: Sam Van Den Berge <sam.van.den.berge@gmail.com>
---
 .../python/python3-apiflask_2.0.1.bb           | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-apiflask_2.0.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-apiflask_2.0.1.bb b/meta-python/recipes-devtools/python/python3-apiflask_2.0.1.bb
new file mode 100644
index 000000000..ad946470e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-apiflask_2.0.1.bb
@@ -0,0 +1,18 @@ 
+SUMMARY = "APIFlask is a lightweight Python web API framework based on Flask and marshmallow-code projects."
+HOMEPAGE = "https://github.com/apiflask/apiflask"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5f89d1b0dec37448d4f4163dc3c40e64"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "APIFlask"
+
+SRC_URI[sha256sum] = "7ffe29e082c6cc76d8ae78ba2445b5fcd69092fac04f4f8cd23b1c887cb291cc"
+
+RDEPENDS:${PN} += "\
+    python3-flask \
+    python3-flask-marshmallow \
+    python3-webargs \
+    python3-flask-httpauth \
+    python3-apispec \
+    "