diff mbox series

[meta-python,kirkstone,1/1] python3-aiohttp: upgrade 3.8.1 -> 3.8.5

Message ID 20230821113405.2182966-1-narpat.mali@windriver.com
State New
Headers show
Series [meta-python,kirkstone,1/1] python3-aiohttp: upgrade 3.8.1 -> 3.8.5 | expand

Commit Message

nmali Aug. 21, 2023, 11:34 a.m. UTC
From: Narpat Mali <narpat.mali@windriver.com>

The delta between 3.8.1 & 3.8.5 contains the CVE-2023-37276 fix and other bugfixes.
https://github.com/aio-libs/aiohttp/security/advisories/GHSA-45c4-8wx5-qw6w

Changelog:
https://docs.aiohttp.org/en/stable/changes.html

- Increased the upper boundary of the multidict dependency to allow for the version 6
- License-Update: Update copyright year from 2020 to 2022
- Fixed incorrectly overwriting cookies with the same name and domain, but different path
- Fixed ConnectionResetError not being raised after client disconnection in SSL environments
- Upgraded the vendored copy of llhttp_ to v8.1.1
- Added information to C parser exceptions to show which character caused the error
- Fixed a transport is :data:None error

Upstream master patches:
3.8.1 -> 3.8.3 : https://git.openembedded.org/meta-openembedded/commit/?id=c0d2a5bcc87ee8564a5b9be35f3e2b930e384a59
3.8.3 -> 3.8.4 : https://git.openembedded.org/meta-openembedded/commit/?id=1fc465466cd138e1fcc87de18e84f88e2c5f1b4f
3.8.4 -> 3.8.5 : https://git.openembedded.org/meta-openembedded/commit/?id=ba5d26d1d8b30d71cb648f95b6431c16134e82e9

Signed-off-by: Narpat Mali <narpat.mali@windriver.com>
---
 .../{python3-aiohttp_3.8.1.bb => python3-aiohttp_3.8.5.bb}    | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-aiohttp_3.8.1.bb => python3-aiohttp_3.8.5.bb} (80%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.8.1.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.8.5.bb
similarity index 80%
rename from meta-python/recipes-devtools/python/python3-aiohttp_3.8.1.bb
rename to meta-python/recipes-devtools/python/python3-aiohttp_3.8.5.bb
index f2b8d52a72..d04279ed97 100644
--- a/meta-python/recipes-devtools/python/python3-aiohttp_3.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.8.5.bb
@@ -2,9 +2,9 @@  SUMMARY = "Async http client/server framework"
 DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
 HOMEPAGE = "https://github.com/aio-libs/aiohttp"
 LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8074d6c6e217873b2a018a4522243ea3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=748073912af33aa59430d3702aa32d41"
 
-SRC_URI[sha256sum] = "fc5471e1a54de15ef71c1bc6ebe80d4dc681ea600e68bfd1cbce40427f0b7578"
+SRC_URI[sha256sum] = "b9552ec52cc147dbf1944ac7ac98af7602e51ea2dcd076ed194ca3c0d1c7d0bc"
 
 PYPI_PACKAGE = "aiohttp"
 inherit python_setuptools_build_meta pypi