diff mbox series

[meta-python,v2] python3-oauth2client_4.1.2.bb: recipe added

Message ID 20230817121421.3519563-1-ewa.kujawska@3mdeb.com
State New
Headers show
Series [meta-python,v2] python3-oauth2client_4.1.2.bb: recipe added | expand

Commit Message

Ewa Kujawska Aug. 17, 2023, 12:13 p.m. UTC
Signed-off-by: Ewa Kujawska <ewa.kujawska@3mdeb.com>
---
 .../python3-oauth2client_4.1.2.bb             | 19 ++++++++++++++++++-
 1 file changed, 18 insertions(+), 1 deletion(-)

Comments

Khem Raj Aug. 17, 2023, 3:10 p.m. UTC | #1
is this patch on top of last patch ? if so then its not a v2 but
incremental change. Usually I prefer a resend of whole patch with
rework on next version of patch.

On Thu, Aug 17, 2023 at 5:14 AM Ewa Kujawska <ewa.kujawska@3mdeb.com> wrote:
>
> Signed-off-by: Ewa Kujawska <ewa.kujawska@3mdeb.com>
> ---
>  .../python3-oauth2client_4.1.2.bb             | 19 ++++++++++++++++++-
>  1 file changed, 18 insertions(+), 1 deletion(-)
>
> diff --git a/meta-python/recipes-devtools/python3-oauth2client/python3-oauth2client_4.1.2.bb b/meta-python/recipes-devtools/python3-oauth2client/python3-oauth2client_4.1.2.bb
> index 96508007b2f3..0301763030e0 100644
> --- a/meta-python/recipes-devtools/python3-oauth2client/python3-oauth2client_4.1.2.bb
> +++ b/meta-python/recipes-devtools/python3-oauth2client/python3-oauth2client_4.1.2.bb
> @@ -1,2 +1,19 @@
> +DESCRIPTION = "OAuth 2.0 client library"
> +
> +HOMEPAGE = "http://github.com/google/oauth2client/"
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=038e1390e94fe637991fa5569daa62bc"
> +
> +inherit pypi
> +
> +SRC_URI[sha256sum] = "bd3062c06f8b10c6ef7a890b22c2740e5f87d61b6e1f4b1c90d069cdfc9dadb5"
> +
> +RDEPENDS:${PN} += " \
> +        ${PYTHON_PN}-httplib2 \
> +        ${PYTHON_PN}-pyasn1 \
> +        ${PYTHON_PN}-pyasn1-modules \
> +        ${PYTHON_PN}-rsa \
> +        ${PYTHON_PN}-six \
> +        "
> +
>  inherit setuptools3
> -require python-oauth2client.inc
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104462): https://lists.openembedded.org/g/openembedded-devel/message/104462
> Mute This Topic: https://lists.openembedded.org/mt/100799067/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python3-oauth2client/python3-oauth2client_4.1.2.bb b/meta-python/recipes-devtools/python3-oauth2client/python3-oauth2client_4.1.2.bb
index 96508007b2f3..0301763030e0 100644
--- a/meta-python/recipes-devtools/python3-oauth2client/python3-oauth2client_4.1.2.bb
+++ b/meta-python/recipes-devtools/python3-oauth2client/python3-oauth2client_4.1.2.bb
@@ -1,2 +1,19 @@ 
+DESCRIPTION = "OAuth 2.0 client library"
+
+HOMEPAGE = "http://github.com/google/oauth2client/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=038e1390e94fe637991fa5569daa62bc"
+
+inherit pypi
+
+SRC_URI[sha256sum] = "bd3062c06f8b10c6ef7a890b22c2740e5f87d61b6e1f4b1c90d069cdfc9dadb5"
+
+RDEPENDS:${PN} += " \
+        ${PYTHON_PN}-httplib2 \
+        ${PYTHON_PN}-pyasn1 \
+        ${PYTHON_PN}-pyasn1-modules \
+        ${PYTHON_PN}-rsa \
+        ${PYTHON_PN}-six \
+        "
+
 inherit setuptools3
-require python-oauth2client.inc