diff mbox series

[meta-oe,v2] recipes-bsp: Add bolt

Message ID 20230816183437.1903299-1-chaitanya.vadrevu@ni.com
State New
Headers show
Series [meta-oe,v2] recipes-bsp: Add bolt | expand

Commit Message

Chaitanya Vadrevu Aug. 16, 2023, 6:34 p.m. UTC
bolt is used for managing thunderbolt devices.

Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
---
Changes in v2:
 * Removed redundant cmake-native from DEPENDS
 * Set REQUIRED_DISTRO_FEATURES to polkit as polkit is always needed for
   bolt

 meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb

Comments

Khem Raj Aug. 16, 2023, 6:39 p.m. UTC | #1
On 8/16/23 11:34 AM, Chaitanya Vadrevu wrote:
> bolt is used for managing thunderbolt devices.
> 
> Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
> ---
> Changes in v2:
>   * Removed redundant cmake-native from DEPENDS
>   * Set REQUIRED_DISTRO_FEATURES to polkit as polkit is always needed for
>     bolt
> 

There was a similar v2 patch sent yesterday. Is it any different ?

>   meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb | 19 +++++++++++++++++++
>   1 file changed, 19 insertions(+)
>   create mode 100644 meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
> 
> diff --git a/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
> new file mode 100644
> index 0000000000..b6ad6337ce
> --- /dev/null
> +++ b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
> @@ -0,0 +1,19 @@
> +SUMMARY = "Thunderbolt user-space management tool"
> +DESCRIPTION = "Userspace system daemon to enable security levels for Thunderbolt on GNU/Linux"
> +HOMEPAGE = "https://gitlab.freedesktop.org/bolt/bolt"
> +LICENSE = "LGPL-2.1-only"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
> +
> +DEPENDS = "udev polkit dbus"
> +REQUIRED_DISTRO_FEATURES = "polkit"
> +
> +SRC_URI = "git://gitlab.freedesktop.org/bolt/bolt.git;protocol=https;branch=master"
> +SRCREV = "5a8a5866a847561566499847d46a97c612b4e6dd"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit cmake pkgconfig meson features_check
> +
> +FILES:${PN} += "${datadir}/dbus-1/* \
> +                ${datadir}/polkit-1/* \
> +               "
Chaitanya Vadrevu Aug. 16, 2023, 6:52 p.m. UTC | #2
It is the same but yesterday's v2 patch but the mailing list ( https://lists.openembedded.org/g/openembedded-devel/search?p=created%2C0%2C%2C1%2C2%2C0%2C0&q=recipes-bsp%3A+add+bolt ) did not receive it (you apparently received it though) and I realized that I made a mistake in specifying email recipients so I resent it correctly this time.
Khem Raj Aug. 16, 2023, 6:53 p.m. UTC | #3
On Wed, Aug 16, 2023 at 11:52 AM Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
wrote:

> It is the same but yesterday's v2 patch but the mailing list
> <https://lists.openembedded.org/g/openembedded-devel/search?p=created%2C0%2C%2C1%2C2%2C0%2C0&q=recipes-bsp%3A+add+bolt> did
> not receive it (you apparently received it though) and I realized that I
> made a mistake in specifying email recipients so I resent it correctly this
> time.


Ok you did the right thing no worries I have it staged in master-next
already


> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104442):
> https://lists.openembedded.org/g/openembedded-devel/message/104442
> Mute This Topic: https://lists.openembedded.org/mt/100785507/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Chaitanya Vadrevu Aug. 16, 2023, 7 p.m. UTC | #4
> 
> Ok you did the right thing no worries I have it staged in master-next
> already

Thank you.
Philip Balister Aug. 17, 2023, 12:08 p.m. UTC | #5
My fault, I will be slow approving things in the moderation queue for a 
few days.

Philip

On 8/16/23 20:52, Chaitanya Vadrevu wrote:
> It is the same but yesterday's v2 patch but the mailing list 
> <https://lists.openembedded.org/g/openembedded-devel/search?p=created%2C0%2C%2C1%2C2%2C0%2C0&q=recipes-bsp%3A+add+bolt> did not receive it (you apparently received it though) and I realized that I made a mistake in specifying email recipients so I resent it correctly this time.
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104442): https://lists.openembedded.org/g/openembedded-devel/message/104442
> Mute This Topic: https://lists.openembedded.org/mt/100785507/384425
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [philip@balister.org]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
new file mode 100644
index 0000000000..b6ad6337ce
--- /dev/null
+++ b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "Thunderbolt user-space management tool"
+DESCRIPTION = "Userspace system daemon to enable security levels for Thunderbolt on GNU/Linux"
+HOMEPAGE = "https://gitlab.freedesktop.org/bolt/bolt"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "udev polkit dbus"
+REQUIRED_DISTRO_FEATURES = "polkit"
+
+SRC_URI = "git://gitlab.freedesktop.org/bolt/bolt.git;protocol=https;branch=master"
+SRCREV = "5a8a5866a847561566499847d46a97c612b4e6dd"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig meson features_check
+
+FILES:${PN} += "${datadir}/dbus-1/* \
+                ${datadir}/polkit-1/* \
+               "