diff mbox series

[meta-oe] ttf-google-fira: add recipe

Message ID 20230816073725.9331-1-tymoteusz.burak@3mdeb.com
State Under Review
Headers show
Series [meta-oe] ttf-google-fira: add recipe | expand

Commit Message

Tymoteusz Burak Aug. 16, 2023, 7:37 a.m. UTC
---
 .../ttf-fonts/ttf-google-fira.bb              | 54 +++++++++++++++++++
 1 file changed, 54 insertions(+)
 create mode 100644 meta-oe/recipes-graphics/ttf-fonts/ttf-google-fira.bb

Comments

Khem Raj Aug. 16, 2023, 3:08 p.m. UTC | #1
On Wed, Aug 16, 2023 at 12:37 AM Tymoteusz Burak
<tymoteusz.burak@3mdeb.com> wrote:
>
> ---
>  .../ttf-fonts/ttf-google-fira.bb              | 54 +++++++++++++++++++
>  1 file changed, 54 insertions(+)
>  create mode 100644 meta-oe/recipes-graphics/ttf-fonts/ttf-google-fira.bb
>
> diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-google-fira.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-google-fira.bb
> new file mode 100644
> index 000000000000..b330f40387bb
> --- /dev/null
> +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-google-fira.bb
> @@ -0,0 +1,54 @@
> +SUMMARY = "Google Fira Fonts- TTF Edition"
> +HOMEPAGE = "https://fonts.google.com/?query=fira"
> +LICENSE = "OFL-1.1"
> +LIC_FILES_CHKSUM = " \
> +    file://${S}/firamono/OFL.txt;md5=0373cf792d4b95c61399b94c02702892 \
> +    file://${S}/firacode/OFL.txt;md5=c75ca55aa0a5809a854d87db2a8ebf23 \
> +    file://${S}/firasans/OFL.txt;md5=de28deb2f8c1f23fd4d6918113ac3ddd \
> +    file://${S}/firasanscondensed/OFL.txt;md5=de28deb2f8c1f23fd4d6918113ac3ddd \
> +    file://${S}/firasansextracondensed/OFL.txt;md5=de28deb2f8c1f23fd4d6918113ac3ddd \
> +"
> +SRCREV = "47a6c224b3e0287b2e48e3ffef8c9ce2ca4931f4"
> +
> +SRC_URI = "git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firamono \
> +           git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firacode \
> +           git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firasans \
> +           git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firasanscondensed \
> +           git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firasansextracondensed"
> +

We need to define SRCREV_FORMAT since it uses multiple uris here it
will be fail to parse otherwise with latest core
check meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb
for example.

> +S = "${WORKDIR}"
> +
> +do_install:append() {
> +    install -d ${D}${datadir}/fonts/truetype/
> +    find ${S} -path 'fira*/*.tt[cf]' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/{} \;
> +    install -D -m 0644 ${S}/firamono/OFL.txt ${D}${datadir}/licenses/${PN}mono/OFL.txt
> +    install -D -m 0644 ${S}/firacode/OFL.txt ${D}${datadir}/licenses/${PN}code/OFL.txt
> +    install -D -m 0644 ${S}/firasans/OFL.txt ${D}${datadir}/licenses/${PN}sans/OFL.txt
> +    install -D -m 0644 ${S}/firasanscondensed/OFL.txt ${D}${datadir}/licenses/${PN}sanscondensed/OFL.txt
> +    install -D -m 0644 ${S}/firasansextracondensed/OFL.txt ${D}${datadir}/licenses/${PN}sansextracondensed/OFL.txt
> +}
> +
> +PACKAGES =+ "${PN}-mono ${PN}-code ${PN}-sans ${PN}-sanscondensed ${PN}-sansextracondensed"
> +
> +FILES:${PN}-mono += " \
> +                    ${datadir}/fonts/truetype/FiraMono* \
> +                    ${datadir}/licenses/${PN}mono/OFL.txt \
> +                "
> +FILES:${PN}-code += " \
> +                    ${datadir}/fonts/truetype/FiraCode* \
> +                    ${datadir}/licenses/${PN}code/OFL.txt \
> +                "
> +FILES:${PN}-sans += " \
> +                    ${datadir}/fonts/truetype/FiraSans-* \
> +                    ${datadir}/licenses/${PN}sans/OFL.txt \
> +                "
> +FILES:${PN}-sanscondensed += " \
> +                            ${datadir}/fonts/truetype/FiraSansCondensed-* \
> +                            ${datadir}/licenses/${PN}sanscondensed/OFL.txt \
> +                        "
> +FILES:${PN}-sansextracondensed += " \
> +                                    ${datadir}/fonts/truetype/FiraSansExtraCondensed-* \
> +                                    ${datadir}/licenses/${PN}sansextracondensed/OFL.txt \
> +                                 "
> +
> +require ttf.inc
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104415): https://lists.openembedded.org/g/openembedded-devel/message/104415
> Mute This Topic: https://lists.openembedded.org/mt/100775201/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-google-fira.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-google-fira.bb
new file mode 100644
index 000000000000..b330f40387bb
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-google-fira.bb
@@ -0,0 +1,54 @@ 
+SUMMARY = "Google Fira Fonts- TTF Edition"
+HOMEPAGE = "https://fonts.google.com/?query=fira"
+LICENSE = "OFL-1.1"
+LIC_FILES_CHKSUM = " \
+    file://${S}/firamono/OFL.txt;md5=0373cf792d4b95c61399b94c02702892 \
+    file://${S}/firacode/OFL.txt;md5=c75ca55aa0a5809a854d87db2a8ebf23 \
+    file://${S}/firasans/OFL.txt;md5=de28deb2f8c1f23fd4d6918113ac3ddd \
+    file://${S}/firasanscondensed/OFL.txt;md5=de28deb2f8c1f23fd4d6918113ac3ddd \
+    file://${S}/firasansextracondensed/OFL.txt;md5=de28deb2f8c1f23fd4d6918113ac3ddd \
+"
+SRCREV = "47a6c224b3e0287b2e48e3ffef8c9ce2ca4931f4"
+
+SRC_URI = "git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firamono \
+           git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firacode \
+           git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firasans \
+           git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firasanscondensed \
+           git://github.com/google/fonts.git;protocol=https;branch=main;subpath=ofl/firasansextracondensed"
+
+S = "${WORKDIR}"
+
+do_install:append() {
+    install -d ${D}${datadir}/fonts/truetype/
+    find ${S} -path 'fira*/*.tt[cf]' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/{} \;
+    install -D -m 0644 ${S}/firamono/OFL.txt ${D}${datadir}/licenses/${PN}mono/OFL.txt
+    install -D -m 0644 ${S}/firacode/OFL.txt ${D}${datadir}/licenses/${PN}code/OFL.txt
+    install -D -m 0644 ${S}/firasans/OFL.txt ${D}${datadir}/licenses/${PN}sans/OFL.txt
+    install -D -m 0644 ${S}/firasanscondensed/OFL.txt ${D}${datadir}/licenses/${PN}sanscondensed/OFL.txt
+    install -D -m 0644 ${S}/firasansextracondensed/OFL.txt ${D}${datadir}/licenses/${PN}sansextracondensed/OFL.txt
+}
+
+PACKAGES =+ "${PN}-mono ${PN}-code ${PN}-sans ${PN}-sanscondensed ${PN}-sansextracondensed"
+
+FILES:${PN}-mono += " \
+                    ${datadir}/fonts/truetype/FiraMono* \
+                    ${datadir}/licenses/${PN}mono/OFL.txt \
+                "
+FILES:${PN}-code += " \
+                    ${datadir}/fonts/truetype/FiraCode* \
+                    ${datadir}/licenses/${PN}code/OFL.txt \
+                "
+FILES:${PN}-sans += " \
+                    ${datadir}/fonts/truetype/FiraSans-* \
+                    ${datadir}/licenses/${PN}sans/OFL.txt \
+                "
+FILES:${PN}-sanscondensed += " \
+                            ${datadir}/fonts/truetype/FiraSansCondensed-* \
+                            ${datadir}/licenses/${PN}sanscondensed/OFL.txt \
+                        "
+FILES:${PN}-sansextracondensed += " \
+                                    ${datadir}/fonts/truetype/FiraSansExtraCondensed-* \
+                                    ${datadir}/licenses/${PN}sansextracondensed/OFL.txt \
+                                 "
+
+require ttf.inc