diff mbox series

[meta-oe] recipes-bsp: Add bolt

Message ID 20230814213631.535375-1-chaitanya.vadrevu@ni.com
State Under Review
Headers show
Series [meta-oe] recipes-bsp: Add bolt | expand

Commit Message

Chaitanya Vadrevu Aug. 14, 2023, 9:36 p.m. UTC
bolt is used for managing thunderbolt devices.

Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
---
 meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb

Comments

Khem Raj Aug. 15, 2023, 3:29 p.m. UTC | #1
On Mon, Aug 14, 2023 at 11:10 PM Chaitanya Vadrevu
<chaitanya.vadrevu@ni.com> wrote:
>
> bolt is used for managing thunderbolt devices.
>
> Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
> ---
>  meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb | 16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
>  create mode 100644 meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
>
> diff --git a/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
> new file mode 100644
> index 0000000000..f9f1b026f4
> --- /dev/null
> +++ b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
> @@ -0,0 +1,16 @@
> +SUMMARY = "Thunderbolt user-space management tool"
> +DESCRIPTION = "Userspace system daemon to enable security levels for Thunderbolt on GNU/Linux"
> +HOMEPAGE = "https://gitlab.freedesktop.org/bolt/bolt"
> +LICENSE = "LGPL-2.1-only"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
> +
> +DEPENDS = "cmake-native udev polkit dbus"

cmake-native would be added by inherit cmake below. polkit is a distro
feature so we should add
a check for that feature see meta/recipes-gnome/gnome/gconf_3.2.6.bb
for an example. If polkit is
always needed for this then add a distro feature check.


> +
> +SRC_URI = "git://gitlab.freedesktop.org/bolt/bolt.git;protocol=https;branch=master"
> +SRCREV = "5a8a5866a847561566499847d46a97c612b4e6dd"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit cmake pkgconfig meson
> +
> +FILES:${PN} += "${datadir}/dbus-1/* ${datadir}/polkit-1/*"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104355): https://lists.openembedded.org/g/openembedded-devel/message/104355
> Mute This Topic: https://lists.openembedded.org/mt/100753366/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
new file mode 100644
index 0000000000..f9f1b026f4
--- /dev/null
+++ b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
@@ -0,0 +1,16 @@ 
+SUMMARY = "Thunderbolt user-space management tool"
+DESCRIPTION = "Userspace system daemon to enable security levels for Thunderbolt on GNU/Linux"
+HOMEPAGE = "https://gitlab.freedesktop.org/bolt/bolt"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "cmake-native udev polkit dbus"
+
+SRC_URI = "git://gitlab.freedesktop.org/bolt/bolt.git;protocol=https;branch=master"
+SRCREV = "5a8a5866a847561566499847d46a97c612b4e6dd"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig meson
+
+FILES:${PN} += "${datadir}/dbus-1/* ${datadir}/polkit-1/*"