diff mbox series

[meta-python,4/5] python3-mypy: upgrade 0.971 -> 1.5.0

Message ID 20230810153953.17293-4-jsbronder@cold-front.org
State Under Review
Headers show
Series [meta-python,1/5] python3-mypy-extensions: upgrade 0.4.3 -> 1.0.0 | expand

Commit Message

Justin Bronder Aug. 10, 2023, 3:39 p.m. UTC
Switched RDEPEND to python3-modules as this is a complex package that is
still under fairly heavy development by python core contributors.  It's
likely that the dependency list will change from release to release and
unlikely that anyone wanting type-checking will be object to having a
full python installation.

Note for anyone attempting to backport this, you'll need to add
python3-tomli to RDEPENDS as python < 3.11 won't be in the stdlib.

Signed-off-by: Justin Bronder <jsbronder@cold-front.org>
---
 .../python/python3-mypy_0.971.bb              | 23 -------------------
 .../python/python3-mypy_1.5.0.bb              | 23 +++++++++++++++++++
 2 files changed, 23 insertions(+), 23 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-mypy_0.971.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-mypy_1.5.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb b/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
deleted file mode 100644
index 31fcb06c9..000000000
--- a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
+++ /dev/null
@@ -1,23 +0,0 @@ 
-SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
-HOMEPAGE = "https://github.com/python/mypy"
-LICENSE = "MIT & Python-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=6ba8ec528da02073b7e1f4124c0f836f"
-
-PYPI_PACKAGE = "mypy"
-
-inherit pypi python_setuptools_build_meta
-
-SRC_URI[sha256sum] = "40b0f21484238269ae6a57200c807d80debc6459d444c0489a102d7c6a75fa56"
-
-BBCLASSEXTEND = "native"
-
-RDEPENDS:${PN} += " \
-    ${PYTHON_PN}-mypy-extensions \
-    ${PYTHON_PN}-typed-ast \
-    ${PYTHON_PN}-typing-extensions \
-    ${PYTHON_PN}-json \
-    ${PYTHON_PN}-compression \
-    ${PYTHON_PN}-pprint \
-    ${PYTHON_PN}-difflib \
-    ${PYTHON_PN}-toml \
-"
diff --git a/meta-python/recipes-devtools/python/python3-mypy_1.5.0.bb b/meta-python/recipes-devtools/python/python3-mypy_1.5.0.bb
new file mode 100644
index 000000000..46730aa23
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-mypy_1.5.0.bb
@@ -0,0 +1,23 @@ 
+SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
+HOMEPAGE = "https://github.com/python/mypy"
+LICENSE = "MIT & Python-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ba8ec528da02073b7e1f4124c0f836f"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "f3460f34b3839b9bc84ee3ed65076eb827cd99ed13ed08d723f9083cada4a212"
+
+BBCLASSEXTEND = "native"
+
+DEPENDS += " \
+    python3-mypy-extensions-native \
+    python3-types-psutil-native \
+    python3-types-setuptools-native \
+    python3-typing-extensions-native \
+"
+
+RDEPENDS:${PN} += " \
+    python3-modules \
+    python3-mypy-extensions \
+    python3-typing-extensions \
+"