diff mbox series

recipes-extended: Add initial recipe for qad package

Message ID 20230810130340.14130-1-sudipm.mukherjee@gmail.com
State Under Review
Headers show
Series recipes-extended: Add initial recipe for qad package | expand

Commit Message

Sudip Mukherjee Aug. 10, 2023, 1:03 p.m. UTC
QAD is a daemon used for automated remote testing on hardware which can
take screenshots and can inject mouse or touch and keyboard events.

Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
---
 meta-oe/recipes-extended/qad/qad_git.bb | 27 +++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 meta-oe/recipes-extended/qad/qad_git.bb

Comments

Khem Raj Aug. 10, 2023, 2:49 p.m. UTC | #1
I have fixed the commit summary to match format

recipe: short summary of change

On Thu, Aug 10, 2023 at 6:05 AM Sudip Mukherjee
<sudipm.mukherjee@gmail.com> wrote:
>
> QAD is a daemon used for automated remote testing on hardware which can
> take screenshots and can inject mouse or touch and keyboard events.
>
> Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
> ---
>  meta-oe/recipes-extended/qad/qad_git.bb | 27 +++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
>  create mode 100644 meta-oe/recipes-extended/qad/qad_git.bb
>
> diff --git a/meta-oe/recipes-extended/qad/qad_git.bb b/meta-oe/recipes-extended/qad/qad_git.bb
> new file mode 100644
> index 000000000..e2a59139d
> --- /dev/null
> +++ b/meta-oe/recipes-extended/qad/qad_git.bb
> @@ -0,0 +1,27 @@
> +SUMMARY = "Simple, REST-API compliant daemon for automated testing"
> +DESCRIPTION = " This is a simple, REST-API compliant daemon which makes \
> +automated testing on hardware possible by removing the need for physical \
> +intervention as Q.A.D allows inputs to be injected via http/https requests. \
> +This both eliminates the need to physically interact with the rig and allows \
> +for tasks to be carried out entirely automatically."
> +
> +LICENSE = "MIT & GPL-2.0-or-later"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=402cce7fbcb6ea9ab5a0378dd7f40806 \
> +                    file://openqa/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> +                   "
> +SRC_URI = "git://gitlab.com/CodethinkLabs/qad/qad;branch=main;protocol=https"
> +
> +SRCREV = "ae0c099c1fdc0ca6f5d631cea6b302937122b362"
> +
> +S = "${WORKDIR}/git"
> +PV = "0.0+git${SRCPV}"
> +
> +DEPENDS = "cjson libmicrohttpd libdrm libpng"
> +
> +FILES:${PN} += "qad"
> +inherit meson pkgconfig
> +
> +do_install () {
> +    install -d ${D}${bindir}
> +    install -p -m 755 qad ${D}${bindir}/
> +}
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104315): https://lists.openembedded.org/g/openembedded-devel/message/104315
> Mute This Topic: https://lists.openembedded.org/mt/100662750/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/qad/qad_git.bb b/meta-oe/recipes-extended/qad/qad_git.bb
new file mode 100644
index 000000000..e2a59139d
--- /dev/null
+++ b/meta-oe/recipes-extended/qad/qad_git.bb
@@ -0,0 +1,27 @@ 
+SUMMARY = "Simple, REST-API compliant daemon for automated testing"
+DESCRIPTION = " This is a simple, REST-API compliant daemon which makes \
+automated testing on hardware possible by removing the need for physical \
+intervention as Q.A.D allows inputs to be injected via http/https requests. \
+This both eliminates the need to physically interact with the rig and allows \
+for tasks to be carried out entirely automatically."
+
+LICENSE = "MIT & GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=402cce7fbcb6ea9ab5a0378dd7f40806 \
+                    file://openqa/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+                   "
+SRC_URI = "git://gitlab.com/CodethinkLabs/qad/qad;branch=main;protocol=https"
+
+SRCREV = "ae0c099c1fdc0ca6f5d631cea6b302937122b362"
+
+S = "${WORKDIR}/git"
+PV = "0.0+git${SRCPV}"
+
+DEPENDS = "cjson libmicrohttpd libdrm libpng"
+
+FILES:${PN} += "qad"
+inherit meson pkgconfig
+
+do_install () {
+    install -d ${D}${bindir}
+    install -p -m 755 qad ${D}${bindir}/
+}