diff mbox series

[kirkstone,meta-python] python3-can: Add missing runtime dependencies

Message ID 20230810124730.238812-1-frieder@fris.de
State New
Headers show
Series [kirkstone,meta-python] python3-can: Add missing runtime dependencies | expand

Commit Message

Frieder Schrempf Aug. 10, 2023, 12:47 p.m. UTC
From: Frieder Schrempf <frieder.schrempf@kontron.de>

According to the setup.py of v4.0.0 [1] the following runtime
dependencies are currently missing. Add them.

* packaging
* setuptools
* typing_extensions

While at it, also reorder the list alphabetically.

[1] https://github.com/hardbyte/python-can/blob/4.0.0/setup.py

Signed-off-by: Frieder Schrempf <frieder.schrempf@kontron.de>
---
 meta-python/recipes-devtools/python/python3-can_4.0.0.bb | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-can_4.0.0.bb b/meta-python/recipes-devtools/python/python3-can_4.0.0.bb
index 2cd2e624b..79aa3e19e 100644
--- a/meta-python/recipes-devtools/python/python3-can_4.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-can_4.0.0.bb
@@ -11,16 +11,19 @@  inherit pypi setuptools3
 
 RDEPENDS:${PN}:class-target += "\
     ${PYTHON_PN}-aenum \
-    ${PYTHON_PN}-ctypes \
     ${PYTHON_PN}-codecs \
     ${PYTHON_PN}-compression \
+    ${PYTHON_PN}-ctypes \
     ${PYTHON_PN}-fcntl \
     ${PYTHON_PN}-logging \
     ${PYTHON_PN}-misc \
     ${PYTHON_PN}-netserver \
+    ${PYTHON_PN}-packaging \
+    ${PYTHON_PN}-pkg-resources \
+    ${PYTHON_PN}-setuptools \
     ${PYTHON_PN}-sqlite3 \
+    ${PYTHON_PN}-typing-extensions \
     ${PYTHON_PN}-wrapt \
-    ${PYTHON_PN}-pkg-resources \
 "
 
 BBCLASSEXTEND = "native nativesdk"