diff mbox series

[meta-xfce,3/3] xfce4-sensors-plugin: Use bfd linker instead of lld

Message ID 20230612184309.1556169-3-raj.khem@gmail.com
State New
Headers show
Series [meta-multimedia,1/3] schroedinger: Fix building tests | expand

Commit Message

Khem Raj June 12, 2023, 6:43 p.m. UTC
lld linking fails
| aarch64-yoe-linux-ld.lld: error: undefined symbol: gtk_sensorstacho_new(GtkOrientation, unsigned int, SensorsTachoStyle)
| >>> referenced by actions.cc:143 (/usr/src/debug/xfce4-sensors-plugin/1.4.4-r0/src/../../xfce4-sensors-plugin-1.4.4/src/actions.cc:143)
| >>>               xfce4_sensors-actions.o:(refresh_tacho_view(xfce4::Ptr<t_sensors_dialog> const&))
|
| aarch64-yoe-linux-ld.lld: error: undefined symbol: gtk_sensorstacho_set_color(_GtkSensorsTacho*, char const*)
| >>> referenced by actions.cc:146 (/usr/src/debug/xfce4-sensors-plugin/1.4.4-r0/src/../../xfce4-sensors-plugin-1.4.4/src/actions.cc:146)
| >>>               xfce4_sensors-actions.o:(refresh_tacho_view(xfce4::Ptr<t_sensors_dialog> const&))
| >>> referenced by callbacks.cc:197 (/usr/src/debug/xfce4-sensors-plugin/1.4.4-r0/src/../../xfce4-sensors-plugin-1.4.4/src/callbacks.cc:197)
| >>>               xfce4_sensors-callbacks.o:(list_cell_color_edited_(_GtkCellRendererText*, char const*, char const*, xfce4::Ptr<t_sensors_dialog> const&))
|

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
index 69996d2a3f..eb1165c578 100644
--- a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
+++ b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.4.4.bb
@@ -13,6 +13,8 @@  EXTRA_OECONF = " \
     --disable-xnvctrl \
 "
 
+LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' -fuse-ld=bfd', '', d)}"
+
 do_configure:prepend() {
     sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
 }