diff mbox series

[meta-oe] ply: Demand BFD linker explicitly

Message ID 20230612005935.3467771-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] ply: Demand BFD linker explicitly | expand

Commit Message

Khem Raj June 12, 2023, 12:59 a.m. UTC
Default ld on OE could be either gold/bfd/lld, here its assuming ld to
ld.bfd which is not right assumption when it really should ask for BFD
linker since its relying on its options

see src/ply/Makefile.am

$(LD) -r -b binary -o $(abs_builddir)/self-test.o self-test.sh

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-devtools/ply/ply_git.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/ply/ply_git.bb b/meta-oe/recipes-devtools/ply/ply_git.bb
index 61a0092c81..c22dcbd12a 100644
--- a/meta-oe/recipes-devtools/ply/ply_git.bb
+++ b/meta-oe/recipes-devtools/ply/ply_git.bb
@@ -12,6 +12,8 @@  SRCREV = "864fac79116870df1ab7aa21e639578807e41e75"
 
 S = "${WORKDIR}/git"
 
+LD = "${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}"
+
 inherit autotools-brokensep
 
 COMPATIBLE_HOST = "(x86_64.*|aarch64.*|arm.*|powerpc)-linux"