diff mbox series

[meta-oe] fftw: Check for TOOLCHAIN_OPTIONS to be non-empty before sed ops

Message ID 20230523045151.139311-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] fftw: Check for TOOLCHAIN_OPTIONS to be non-empty before sed ops | expand

Commit Message

Khem Raj May 23, 2023, 4:51 a.m. UTC
Ensures that we do not apply empty sed expression which might happen
when building native recipe

Cc: jan vermaete <jan.vermaete@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-support/fftw/fftw_3.3.10.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Böszörményi Zoltán June 7, 2023, 7:54 a.m. UTC | #1
Please backport this to mickledore ASAP.

2023. 05. 23. 6:51 keltezéssel, Khem Raj írta:
> Ensures that we do not apply empty sed expression which might happen
> when building native recipe
>
> Cc: jan vermaete <jan.vermaete@gmail.com>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>   meta-oe/recipes-support/fftw/fftw_3.3.10.bb | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta-oe/recipes-support/fftw/fftw_3.3.10.bb b/meta-oe/recipes-support/fftw/fftw_3.3.10.bb
> index 1fead4d029..33e8279880 100644
> --- a/meta-oe/recipes-support/fftw/fftw_3.3.10.bb
> +++ b/meta-oe/recipes-support/fftw/fftw_3.3.10.bb
> @@ -55,7 +55,7 @@ do_configure() {
>   do_compile() {
>       for lib in fftw fftwl fftwf; do
>           cd ${WORKDIR}/build-$lib
> -        sed -i -e 's|${TOOLCHAIN_OPTIONS}||g' config.h
> +        test -n "${TOOLCHAIN_OPTIONS}" && sed -i -e 's|${TOOLCHAIN_OPTIONS}||g' config.h
>           autotools_do_compile
>       done
>   }
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#102729): https://lists.openembedded.org/g/openembedded-devel/message/102729
> Mute This Topic: https://lists.openembedded.org/mt/99081361/3617728
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [zboszor@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/fftw/fftw_3.3.10.bb b/meta-oe/recipes-support/fftw/fftw_3.3.10.bb
index 1fead4d029..33e8279880 100644
--- a/meta-oe/recipes-support/fftw/fftw_3.3.10.bb
+++ b/meta-oe/recipes-support/fftw/fftw_3.3.10.bb
@@ -55,7 +55,7 @@  do_configure() {
 do_compile() {
     for lib in fftw fftwl fftwf; do
         cd ${WORKDIR}/build-$lib
-        sed -i -e 's|${TOOLCHAIN_OPTIONS}||g' config.h
+        test -n "${TOOLCHAIN_OPTIONS}" && sed -i -e 's|${TOOLCHAIN_OPTIONS}||g' config.h
         autotools_do_compile
     done
 }