diff mbox series

[meta-python,4/6] python3-pylint: upgrade 2.14.5 -> 2.17.3

Message ID 20230502165005.880470-5-tgamblin@baylibre.com
State Under Review
Headers show
Series Support updated python3-pylint | expand

Commit Message

Trevor Gamblin May 2, 2023, 4:50 p.m. UTC
Change pylint to inherit python_setuptools_build_meta instead of
setuptools3. Also add a patch to remove hard-coded version depdendencies
for wheel and setuptools from the pyproject.toml, otherwise the
following error occurs during do_compile:

| ERROR Missing dependencies:
|       wheel~=0.37.1
|       setuptools~=62.6

Release note links:
2.17.x: https://pylint.readthedocs.io/en/latest/whatsnew/2/2.17/index.html
2.16.x: https://pylint.readthedocs.io/en/latest/whatsnew/2/2.16/index.html
2.15.x: https://pylint.readthedocs.io/en/latest/whatsnew/2/2.15/index.html
2.14.x: https://pylint.readthedocs.io/en/latest/whatsnew/2/2.14/index.html

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 ....toml-Remove-hard-coded-dependencies.patch | 30 +++++++++++++++++++
 ...int_2.14.5.bb => python3-pylint_2.17.3.bb} |  5 ++--
 2 files changed, 33 insertions(+), 2 deletions(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
 rename meta-python/recipes-devtools/python/{python3-pylint_2.14.5.bb => python3-pylint_2.17.3.bb} (72%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
new file mode 100644
index 000000000..55d42b101
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
@@ -0,0 +1,30 @@ 
+From 843d050f1bf889b81fa8fc3e7a1350385c8348ec Mon Sep 17 00:00:00 2001
+From: Trevor Gamblin <tgamblin@baylibre.com>
+Date: Mon, 1 May 2023 11:32:24 -0400
+Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies
+
+The upstream pyproject.toml has hard-coded dependencies on specific
+versions of wheel and setuptools. This breaks builds of pylint 
+2.17.3, so patch it to remove the pinned versions.
+
+Upstream-Status: Pending
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index e4b63c660..0ee21e0eb 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,5 +1,5 @@
+ [build-system]
+-requires = ["setuptools~=62.6", "wheel~=0.37.1"]
++requires = ["setuptools", "wheel"]
+ build-backend = "setuptools.build_meta"
+ 
+ [project]
+-- 
+2.40.0
+
diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.14.5.bb b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
similarity index 72%
rename from meta-python/recipes-devtools/python/python3-pylint_2.14.5.bb
rename to meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
index 738b9250c..b85f77503 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_2.14.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
@@ -3,9 +3,10 @@  HOMEPAGE= "http://www.pylint.org/"
 LICENSE = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
 
-SRC_URI[sha256sum] = "487ce2192eee48211269a0e976421f334cf94de1806ca9d0a99449adcdf0285e"
+SRC_URI += "file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch"
+SRC_URI[sha256sum] = "761907349e699f8afdcd56c4fe02f3021ab5b3a0fc26d19a9bfdc66c7d0d5cd5"
 
-inherit pypi setuptools3
+inherit pypi python_setuptools_build_meta
 
 RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
                    ${PYTHON_PN}-isort \