diff mbox series

[meta-python] python3-pyzstd: add new recipe

Message ID 20230427094117.256986-1-johannes.pointner@br-automation.com
State Under Review
Headers show
Series [meta-python] python3-pyzstd: add new recipe | expand

Commit Message

Johannes Pointner April 27, 2023, 9:41 a.m. UTC
Add recipe for python bindings to ZStandard (zstd) compression library

Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com>
---
 .../python/python3-pyzstd_0.15.7.bb                 | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb b/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb
new file mode 100644
index 000000000..e7a6c2108
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb
@@ -0,0 +1,13 @@ 
+DESCRIPTION = "Pyzstd module provides classes and functions for compressing and \
+decompressing data, using Facebook’s Zstandard (or zstd as short name) algorithm."
+HOMEPAGE = "https://github.com/animalize/pyzstd"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8458383225d7107f3383ee5c521628d2"
+
+PYPI_PACKAGE = "pyzstd"
+
+SRC_URI[sha256sum] = "55e503f28f5a9d225ce9d0639e3f5b1801bacace5aea926ec2998e73c5150fe7"
+
+inherit pypi setuptools3