diff mbox series

glmark2: Update to 2023.01

Message ID 20230227192716.77091-1-festevam@gmail.com
State Under Review
Headers show
Series glmark2: Update to 2023.01 | expand

Commit Message

Fabio Estevam Feb. 27, 2023, 7:27 p.m. UTC
From: Fabio Estevam <festevam@denx.de>

Update to the 2023.01 version:

glmark2 2023.01 (20230119)
==========================

* Add gbm-gl/glesv2 flavors for GBM offscreen rendering.
* Add x11-gl-egl flavor that uses EGL under X11.
* Implement SwapInterval 0 for the DRM backend.
* Support multisampled configs in --visual-config.
* Support explicitly specifying the config id in --visual-config.
* Add CPU time and shader compilation time to available results.
* Add --results to specify which kind of results to report.
* Add --results-file to export results to XML or CSV.
* Add --version command-line option.

Remove 0001-libmatrix-Include-missing-utility-header.patch, which has been
upstreamed and refresh 0002-run-dispmanx-fullscreen.patch to avoid
fuzz warnings.

Signed-off-by: Fabio Estevam <festevam@denx.de>
---
 ...atrix-Include-missing-utility-header.patch | 24 -------------------
 .../files/0002-run-dispmanx-fullscreen.patch  | 10 ++++----
 .../recipes-benchmark/glmark2/glmark2_git.bb  |  5 ++--
 3 files changed, 8 insertions(+), 31 deletions(-)
 delete mode 100644 meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch
diff mbox series

Patch

diff --git a/meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch b/meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch
deleted file mode 100644
index 959a18e5e..000000000
--- a/meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch
+++ /dev/null
@@ -1,24 +0,0 @@ 
-From 45cb02332b38b2059e7e44369c3d8684492a7def Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 12 Apr 2022 11:41:41 -0700
-Subject: [PATCH] libmatrix: Include missing <utility> header
-
-Fixes build with gcc12
-| ../git/src/libmatrix/program.h:43:21: error: 'exchange' is not a member of 'std'                                                   |    43 |         ready_(std::exchange(shader.ready_, false)),                                                                       |       |                     ^~~~~~~~
-
-Upstream-Status: Submitted [https://github.com/glmark2/glmark2/pull/174]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/libmatrix/program.h | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/src/libmatrix/program.h
-+++ b/src/libmatrix/program.h
-@@ -13,6 +13,7 @@
- #define PROGRAM_H_
- 
- #include <string>
-+#include <utility>
- #include <vector>
- #include <map>
- #include "mat.h"
diff --git a/meta-oe/recipes-benchmark/glmark2/files/0002-run-dispmanx-fullscreen.patch b/meta-oe/recipes-benchmark/glmark2/files/0002-run-dispmanx-fullscreen.patch
index 0cb22fd56..05a074cf5 100644
--- a/meta-oe/recipes-benchmark/glmark2/files/0002-run-dispmanx-fullscreen.patch
+++ b/meta-oe/recipes-benchmark/glmark2/files/0002-run-dispmanx-fullscreen.patch
@@ -13,10 +13,10 @@  Signed-off-by: Trevor Woerner <twoerner@gmail.com>
  1 file changed, 5 insertions(+)
 
 diff --git a/src/main.cpp b/src/main.cpp
-index 677962e..273a217 100644
+index d1077fe..d717cd4 100644
 --- a/src/main.cpp
 +++ b/src/main.cpp
-@@ -164,6 +164,11 @@ main(int argc, char *argv[])
+@@ -202,6 +202,11 @@ main(int argc, char *argv[])
          Options::size = std::pair<int,int>(800, 600);
      }
  
@@ -26,5 +26,7 @@  index 677962e..273a217 100644
 +#endif
 +
      // Create the canvas
- #if GLMARK2_USE_X11
-     NativeStateX11 native_state;
+ #if GLMARK2_USE_EGL
+     GLStateEGL gl_state;
+--
+2.25.1
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 2a3e74f02..a2d5b152f 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -11,15 +11,14 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
 DEPENDS = "libpng jpeg udev"
 DEPENDS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-native wayland-protocols', '', d)}"
 
-PV = "2021.12"
+PV = "2023.01"
 
 SRC_URI = " \
     git://github.com/glmark2/glmark2.git;protocol=https;branch=master \
     file://0001-fix-dispmanx-build.patch \
     file://0002-run-dispmanx-fullscreen.patch \
-    file://0001-libmatrix-Include-missing-utility-header.patch \
 "
-SRCREV = "0858b450cd88c84a15b99dda9698d44e7f7e8c70"
+SRCREV = "42e3d8fe3aa88743ef90348138f643f7b04a9237"
 
 S = "${WORKDIR}/git"