diff mbox series

[meta-oe,v2] smemstat: add recipe

Message ID 20230214151754.3430230-1-jlu@pengutronix.de
State Under Review
Headers show
Series [meta-oe,v2] smemstat: add recipe | expand

Commit Message

Jan Lübbe Feb. 14, 2023, 3:17 p.m. UTC
This is useful to see which processes use physical memory.

Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
---

Changed since v2:
 - use make install for installation (suggested by Martin Jansa)
 - inherit bash-completion as make install also installs the
   bash-completion script
 - drop empty do_configure function

---
 .../smemstat/smemstat_0.02.11.bb              | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb b/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
new file mode 100644
index 000000000000..21f315b1c257
--- /dev/null
+++ b/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
@@ -0,0 +1,22 @@ 
+SUMMARY = "smemstat reports the physical memory usage taking into consideration shared memory"
+HOMEPAGE = "https://github.com/ColinIanKing/smemstat"
+LICENSE = "GPL-2.0-or-later"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "ncurses"
+
+SRC_URI = "git://github.com/ColinIanKing/smemstat.git;protocol=https;branch=master"
+SRCREV = "9eea7504ab33783d804c4ed9237e299effb68874"
+
+S = "${WORKDIR}/git"
+
+inherit bash-completion
+
+do_compile () {
+    oe_runmake smemstat
+}
+
+do_install () {
+    oe_runmake DESTDIR=${D} install
+}