diff mbox series

python3-daemon_2.3.2.bb: add python-daemon recipe for python3

Message ID 20230212185850.2856474-1-bhargav_das@mentor.com
State Under Review
Headers show
Series python3-daemon_2.3.2.bb: add python-daemon recipe for python3 | expand

Commit Message

Bhargav Das Feb. 12, 2023, 6:58 p.m. UTC
python-daemon was part of meta-python2 this has now been updated to
python3 and v2.3.2

Signed-off-by: Bhargav Das <bhargav_das@mentor.com>
---
 .../python/python3-daemon_2.3.2.bb            | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb b/meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb
new file mode 100644
index 000000000..49b094fce
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb
@@ -0,0 +1,19 @@ 
+DESCRIPTION = "Library to implement a well-behaved Unix daemon process"
+HOMEPAGE = "https://pagure.io/python-daemon/"
+SECTION = "devel/python"
+
+DEPENDS += "${PYTHON_PN}-docutils-native"
+RDEPENDS:${PN} = "${PYTHON_PN}-docutils \
+                  ${PYTHON_PN}-lockfile (>= 0.10) \
+                  ${PYTHON_PN}-resource \
+"
+
+LICENSE = "Apache-2.0 & GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://README;md5=a3a94c615dc969a70525f1eebbacf235"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "b7397fe73d516dc14921500a1245b41c"
+SRC_URI[sha256sum] = "3deeb808e72b6b89f98611889e11cc33754f5b2c1517ecfa1aaf25f402051fb5"
+
+PYPI_PACKAGE = "python-daemon"