diff mbox series

[meta-oe,05/13] redis-plus-plus: Fix build with gcc13

Message ID 20230126071735.2444745-5-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,01/13] vulkan-cts,opengl-es-cts: Fix build with gcc-13 | expand

Commit Message

Khem Raj Jan. 26, 2023, 7:17 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../files/0001-include-cstdint.patch          | 37 +++++++++++++++++++
 .../redis-plus-plus/redis-plus-plus_1.3.7.bb  |  3 +-
 2 files changed, 39 insertions(+), 1 deletion(-)
 create mode 100644 meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch b/meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch
new file mode 100644
index 0000000000..bfe2412b5d
--- /dev/null
+++ b/meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch
@@ -0,0 +1,37 @@ 
+From e74bb5a7ef87e697571181280e6108b89104c02d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 25 Jan 2023 20:40:56 -0800
+Subject: [PATCH] include <cstdint>
+
+gcc 13 libstdc++ moved some includes around and as a result <cstdint>
+is no longer transitively included [1]. Explicitly include it for uintXX_t.
+
+Fixes
+
+../git/src/sw/redis++/utils.h:187:1: error: 'uint16_t' does not name a type
+  187 | uint16_t crc16(const char *buf, int len);
+      | ^~~~~~~~
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Upstream-Status: Submitted [https://github.com/sewenew/redis-plus-plus/pull/449]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/sw/redis++/utils.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/sw/redis++/utils.h b/src/sw/redis++/utils.h
+index f77f796..ff38f2d 100644
+--- a/src/sw/redis++/utils.h
++++ b/src/sw/redis++/utils.h
+@@ -17,6 +17,7 @@
+ #ifndef SEWENEW_REDISPLUSPLUS_UTILS_H
+ #define SEWENEW_REDISPLUSPLUS_UTILS_H
+ 
++#include <cstdint>
+ #include <cstring>
+ #include <string>
+ #include <type_traits>
+-- 
+2.39.1
+
diff --git a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
index 21783b30d5..b127025a73 100644
--- a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
+++ b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
@@ -4,7 +4,8 @@  SECTION = "libs"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https"
+SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \
+           file://0001-include-cstdint.patch"
 SRCREV = "f3b19a8a1f609d1a1b79002802e5cf8c336dc262"
 
 S = "${WORKDIR}/git"