diff mbox series

[meta-gnome] xdg-desktop-portal-gtk: add recipe

Message ID 20230103143354.97830-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-gnome] xdg-desktop-portal-gtk: add recipe | expand

Commit Message

Markus Volk Jan. 3, 2023, 2:33 p.m. UTC
- add it as denpendency for xdg-desktop-portal-gnome

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../xdg-desktop-portal-gnome_43.1.bb          |  3 ++
 .../xdg-desktop-portal-gtk_1.14.1.bb          | 42 +++++++++++++++++++
 2 files changed, 45 insertions(+)
 create mode 100644 meta-gnome/recipes-support/xdg-desktop-portal/xdg-desktop-portal-gtk_1.14.1.bb
diff mbox series

Patch

diff --git a/meta-gnome/recipes-support/xdg-desktop-portal/xdg-desktop-portal-gnome_43.1.bb b/meta-gnome/recipes-support/xdg-desktop-portal/xdg-desktop-portal-gnome_43.1.bb
index a1532c24c..050ce1a04 100644
--- a/meta-gnome/recipes-support/xdg-desktop-portal/xdg-desktop-portal-gnome_43.1.bb
+++ b/meta-gnome/recipes-support/xdg-desktop-portal/xdg-desktop-portal-gnome_43.1.bb
@@ -7,6 +7,7 @@  DEPENDS = " \
     glib-2.0-native \
     gtk4\
     xdg-desktop-portal \
+    xdg-desktop-portal-gtk \
     libadwaita \
     fontconfig \
     gsettings-desktop-schemas \
@@ -14,6 +15,8 @@  DEPENDS = " \
     dconf \
 "
 
+RDEPENDS:${PN} = "xdg-desktop-portal xdg-desktop-portal-gtk"
+
 inherit meson pkgconfig gsettings features_check
 
 REQUIRED_DISTRO_FEATURES = "polkit"
diff --git a/meta-gnome/recipes-support/xdg-desktop-portal/xdg-desktop-portal-gtk_1.14.1.bb b/meta-gnome/recipes-support/xdg-desktop-portal/xdg-desktop-portal-gtk_1.14.1.bb
new file mode 100644
index 000000000..79597cb94
--- /dev/null
+++ b/meta-gnome/recipes-support/xdg-desktop-portal/xdg-desktop-portal-gtk_1.14.1.bb
@@ -0,0 +1,42 @@ 
+SUMMARY = "A backend implementation for xdg-desktop-portal that is using GTK and various pieces of GNOME infrastructure."
+HOMEPAGE = "https://github.com/flatpak/xdg-desktop-portal-gtk"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = " \
+    glib-2.0-native \
+    gtk+3\
+    xdg-desktop-portal \
+    libadwaita \
+    fontconfig \
+    gsettings-desktop-schemas \
+    gnome-desktop \
+    dconf \
+"
+
+inherit gettext autotools pkgconfig gsettings features_check
+
+REQUIRED_DISTRO_FEATURES = "polkit"
+
+SRC_URI = "git://github.com/flatpak/xdg-desktop-portal-gtk.git;protocol=https;nobranch=1"
+
+S = "${WORKDIR}/git"
+SRCREV = "952005f6a7850a247d286f14838202f506b402b7"
+
+# gdbus-codegen wants to create files in ${B}/src and fails because of missing directory
+do_configure:append() {
+	mkdir -p ${B}/src
+}
+
+# Note: wlroots has its own implementation for screenshot and screencast, but
+# you may want to include the according PACKAGECONFIGS for gnome.
+PACKAGECONFIG ?= "wallpaper background appchooser lockdown"
+
+PACKAGECONFIG[screenshot] = "--enable-screenshot,--disable-screenshot,gnome-shell"
+PACKAGECONFIG[screencast] = "--enable-screencast,--disable-screencast,mutter"
+PACKAGECONFIG[wallpaper] = "--enable-wallpaper,--disable-wallpaper,gnome-desktop"
+PACKAGECONFIG[background] = "--enable-background,--disable-background,gnome-shell"
+PACKAGECONFIG[appchooser] = "--enable-appchooser,--disable-appchooser"
+PACKAGECONFIG[lockdown] = "--enable-lockdown,--disable-lockdown"
+
+FILES:${PN} += "${systemd_user_unitdir} ${datadir}"