diff mbox series

[meta-oe,1/4] ostree: Use systemd_system_unitdir for systemd units

Message ID 20230102224234.287772-1-alex.kiernan@gmail.com
State Under Review
Headers show
Series [meta-oe,1/4] ostree: Use systemd_system_unitdir for systemd units | expand

Commit Message

Alex Kiernan Jan. 2, 2023, 10:42 p.m. UTC
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
---

 meta-oe/recipes-extended/ostree/ostree_2022.7.bb | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/ostree/ostree_2022.7.bb b/meta-oe/recipes-extended/ostree/ostree_2022.7.bb
index 771b17b34b35..0a56ad7c8369 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2022.7.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2022.7.bb
@@ -84,7 +84,7 @@  PACKAGECONFIG[selinux] = "--with-selinux, --without-selinux, libselinux, bubblew
 PACKAGECONFIG[smack] = "--with-smack, --without-smack, smack"
 PACKAGECONFIG[soup] = "--with-soup, --without-soup --disable-glibtest, libsoup-2.4"
 PACKAGECONFIG[static] = ""
-PACKAGECONFIG[systemd] = "--with-libsystemd --with-systemdsystemunitdir=${systemd_unitdir}/system, --without-libsystemd, systemd"
+PACKAGECONFIG[systemd] = "--with-libsystemd --with-systemdsystemunitdir=${systemd_system_unitdir}, --without-libsystemd, systemd"
 PACKAGECONFIG[trivial-httpd-cmdline] = "--enable-trivial-httpd-cmdline, --disable-trivial-httpd-cmdline"
 
 EXTRA_OECONF = " \
@@ -139,7 +139,7 @@  PACKAGE_BEFORE_PN = " \
 FILES:${PN} += " \
     ${nonarch_libdir}/${BPN} \
     ${nonarch_libdir}/tmpfiles.d \
-    ${systemd_unitdir}/system \
+    ${systemd_system_unitdir} \
     ${systemd_unitdir}/system-generators \
 "
 FILES:${PN}-dracut = " \
@@ -156,7 +156,7 @@  FILES:${PN}-mkinitcpio = " \
 "
 FILES:${PN}-switchroot = " \
     ${nonarch_libdir}/${BPN}/ostree-prepare-root \
-    ${systemd_unitdir}/system/ostree-prepare-root.service \
+    ${systemd_system_unitdir}/ostree-prepare-root.service \
 "
 FILES:${PN}-trivial-httpd = " \
     ${libexecdir}/libostree/ostree-trivial-httpd \