diff mbox series

[meta-multimedia] pipewire: update 0.3.61 -> 0.3.62

Message ID 20221209181723.3151-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-multimedia] pipewire: update 0.3.61 -> 0.3.62 | expand

Commit Message

Markus Volk Dec. 9, 2022, 6:17 p.m. UTC
PipeWire 0.3.62 (2022-12-09)
This is a bugfix release that is API and ABI compatible with previous
0.3.x releases.

Highlights

A regression in screensharing was fixed. It was caused by a race when
activating links and driver nodes.
Video transform metadata was added so that cameras and screen sharing
can report the video orientation and transformations.
Support for the PulseAudio module-gsettings was added to make paprefs
work.
Support for bluetooth offloading was added. This allows for the bluetooth
reception, decoding and playback to happen completely in hardware.
This also requires some support in WirePlumber.
Many bugfixes and improvements.

PipeWire

More work on stopping nodes in a more controlled way.
Fix a race in starting nodes and drivers. In some cases the driver
node would already be started while the link to the peer node was not
ready yet. This caused regressions in screen sharing. The driver is
now only started after all the followers and links completed.
Fix a case where a slow capture stream would not recycle buffers
anymore and stall. (#2874)
Fix a subtle bug in pw_loop_invoke that could cause callbacks to be
delayed and cause crashes in some cases.
Fix a case where IPC was done from the data-thread and could cause
crashes.

Tools

Silence some expected errors in the pw-top output.

modules

The filter-chain has seen some optimizations in the copy plugin and
the convolver.
The zeroconf plugin will now only unpublish services from the server
that was removed.
Fix a potential crash when stopping pw-loopback.
Some harmless errors were turned into info messages.
Fix some cases where pw_stream methods were called from the data-thread
that could cause segfaults. (#2633)

SPA

There is now a video transform metadata that indicates how a video
frame was transformed (rotated/flipped). libcamera and the GStreamer
elements now have support for this metadata.
The SPA volume plugin is now disabled from the default build.
Handle missing control info in libcamera.
Handle errors from loop better, don't call the callbacks on errors.
Somewhat improve performance in some audioconvert AVX2 code for format
conversion.
Fix PortConfig and EnumPortConfig params in audioconvert and
audioadapter to reflect what is actually going on instead of using
hardcoded values.
Pass ignore-dB property correctly in all cases.
Probing is now done in 48KHz again. (#2857)

Pulse-server

IPv4 addresses are now added first to the list and exposed first with
zeroconf discover.
module-gsettings was added to make paprefs work.
The pulse.idle.timeout option was disabled by default and only enabled
for selected apps (speech-dispatcher) because it caused some problems
for other apps. (#2880)

JACK

Only process valid ports. Could fix some crashes. (#2863)

Bluetooth

Support was added for offloading bluetooth handling. Some hardware can
receive, decode and play the bluetooth audio directly in hardware.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../pipewire/{pipewire_0.3.61.bb => pipewire_0.3.62.bb}       | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
 rename meta-multimedia/recipes-multimedia/pipewire/{pipewire_0.3.61.bb => pipewire_0.3.62.bb} (98%)
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.61.bb b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.62.bb
similarity index 98%
rename from meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.61.bb
rename to meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.62.bb
index 1d88fe92a..a358ea417 100644
--- a/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.61.bb
+++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.62.bb
@@ -13,7 +13,7 @@  LIC_FILES_CHKSUM = " \
 
 DEPENDS = "dbus ncurses"
 
-SRCREV = "f038e3f23824f9319daaa9f9a31600fc6df49a39"
+SRCREV = "3a443b4e1c9730675c7de0453a6279ab9ee263fd"
 SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https"
 
 S = "${WORKDIR}/git"
@@ -85,6 +85,7 @@  PACKAGECONFIG:class-target ??= " \
     ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
     ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez bluez-opus ${BLUETOOTH_AAC}', '', d)} \
     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd systemd-system-service systemd-user-service', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio gtk', 'gsettings', '', d)} \
     ${@bb.utils.filter('DISTRO_FEATURES', 'alsa vulkan pulseaudio', d)} \
     ${PIPEWIRE_SESSION_MANAGER} \
     ${FFMPEG_AVAILABLE} gstreamer jack libusb pw-cat raop sndfile v4l2 udev volume \
@@ -102,6 +103,7 @@  PACKAGECONFIG[bluez-aac] = "-Dbluez5-codec-aac=enabled,-Dbluez5-codec-aac=disabl
 PACKAGECONFIG[bluez-opus] = "-Dbluez5-codec-opus=enabled,-Dbluez5-codec-opus=disabled,libopus"
 PACKAGECONFIG[docs] = "-Ddocs=enabled,-Ddocs=disabled,doxygen-native graphviz-native"
 PACKAGECONFIG[ffmpeg] = "-Dffmpeg=enabled,-Dffmpeg=disabled,ffmpeg"
+PACKAGECONFIG[gsettings] = "-Dgsettings=enabled,-Dgsettings=disabled,glib-2.0"
 PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base,,gstreamer1.0-pipewire"
 PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack,,,pipewire-jack"
 PACKAGECONFIG[libcamera] = "-Dlibcamera=enabled,-Dlibcamera=disabled,libcamera libdrm"