diff mbox series

[meta-python,1/7] python3-pystemd: Regenerate .c sources using newer cython

Message ID 20221130200115.1954308-1-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/7] python3-pystemd: Regenerate .c sources using newer cython | expand

Commit Message

Khem Raj Nov. 30, 2022, 8:01 p.m. UTC
python 3.11 has moved the header "longintrepr.h" into a sub-folder [1]
the pre-generated .c files are generated using older cython, therefore
in order to compile it with python 3.11 regenerate them with OE's own
native cython

[1] https://bugs.python.org/issue35134

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../recipes-devtools/python/python3-pystemd_0.10.0.bb       | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb b/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
index da263fe94e..da22a43deb 100644
--- a/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
@@ -4,10 +4,14 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
 
 SRC_URI[sha256sum] = "d74a814bfda01085db1a8ad90be3cb27daf23a51ab6b03e7e29ec811fa2ae859"
 
-DEPENDS = "systemd"
+DEPENDS = "systemd python3-cython-native"
 RDEPENDS:${PN} += "python3-xml python3-pprint"
 REQUIRED_DISTRO_FEATURES = "systemd"
 
 inherit pypi setuptools3 features_check pkgconfig
 
+do_configure:prepend() {
+    rm -rf ${S}/pystemd/*.c
+}
+
 BBCLASSEXTEND = "native"