diff mbox series

[meta-python,2/2] python3-uefi-firmware: add recipe for version 1.9

Message ID 20221125114411.128952-2-tomasz.zyjewski@3mdeb.com
State Under Review
Headers show
Series [meta-python,1/2] python3-binwalk: add recipe for version 2.3.3 | expand

Commit Message

Tomasz Żyjewski Nov. 25, 2022, 11:44 a.m. UTC
Install uefi-firmware-parser tool

Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
---
 .../python/python3-uefi-firmware_1.9.bb         | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb

Comments

Tim Orling Nov. 26, 2022, 11:17 p.m. UTC | #1
On Fri, Nov 25, 2022 at 3:44 AM tomzy <tomasz.zyjewski@3mdeb.com> wrote:

> Install uefi-firmware-parser tool
>
> Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
> ---
>  .../python/python3-uefi-firmware_1.9.bb         | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/
> python3-uefi-firmware_1.9.bb
>
> diff --git a/meta-python/recipes-devtools/python/
> python3-uefi-firmware_1.9.bb b/meta-python/recipes-devtools/python/
> python3-uefi-firmware_1.9.bb
> new file mode 100644
> index 000000000000..ba3124b36e60
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Various data structures and parsing tools for UEFI firmware."
> +DESCRIPTION = "This package contains Python UEFI firmware parser tool.
> The \
> +UEFI firmware parser is a simple module and set of scripts for parsing, \
> +extracting, and recreating UEFI firmware volumes. This includes parsing \
> +modules for BIOS, OptionROM, Intel ME and other formats too."
> +HOMEPAGE = "https://github.com/theopolis/uefi-firmware-parser"
> +AUTHOR = "Teddy Reed <teddy@prosauce.org>"
> +LICENSE = "BSD-2-Clause & BSD-3-Clause"
> +LIC_FILES_CHKSUM = "file://setup.py;md5=90fa5bae1547550f1c1993f651eda955"
> +
> +SRC_URI = "
> https://files.pythonhosted.org/packages/7e/b4/a4ec646d24a1aad709fdb83de6e5eddd6cb24faec02f3a94a3af3b0aba28/uefi_firmware-${PV}.tar.gz
> "
>

If you’re fetching from  pythonhosted, you could very likely simplify the
recipe by inheriting pypi bbclass

+SRC_URI[md5sum] = "ee5011b4d0bcb0eb7c06295e0107894f"


These days, we only really use the sha256sum

>
> +SRC_URI[sha256sum] =
> "234119dd92780c67cce3b664e86119c41d0b2af188d7f372b69789b32c5d5cd0"
> +
> +S = "${WORKDIR}/uefi_firmware-${PV}"
> +
> +inherit setuptools3
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#99729):
> https://lists.openembedded.org/g/openembedded-devel/message/99729
> Mute This Topic: https://lists.openembedded.org/mt/95252447/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Tomasz Żyjewski Nov. 30, 2022, 7:29 a.m. UTC | #2
> 
> On Fri, Nov 25, 2022 at 3:44 AM tomzy < tomasz.zyjewski@... > wrote:
> 

> 
> Install uefi-firmware-parser tool
> 
> Signed-off-by: Tomasz Żyjewski < tomasz.zyjewski@... >
> ---
> .../python/ python3-uefi-firmware_1.9.bb (
> http://python3-uefi-firmware_1.9.bb ) | 17 +++++++++++++++++
> 1 file changed, 17 insertions(+)
> create mode 100644 meta-python/recipes-devtools/python/ python3-uefi-firmware_1.9.bb
> ( http://python3-uefi-firmware_1.9.bb )
> 
> diff --git a/meta-python/recipes-devtools/python/ python3-uefi-firmware_1.9.bb
> ( http://python3-uefi-firmware_1.9.bb ) b/meta-python/recipes-devtools/python/
> python3-uefi-firmware_1.9.bb ( http://python3-uefi-firmware_1.9.bb )
> new file mode 100644
> index 000000000000..ba3124b36e60
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/ python3-uefi-firmware_1.9.bb (
> http://python3-uefi-firmware_1.9.bb )
> @@ -0,0 +1,17 @@
> +SUMMARY = "Various data structures and parsing tools for UEFI firmware."
> +DESCRIPTION = "This package contains Python UEFI firmware parser tool.
> The \
> +UEFI firmware parser is a simple module and set of scripts for parsing, \
> 
> +extracting, and recreating UEFI firmware volumes. This includes parsing \
> 
> +modules for BIOS, OptionROM, Intel ME and other formats too."
> +HOMEPAGE = " https://github.com/theopolis/uefi-firmware-parser "
> +AUTHOR = "Teddy Reed < teddy@... >"
> +LICENSE = "BSD-2-Clause & BSD-3-Clause"
> +LIC_FILES_CHKSUM = "file://setup.py;md5=90fa5bae1547550f1c1993f651eda955"
> 
> +
> +SRC_URI = " https://files.pythonhosted.org/packages/7e/b4/a4ec646d24a1aad709fdb83de6e5eddd6cb24faec02f3a94a3af3b0aba28/uefi_firmware-${PV}.tar.gz
> (
> https://files.pythonhosted.org/packages/7e/b4/a4ec646d24a1aad709fdb83de6e5eddd6cb24faec02f3a94a3af3b0aba28/uefi_firmware-$%7BPV%7D.tar.gz
> ) "

> 
> 
> If you’re fetching from  pythonhosted, you could very likely simplify the
> recipe by inheriting pypi bbclass
> 
> 

> 
> +SRC_URI[md5sum] = "ee5011b4d0bcb0eb7c06295e0107894f"

> 
> 
> These days, we only really use the sha256sum
> +SRC_URI[sha256sum] =
> "234119dd92780c67cce3b664e86119c41d0b2af188d7f372b69789b32c5d5cd0" + +S =
> "${WORKDIR}/uefi_firmware-${PV}" + +inherit setuptools3 -- 2.25.1

Used git fetcher here, I just send PATCH V2, not sure if it visible on mailing list.
Khem Raj Nov. 30, 2022, 8:08 p.m. UTC | #3
On 11/29/22 11:29 PM, tomzy wrote:
>     On Fri, Nov 25, 2022 at 3:44 AM tomzy <tomasz.zyjewski@...
>     <mailto:tomasz.zyjewski@...>> wrote:
> 
>     Install uefi-firmware-parser tool
> 
>     Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@...
>     <mailto:tomasz.zyjewski@...>>
>     ---
>       .../python/python3-uefi-firmware_1.9.bb
>     <http://python3-uefi-firmware_1.9.bb>         | 17 +++++++++++++++++
>       1 file changed, 17 insertions(+)
>       create mode 100644
>     meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
>     <http://python3-uefi-firmware_1.9.bb>
> 
>     diff --git
>     a/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
>     <http://python3-uefi-firmware_1.9.bb>
>     b/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
>     <http://python3-uefi-firmware_1.9.bb>
>     new file mode 100644
>     index 000000000000..ba3124b36e60
>     --- /dev/null
>     +++
>     b/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
>     <http://python3-uefi-firmware_1.9.bb>
>     @@ -0,0 +1,17 @@
>     +SUMMARY = "Various data structures and parsing tools for UEFI
>     firmware."
>     +DESCRIPTION = "This package contains Python UEFI firmware parser
>     tool. The \
>     +UEFI firmware parser is a simple module and set of scripts for
>     parsing, \
>     +extracting, and recreating UEFI firmware volumes. This includes
>     parsing \
>     +modules for BIOS, OptionROM, Intel ME and other formats too."
>     +HOMEPAGE = "https://github.com/theopolis/uefi-firmware-parser
>     <https://github.com/theopolis/uefi-firmware-parser>"
>     +AUTHOR = "Teddy Reed <teddy@... <mailto:teddy@...>>"
>     +LICENSE = "BSD-2-Clause & BSD-3-Clause"
>     +LIC_FILES_CHKSUM =
>     "file://setup.py;md5=90fa5bae1547550f1c1993f651eda955"
>     +
>     +SRC_URI =
>     "https://files.pythonhosted.org/packages/7e/b4/a4ec646d24a1aad709fdb83de6e5eddd6cb24faec02f3a94a3af3b0aba28/uefi_firmware-${PV}.tar.gz <https://files.pythonhosted.org/packages/7e/b4/a4ec646d24a1aad709fdb83de6e5eddd6cb24faec02f3a94a3af3b0aba28/uefi_firmware-$%7BPV%7D.tar.gz>"
> 
>     If you’re fetching from  pythonhosted, you could very likely
>     simplify the recipe by inheriting pypi bbclass
> 
>     +SRC_URI[md5sum] = "ee5011b4d0bcb0eb7c06295e0107894f"
> 
>     These days, we only really use the sha256sum
>     +SRC_URI[sha256sum] =
>     "234119dd92780c67cce3b664e86119c41d0b2af188d7f372b69789b32c5d5cd0" +
>     +S = "${WORKDIR}/uefi_firmware-${PV}" + +inherit setuptools3 -- 2.25.1
> 
> 
> Used git fetcher here, I just send PATCH V2, not sure if it visible on 
> mailing list.

Its not. Where did you send it ?

> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#99869): https://lists.openembedded.org/g/openembedded-devel/message/99869
> Mute This Topic: https://lists.openembedded.org/mt/95252447/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Tomasz Żyjewski Dec. 1, 2022, 8:37 a.m. UTC | #4
On Wed, Nov 30, 2022 at 09:08 PM, Khem Raj wrote:

> 
> On 11/29/22 11:29 PM, tomzy wrote:
> 
>> On Fri, Nov 25, 2022 at 3:44 AM tomzy <tomasz.zyjewski@...
>> <mailto:tomasz.zyjewski@...>> wrote:
>> 
>> Install uefi-firmware-parser tool
>> 
>> Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@...
>> <mailto:tomasz.zyjewski@...>>
>> ---
>> .../python/python3-uefi-firmware_1.9.bb
>> < http://python3-uefi-firmware_1.9.bb >         | 17 +++++++++++++++++
>> 1 file changed, 17 insertions(+)
>> create mode 100644
>> meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
>> < http://python3-uefi-firmware_1.9.bb >
>> 
>> diff --git
>> a/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
>> < http://python3-uefi-firmware_1.9.bb >
>> b/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
>> < http://python3-uefi-firmware_1.9.bb >
>> new file mode 100644
>> index 000000000000..ba3124b36e60
>> --- /dev/null
>> +++
>> b/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
>> < http://python3-uefi-firmware_1.9.bb >
>> @@ -0,0 +1,17 @@
>> +SUMMARY = "Various data structures and parsing tools for UEFI
>> firmware."
>> +DESCRIPTION = "This package contains Python UEFI firmware parser
>> tool. The \
>> +UEFI firmware parser is a simple module and set of scripts for
>> parsing, \
>> +extracting, and recreating UEFI firmware volumes. This includes
>> parsing \
>> +modules for BIOS, OptionROM, Intel ME and other formats too."
>> +HOMEPAGE = " https://github.com/theopolis/uefi-firmware-parser
>> < https://github.com/theopolis/uefi-firmware-parser>"
>> +AUTHOR = "Teddy Reed <teddy@... <mailto:teddy@...>>"
>> +LICENSE = "BSD-2-Clause & BSD-3-Clause"
>> +LIC_FILES_CHKSUM =
>> "file://setup.py;md5=90fa5bae1547550f1c1993f651eda955"
>> +
>> +SRC_URI =
>> " https://files.pythonhosted.org/packages/7e/b4/a4ec646d24a1aad709fdb83de6e5eddd6cb24faec02f3a94a3af3b0aba28/uefi_firmware-
>> ${PV}.tar.gz < https://files.pythonhosted.org/packages/7e/b4/a4ec646d24a1aad709fdb83de6e5eddd6cb24faec02f3a94a3af3b0aba28/uefi_firmware-
>> $%7BPV%7D.tar.gz>"
>> 
>> If you’re fetching from  pythonhosted, you could very likely
>> simplify the recipe by inheriting pypi bbclass
>> 
>> +SRC_URI[md5sum] = "ee5011b4d0bcb0eb7c06295e0107894f"
>> 
>> These days, we only really use the sha256sum
>> +SRC_URI[sha256sum] =
>> "234119dd92780c67cce3b664e86119c41d0b2af188d7f372b69789b32c5d5cd0" +
>> +S = "${WORKDIR}/uefi_firmware-${PV}" + +inherit setuptools3 -- 2.25.1
>> 
>> 
>> Used git fetcher here, I just send PATCH V2, not sure if it visible on
>> mailing list.
> 
> Its not. Where did you send it ?

I must had something wrong with my email settings. Now it is sent. Just pushed V3 because of typo in subject-prefix.

uefi-firmware: https://lists.openembedded.org/g/openembedded-devel/message/99883

binwalk: https://lists.openembedded.org/g/openembedded-devel/message/99882
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb b/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
new file mode 100644
index 000000000000..ba3124b36e60
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-uefi-firmware_1.9.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Various data structures and parsing tools for UEFI firmware."
+DESCRIPTION = "This package contains Python UEFI firmware parser tool. The \
+UEFI firmware parser is a simple module and set of scripts for parsing, \
+extracting, and recreating UEFI firmware volumes. This includes parsing \
+modules for BIOS, OptionROM, Intel ME and other formats too."
+HOMEPAGE = "https://github.com/theopolis/uefi-firmware-parser"
+AUTHOR = "Teddy Reed <teddy@prosauce.org>"
+LICENSE = "BSD-2-Clause & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://setup.py;md5=90fa5bae1547550f1c1993f651eda955"
+
+SRC_URI = "https://files.pythonhosted.org/packages/7e/b4/a4ec646d24a1aad709fdb83de6e5eddd6cb24faec02f3a94a3af3b0aba28/uefi_firmware-${PV}.tar.gz"
+SRC_URI[md5sum] = "ee5011b4d0bcb0eb7c06295e0107894f"
+SRC_URI[sha256sum] = "234119dd92780c67cce3b664e86119c41d0b2af188d7f372b69789b32c5d5cd0"
+
+S = "${WORKDIR}/uefi_firmware-${PV}"
+
+inherit setuptools3