diff mbox series

python3-aioserial: new package

Message ID 20221125091903.446-1-gdelaende@gmail.com
State Under Review
Headers show
Series python3-aioserial: new package | expand

Commit Message

Gerbrand De Laender Nov. 25, 2022, 9:19 a.m. UTC
Adds a recipe for aioserial - an asynchronous serial port library for
Python

Signed-off-by: Gerbrand De Laender <gdelaende@gmail.com>
---
 .../python/python3-aioserial_1.3.1.bb           | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100755 meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb b/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
new file mode 100755
index 000000000..7ef47a2f8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
@@ -0,0 +1,17 @@ 
+DESCRIPTION = "An asynchronous serial port library for Python"
+HOMEPAGE = "https://github.com/changyuheng/aioserial.py"
+SECTION = "devel/python"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=650b9179efef1ea560df5c08bc32b494"
+
+PYPI_PACKAGE = "aioserial"
+
+SRC_URI[sha256sum] = "702bf03b0eb84b8ef2d8dac5cb925e1e685dce98f77b125569bc6fd2b3b58228"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-pyserial \
+"