diff mbox series

[meta-python,2/2] python3-distro: Upgrade 1.7.0 -> 1.8.0

Message ID 20221017105226.3623929-2-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/2] python3-imageio: Upgrade 2.22.1 -> 2.22.2 | expand

Commit Message

Leon Anavi Oct. 17, 2022, 10:52 a.m. UTC
Upgrade to release 1.8.0:

- Replace setup.py with build
- Lowered LinuxDistribution._distro_release_info method complexity
- Added official support for Buildroot distribution
- Added official support for Guix distribution
- Added support for /etc/debian_version
- Fixed a typography in CONTRIBUTING.md
- Improved README.md "Usage" code block

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-distro_1.7.0.bb => python3-distro_1.8.0.bb}      | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-distro_1.7.0.bb => python3-distro_1.8.0.bb} (72%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb b/meta-python/recipes-devtools/python/python3-distro_1.8.0.bb
similarity index 72%
rename from meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
rename to meta-python/recipes-devtools/python/python3-distro_1.8.0.bb
index f069234d1..f7616e473 100644
--- a/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-distro_1.8.0.bb
@@ -5,9 +5,9 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
 
 PYPI_PACKAGE = "distro"
 
-SRC_URI[sha256sum] = "151aeccf60c216402932b52e40ee477a939f8d58898927378a02abbe852c1c39"
+SRC_URI[sha256sum] = "02e111d1dc6a50abb8eed6bf31c3e48ed8b0830d1ea2a1b78c61765c2513fdd8"
 
-inherit pypi setuptools3
+inherit pypi python_setuptools_build_meta
 
 RDEPENDS:${PN} = "\
 	${PYTHON_PN}-core \