diff mbox series

[meta-python] python3-sentry-sdk: Upgrade 1.5.12 -> 1.9.10

Message ID 20221011100004.409112-1-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python] python3-sentry-sdk: Upgrade 1.5.12 -> 1.9.10 | expand

Commit Message

Leon Anavi Oct. 11, 2022, 10 a.m. UTC
Upgrade to release 1.9.10:

- Added newer Celery versions to test suite
- Django 4.x support
- Cancel old CI runs when new one is started.
- Increase max string size for desc
- Pin Sanic version for CI
- Fix for partial signals in old Django and old Python versions.
- Convert profile output to the sample format
- Dynamically adjust profiler sleep time

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...ry-sdk_1.5.12.bb => python3-sentry-sdk_1.9.10.bb} | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-sentry-sdk_1.5.12.bb => python3-sentry-sdk_1.9.10.bb} (57%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.5.12.bb b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.9.10.bb
similarity index 57%
rename from meta-python/recipes-devtools/python/python3-sentry-sdk_1.5.12.bb
rename to meta-python/recipes-devtools/python/python3-sentry-sdk_1.9.10.bb
index 36e48f97a..c09a01b2a 100644
--- a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.5.12.bb
+++ b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.9.10.bb
@@ -5,9 +5,17 @@  HOMEPAGE = "https://github.com/getsentry/sentry-python"
 LICENSE = "BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=0c79f8d3c91fc847350efd28bfe0a341"
 
-RDEPENDS:${PN} += "python3-urllib3"
+RDEPENDS:${PN} += "\
+	${PYTHON_PN}-urllib3 \
+	${PYTHON_PN}-core \
+	${PYTHON_PN}-json \
+	${PYTHON_PN}-logging \
+	${PYTHON_PN}-threading \
+	${PYTHON_PN}-compression \
+	${PYTHON_PN}-datetime \
+"
 
-SRC_URI[sha256sum] = "259535ba66933eacf85ab46524188c84dcb4c39f40348455ce15e2c0aca68863"
+SRC_URI[sha256sum] = "4fbace9a763285b608c06f01a807b51acb35f6059da6a01236654e08b0ee81ff"
 
 PYPI_PACKAGE = "sentry-sdk"