diff mbox series

[meta-networking,1/1] chrony: add pkgconfig class as pkg-config is explicitly searched for

Message ID 20221006121721.10025-1-fede@evolware.org
State Under Review
Headers show
Series [meta-networking,1/1] chrony: add pkgconfig class as pkg-config is explicitly searched for | expand

Commit Message

Federico Pellegrin Oct. 6, 2022, 12:17 p.m. UTC
The configure script present in chrony will explicitly look for
pkg-config and without the pkgconfig class it will fail:

Checking for pkg-config : No

This then affects the possibility (via image features or bbappend)
to use features based on nettle/gnutls/nss which strictly require
pkgconfig to be present and working.

Signed-off-by: Federico Pellegrin <fede@evolware.org>
---
 meta-networking/recipes-support/chrony/chrony_4.3.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/chrony/chrony_4.3.bb b/meta-networking/recipes-support/chrony/chrony_4.3.bb
index 083d2cbc0..6617164e3 100644
--- a/meta-networking/recipes-support/chrony/chrony_4.3.bb
+++ b/meta-networking/recipes-support/chrony/chrony_4.3.bb
@@ -45,7 +45,7 @@  DEPENDS = "pps-tools"
 
 # Note: Despite being built via './configure; make; make install',
 #       chrony does not use GNU Autotools.
-inherit update-rc.d systemd
+inherit update-rc.d systemd pkgconfig
 
 # Add chronyd user if privdrop packageconfig is selected
 inherit ${@bb.utils.contains('PACKAGECONFIG', 'privdrop', 'useradd', '', d)}