diff mbox series

[meta-python] python3-termcolor: Upgrade 1.1.0 -> 2.0.1

Message ID 20220920100208.408905-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python] python3-termcolor: Upgrade 1.1.0 -> 2.0.1 | expand

Commit Message

Leon Anavi Sept. 20, 2022, 10:02 a.m. UTC
Upgrade to release 2.0.1:

- Add support for Python 3.11 and PyPy
- Add support for Python 3.10
- Add type annotations to the project and run mypy on CI
- Add tests
- Refer to GitHub Releases for release notes for 2.0.0+
- Autodeploy to TestPyPI and to PyPI for GH releases
- Migrate from setuptools + setuptools_scm to hatchling + hatch-vcs
- Replace deprecated license_file with license_files in setup.cfg
- Use declarative metadata in setup.cfg
- Replace 3.9-dev with 3.9 in CI to use Python 3.9 final
- Drop support for EOL Python <= 3.6
- Remove hardcoded VERSION constant
- Update source URL

License-Update: Removed new line from the end of license file.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...-Use-setuptools-instead-of-distutils.patch | 27 -------------------
 .../python/python3-termcolor_1.1.0.bb         | 13 ---------
 .../python/python3-termcolor_2.0.1.bb         | 16 +++++++++++
 3 files changed, 16 insertions(+), 40 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-termcolor/0001-setup.py-Use-setuptools-instead-of-distutils.patch
 delete mode 100644 meta-python/recipes-devtools/python/python3-termcolor_1.1.0.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-termcolor_2.0.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-termcolor/0001-setup.py-Use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-termcolor/0001-setup.py-Use-setuptools-instead-of-distutils.patch
deleted file mode 100644
index a55a6a914..000000000
--- a/meta-python/recipes-devtools/python/python3-termcolor/0001-setup.py-Use-setuptools-instead-of-distutils.patch
+++ /dev/null
@@ -1,27 +0,0 @@ 
-From e30308284c721210e2ba50d8b3d159cedf5eada8 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 28 Feb 2022 14:44:42 -0800
-Subject: [PATCH] setup.py: Use setuptools instead of distutils
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index c4fe4ed..dad1d29 100755
---- a/setup.py
-+++ b/setup.py
-@@ -23,7 +23,7 @@
- # Author: Konstantin Lepa <konstantin.lepa@gmail.com>
- 
- import os
--from distutils.core import setup
-+from setuptools import setup
- 
- prjdir = os.path.dirname(__file__)
- 
--- 
-2.35.1
-
diff --git a/meta-python/recipes-devtools/python/python3-termcolor_1.1.0.bb b/meta-python/recipes-devtools/python/python3-termcolor_1.1.0.bb
deleted file mode 100644
index 15bab622a..000000000
--- a/meta-python/recipes-devtools/python/python3-termcolor_1.1.0.bb
+++ /dev/null
@@ -1,13 +0,0 @@ 
-SUMMARY = "ANSII Color formatting for output in terminal"
-HOMEPAGE = "https://pypi.python.org/pypi/termcolor"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING.txt;md5=809e8749b63567978acfbd81d9f6a27d"
-
-inherit pypi setuptools3
-
-SRC_URI += "file://0001-setup.py-Use-setuptools-instead-of-distutils.patch"
-
-SRC_URI[sha256sum] = "1d6d69ce66211143803fbc56652b41d73b4a400a2891d7bf7a1cdf4c02de613b"
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-termcolor_2.0.1.bb b/meta-python/recipes-devtools/python/python3-termcolor_2.0.1.bb
new file mode 100644
index 000000000..47f7938f1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-termcolor_2.0.1.bb
@@ -0,0 +1,16 @@ 
+SUMMARY = "ANSII Color formatting for output in terminal"
+HOMEPAGE = "https://pypi.python.org/pypi/termcolor"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=e5f5f7c9b280511f124dba5dda3d180e"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "6b2cf769e93364a2676e1de56a7c0cff2cf5bd07f37e9cc80b0dd6320ebfe388"
+
+DEPENDS += " \
+	${PYTHON_PN}-toml-native \
+	${PYTHON_PN}-hatch-vcs-native \
+"
+
+BBCLASSEXTEND = "native"